1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

No start after fuel pump replaced

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Y2kbaja, Oct 28, 2020.

  1. Oct 28, 2020 at 11:11 AM
    #1
    Y2kbaja

    Y2kbaja [OP] Well-Known Member

    Joined:
    Jun 11, 2013
    Member:
    #106028
    Messages:
    702
    Gender:
    Male
    Sacramento
    Vehicle:
    05 Total Chaos Tacoma
    Total Chaos
    Need some help. 2005, I replaced the fuel pump and now truck won’t start. Cranks but no start. I pulled the relay and “discharged” the system per the repair manual prior to removing. Pump is new Toyota pump. Relay is plugged back in. Connector on top of the pump broke the retainer on removal but I’m sure, triple sure, it’s plugged in.
    is there a way to “prime” the pump?
    This was a royal pain in the ass job and I’d rather not pull the tank again. thanks in advance for the help. I’d call my work (Toyota dealer) but I called in sick to finish this repair.
     
  2. Oct 28, 2020 at 11:15 AM
    #2
    IL Capo

    IL Capo Well-Known Member

    Joined:
    Nov 8, 2019
    Member:
    #310211
    Messages:
    301
    Gender:
    Male
    Sidney BC Canada
    Did it through a fault code....
     
  3. Oct 28, 2020 at 11:17 AM
    #3
    Y2kbaja

    Y2kbaja [OP] Well-Known Member

    Joined:
    Jun 11, 2013
    Member:
    #106028
    Messages:
    702
    Gender:
    Male
    Sacramento
    Vehicle:
    05 Total Chaos Tacoma
    Total Chaos
    I can pull codes but it should be 171? lean condition. Per rm that code will come on when dischargeing the system.
     
  4. Oct 28, 2020 at 11:22 AM
    #4
    CraigF

    CraigF Well-Known Member

    Joined:
    Jun 21, 2020
    Member:
    #332105
    Messages:
    118
    Gender:
    Male
    First Name:
    Craig
    Oak Grove, OR
    Vehicle:
    06 AC PR OR 4.0L
    none yet
    with the key in the Run position can you hear the pump running?
     
  5. Oct 28, 2020 at 11:24 AM
    #5
    IL Capo

    IL Capo Well-Known Member

    Joined:
    Nov 8, 2019
    Member:
    #310211
    Messages:
    301
    Gender:
    Male
    Sidney BC Canada
  6. Oct 28, 2020 at 12:27 PM
    #6
    Y2kbaja

    Y2kbaja [OP] Well-Known Member

    Joined:
    Jun 11, 2013
    Member:
    #106028
    Messages:
    702
    Gender:
    Male
    Sacramento
    Vehicle:
    05 Total Chaos Tacoma
    Total Chaos
    No fuel at either line out of the tank after cranking several minutes. Looks like I’m pulling the tank again. At least all the stupid push clip fittings are loosened.
     
  7. Oct 28, 2020 at 12:31 PM
    #7
    SR-71A

    SR-71A Define "Well-Known Member"

    Joined:
    Jun 1, 2018
    Member:
    #255145
    Messages:
    4,235
    Gender:
    Male
    First Name:
    Zack
    Southern Maine
    Vehicle:
    2012 DCSB, TX Baja Edition. Barcelona Red
    Mobtown sliders, ARB bar, Icon RXT leafs, extended & adjustable Kings, JBA UCAs, Tepui Ayer 2, dual batteries, Gen2 xrc9.5 winch, CB, GMRS, S1 ditch lights...
    Just going to through this out there...

    If the connector clip broke, then at the very least thats probably going to cause you issues down the road. If not right now
     
  8. Nov 21, 2020 at 2:27 PM
    #8
    choi0706

    choi0706 Member

    Joined:
    Nov 21, 2020
    Member:
    #347342
    Messages:
    6
    figure it out?
     
  9. Nov 21, 2020 at 6:24 PM
    #9
    Y2kbaja

    Y2kbaja [OP] Well-Known Member

    Joined:
    Jun 11, 2013
    Member:
    #106028
    Messages:
    702
    Gender:
    Male
    Sacramento
    Vehicle:
    05 Total Chaos Tacoma
    Total Chaos
    Yes. Plug into the pump wasn’t fully engaged.
     
    12TRDTacoma and hx989 like this.
  10. Nov 21, 2020 at 6:32 PM
    #10
    12TRDTacoma

    12TRDTacoma Ocean TRD

    Joined:
    Aug 20, 2012
    Member:
    #85133
    Messages:
    13,903
    Gender:
    Male
    First Name:
    Rob
    Concordia
    Vehicle:
    12 TRD Sport DCLB 4x4 Tacoma
    Supercharged
    You dodo. :rofl:

    Hey at least you found it bro. Good job.
     

Products Discussed in

To Top