1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

noise from flowmaster american thunder exhaust

Discussion in 'Performance and Tuning' started by Schuylerville, Jan 2, 2013.

  1. Jan 2, 2013 at 7:19 PM
    #1
    Schuylerville

    Schuylerville [OP] Member

    Joined:
    Dec 6, 2012
    Member:
    #92538
    Messages:
    8
    Gender:
    Male
    First Name:
    Christian
    Up state NY
    Vehicle:
    Red 2006 SR5 V6 tacoma
    K&N cool air intake, Flowmaster American thunder exhaust
    I got a flowmaster american thunder exhaust. A friend recomended it and they are very pleased with it, as iam i. Except lately, aboutt 2 months after it being professionally installed, there id a noise coming from under my passenger seat, which is where my exhaust runs under the truck. It is a rattling noise that happens only when i accelerate slowly, and my rpm's are around 1700-1900. Right before it shifts. Then the noise goes away when i rev it or completely let off the gas. Any ideas? any help is apprieciated, cannot figure this out, thanks!
     
  2. Jan 2, 2013 at 7:20 PM
    #2
    anthony250f

    anthony250f Well-Known Member

    Joined:
    Feb 18, 2012
    Member:
    #73066
    Messages:
    7,332
    Gender:
    Male
    First Name:
    Anthony
    goleta/santa barbara, ca
    Vehicle:
    97 5 speed 4x4 v6
    lt
    check the bolts, i have the same sound.
     
  3. Jan 3, 2013 at 4:40 AM
    #3
    hotrod45

    hotrod45 Well-Known Member

    Joined:
    Mar 13, 2011
    Member:
    #52916
    Messages:
    305
    Gender:
    Male
    First Name:
    paul
    sarasota fl
    Vehicle:
    09 pre runner sr5
    check the tail pipe near the rear of the leaf spring. mine is making contact there under light throttle and a right turn. fitment issue which cannot be adjusted.
     
  4. Jan 7, 2013 at 12:13 AM
    #4
    Justus

    Justus resident Apple Pie Monster

    Joined:
    Jan 4, 2013
    Member:
    #94417
    Messages:
    6,734
    Gender:
    Male
    First Name:
    Brock
    Paso Robles
    Vehicle:
    not so low, not so slow 2006 6 lug
    stockish
    Alll good suggestions......may I add 1 more?

    Mine was found while the truck was cold.....smacked the cat shield and heard the same rattle....traced it to a pebble/rock inside the cat shield.

    I also had the tail end of the pipe making contact with part of the rear frame iirc but it was only on bumps.

    The small pebble/rock incident caused an annoying rattle at low rpm tho.

    Get under the truck with a glove and start thumping on parts on the exhaust and trace the sound if possible.

    Sometimes flowmasters do rust from the inside out tho.......hopefully that's not the case for you.
     
  5. Jan 7, 2013 at 6:12 AM
    #5
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    13,599
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2007 4.0L 4x4 TRD Sport Access Cab A
    Advantage Torza top (tri-fold), Husky floor mats, RuffTuff seat covers, C2C hood struts, Homelink mirror, USA Spec PA15-Toy (120gig Classic & 8gig nano), Garmin Nuvi 660, Protecta Bed mat, Pop-n-lock, TSB Springs, Scangauge II, Heated drivers seat, Fumoto drain valve, Aries pushbar, PIAA 540 fog lights, Hood scoop grahics, Flowmaster 50 series dual catback exhaust, RainX Latitude windshield wipers, Husky rear floor liner (ontop of folded down seats). Console Vault.
    Check the bolts and ALL your clamps.

    If your setup is strictly held together with clamps (out of the box) - things may have shifted over time and are 'settling in' (so to speak).

    I had mine welded at the clamps after we installed it.
     
  6. Jan 7, 2013 at 6:14 AM
    #6
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    13,599
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2007 4.0L 4x4 TRD Sport Access Cab A
    Advantage Torza top (tri-fold), Husky floor mats, RuffTuff seat covers, C2C hood struts, Homelink mirror, USA Spec PA15-Toy (120gig Classic & 8gig nano), Garmin Nuvi 660, Protecta Bed mat, Pop-n-lock, TSB Springs, Scangauge II, Heated drivers seat, Fumoto drain valve, Aries pushbar, PIAA 540 fog lights, Hood scoop grahics, Flowmaster 50 series dual catback exhaust, RainX Latitude windshield wipers, Husky rear floor liner (ontop of folded down seats). Console Vault.
    It shouldn't rust after only 2 months.

    But I will agree with you..... Mine has rusted out (holes) at the muffler out feed pipes after 4 years. This week I'm getting it removed and going back to a stock setup.
     
To Top