1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

OBX Sport Pedal Help

Discussion in '2nd Gen. Tacomas (2005-2015)' started by ProtoJ, Jan 8, 2009.

  1. Jan 8, 2009 at 8:14 PM
    #1
    ProtoJ

    ProtoJ [OP] Well-Known Member

    Joined:
    Sep 22, 2008
    Member:
    #9406
    Messages:
    141
    Gender:
    Male
    Colorado
    Vehicle:
    07 TRD Sport Double Cab, Superwhite
    Removed 2nd air fliter, AFE Pro Dry filter, Scangauge II, shorty antenna, ARE CX Topper, URD Short Throw w/ TRD Shift Knob, Toyota Chrome Exhaust tip, FJ TRD Center Caps, Westin Prerunner bar w/ Hella 500 Lights, Hardwired Garmin
    Okay, so I got the brake and clutch pedal on no problem. But I spent and hour and half trying to get the accelerator pedal on with no luck. I used soapy water, I used straight up dish soap...I even used KY Jelly! No luck. Do I just say screw it and leave the accelerator pedal cover off or does anyone have any tips they can give me to get that thing on?
     
  2. Jan 9, 2009 at 12:50 PM
    #2
    ProtoJ

    ProtoJ [OP] Well-Known Member

    Joined:
    Sep 22, 2008
    Member:
    #9406
    Messages:
    141
    Gender:
    Male
    Colorado
    Vehicle:
    07 TRD Sport Double Cab, Superwhite
    Removed 2nd air fliter, AFE Pro Dry filter, Scangauge II, shorty antenna, ARE CX Topper, URD Short Throw w/ TRD Shift Knob, Toyota Chrome Exhaust tip, FJ TRD Center Caps, Westin Prerunner bar w/ Hella 500 Lights, Hardwired Garmin

    I figured it out myself. I used a short handled flat head screwdriver to pry the rubber open around the accelerator pedal. These pedals are really a pain in the #@#@$, but they look great and feel pretty good too. The are all very firmly seated around the pedals.
     
  3. Jan 9, 2009 at 1:25 PM
    #3
    longbow

    longbow I see you now..................

    Joined:
    Jun 26, 2008
    Member:
    #7586
    Messages:
    4,041
    Gender:
    Male
    First Name:
    Bill
    Indiana
    Vehicle:
    05 Tacoma Silver Mica TRD 4 Door
    Toy-tec Coil over lift, Eibach 700 lb springs, Sway bar relocate, Total Chaos UCA's, Moto metal wheels, BFG mudterrians, HID, custom 3 piece grill, Highlift jack w/custom mount, Highlift jack cover, bed matt, de-badged 100%, storage box lock mod, using defrost w/o AC mod, short antenna mod, horn re-locate, Tire Gate flat spare tire mount, engine cover painted, bed light (1) mod, wreck bar carrier, Blue Sea 5026 fuse block, center console outlet, flash light mod, Blue Sea inline fuse, Shrockworks sliders, All-Pro front bumper, Piaa 510 driving lights, Warn shackles front, Kennesaw rear bumper, "Tag Boltz" plate lights, Warn shackles rear, Warn M8000 winch, devil horns, BHLM, weathech liners front and rear.....T.W. sticker of course. Custom Sock bed decal for Michele
    I had the same issue, use soap, and the screwdriver, but I also used a hairdryer to warm them up a little. A pain, yes it was, but they went on.

    Good luck! :)
     
To Top