1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

OEM Running Boards installed on Base/Access Cab

Discussion in '2nd Gen. Tacomas (2005-2015)' started by HogTaco, Jan 27, 2011.

  1. Jan 27, 2011 at 10:14 AM
    #1
    HogTaco

    HogTaco [OP] Well-Known Member

    Joined:
    Dec 29, 2010
    Member:
    #48388
    Messages:
    47
    Gender:
    Male
    Northwest Arkansas
    Vehicle:
    2011 Access Cab 2.7 2WD AT
    Bed Mat, OEM Running Boards, Ultra-Gauge.
    Installed these over the weekend. Easy to do. Six bolts per side, and they come pretreated with blue Loctite. I did use a torque wrench. :D I think it balances the look of the truck nicely. Thought about tube steps, but those would look silly on a base model, I think. I primarily wanted them to knock mud off my boots before getting in the truck. They allegedly protect you from door dings, too.

    rb.jpg
     
  2. Jan 27, 2011 at 10:19 AM
    #2
    BryWi

    BryWi Psalm 109:8

    Joined:
    Dec 5, 2010
    Member:
    #47177
    Messages:
    1,769
    Gender:
    Male
    Earth
    Vehicle:
    2011 TRD off-road DC SB w/JBL
    5100s, black valance
    x2

    I've got them, too. Exact same reasons as you cited. They also will not rust or chip.

    I am not a tube step guy on any model Taco. But to each his own...
     
  3. Jan 27, 2011 at 11:17 AM
    #3
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    14,256
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2016 GMC Canyon SLT w/ LineX and....
To Top