1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

OME 886s and Nitros

Discussion in '2nd Gen. Tacomas (2005-2015)' started by iRunUphill, Nov 18, 2012.

  1. Nov 18, 2012 at 6:17 PM
    #1
    iRunUphill

    iRunUphill [OP] New Member

    Joined:
    Nov 18, 2012
    Member:
    #91404
    Messages:
    2
    Gender:
    Male
    First Name:
    Steve
    Vernon, BC
    Vehicle:
    09 DCLB TRD Sport
    ARB bumper T-Max 8500 winch OME HD front end Ride Rite airbags Canopy Yakima roof rack Loadwarrier basket
    So, I recently installed an ARB bumper and M9000 winch on my 09 DCLB Tacoma. Then I had the recommended OME 886 coils and Nitrochargers installed to give the front end the support it needs. Not sure what other people are finding with this set up, but it seems very harsh to me. I drove it offroad today and it was rough, particularly on washboard. I'm also noticing a lot of clunking on small sharp bumps and on the backsides of speedbumps. Sounds like something is loose down there.

    Anybody have any suggestions, advice, experiences with this situation. I'm thinking I chose the wrong springs. Anybody running a heavy plate bumper and winch using the 885 coils.

    Thanks in advance for the help.

    Steve
     
  2. Nov 18, 2012 at 6:19 PM
    #2
    Pugga

    Pugga Pasti-Dip Free Since 1983

    Joined:
    Jun 18, 2010
    Member:
    #39131
    Messages:
    28,978
    Gender:
    Male
    First Name:
    Mike
    Massachusetts
    Vehicle:
    '13 Ford F-150 SCREW
    F-150 Mod
    What bumper are you running?
     
  3. Nov 18, 2012 at 6:31 PM
    #3
    hard2kill

    hard2kill Well-Known Member

    Joined:
    Apr 28, 2011
    Member:
    #55714
    Messages:
    3,860
    Gender:
    Male
    First Name:
    John
    Rhinebeck NY
    Vehicle:
    06 4door trd sport white 6spd
    ...315's,2in bora wheel spacers,safari snorkel,wheel spacers,bruteforcefab rear bumper and sliders,afe filter,hi-lift jack,5100 with OME 886 & 1/2in spacer,allpro expo's,icon 10in rear shox,flip kit,ss brake lines,cobra cb,fog light mod,yellow fogs,weathertech mats,fullsize spare tire and extra sport rim,tinted windows,aeroturbine 2525 muffler dumped over axle...rear diff breather mod...removed factory spare...removed 2nd air filter...THULE roof rack and fairing....bud builts front to back,allpoo front bumper,BAMF lca skids,overland Offroad roof and bed racks,
    Not sure why that would be? I have 886's with a 1/2in top plate spacer and I wish mine were alittle stiffer yet...885's I had couldn't support the weight of bumper and skids much less the winch I have now
     
  4. Nov 18, 2012 at 6:32 PM
    #4
    Large

    Large Red

    Joined:
    Sep 10, 2011
    Member:
    #63268
    Messages:
    16,045
    Gender:
    Male
    Mine works fine. I would look in to the steering TSB for the clunk / rattle.
     
  5. Nov 18, 2012 at 8:04 PM
    #5
    iRunUphill

    iRunUphill [OP] New Member

    Joined:
    Nov 18, 2012
    Member:
    #91404
    Messages:
    2
    Gender:
    Male
    First Name:
    Steve
    Vernon, BC
    Vehicle:
    09 DCLB TRD Sport
    ARB bumper T-Max 8500 winch OME HD front end Ride Rite airbags Canopy Yakima roof rack Loadwarrier basket
    Pugga, I'm running the Deluxe Winch Bumper. I did notice the clunking more on the driver's side. I'll have a look at the TSB.
     
To Top