1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Ottonovi should be named oughtto know better

Discussion in 'Audio & Video' started by abrg, Dec 8, 2012.

  1. Dec 8, 2012 at 3:06 PM
    #1
    abrg

    abrg [OP] Member

    Joined:
    Dec 8, 2012
    Member:
    #92663
    Messages:
    22
    Gender:
    Male
    I got this new Ottonavi in October around the 26th 2012, and immediately had problems with GPS not finding the software I accidentally touched the SD card while trying to turn it off with knob while driving and it was so hot it blistered my finger.
    I contacted Ottonavi thru email the following Monday after about a week with no response back I took the time off to call .
    I had decided I would take the restock fee loss and call it quits since I had already got one and returned it to Amazon prior to this one Amazon accepted it back but it was not in stock and could not get a replacement and I got the impression they would not be getting them in again..
    I called Ottonavi they said first to try making a new map the original sd card was probably bad they sent a link that took 2 days to download a new map their server is very slow like dial up speed. I have 10 gig download speed .
    I made a new SD card map installed it and despite not being able to get the radio time and the GPS time in sync when the GPS displayed 12 hour with am and pm the radio displayed military 24 hour time and vice versa could not get them to sync.
    Despite that it seemed to work ok in my driveway I was never quite sure since there were no instructions with it for install and the so called user manual was so poorly translated to English to read it and make sense of it besides being vague and it skipped around as if you are supposed to know how their unit is supposed to work it left me wondering WTF.
    There were some wires labeled Speed I called Ottonavi support 2 times and neither guy that answered who barely spoke english could not tell me what they were for.
    Then it messed up again so I contacted them wanting to return it for refund well it had gone past the 30 day after they jerked me around for almost 2 weeks now they will not accept it back for refund I am thinking attorney general route, and will only exchange it.
    I returned it have proof of delivery was promised they would ship out a brand new unit the same day they get the old one back on their web page their policy is to ship a brand new unit when replacing , and promised to send the same day and provide tracking number when it shipped which I have not received and was promised again yesterday it would ship yesterday.
    One other very annoying thing about it is that even the low setting for screen back light it is way too bright at night, makes it a bit dangerous, also there are listed choices of backgrounds and voices that do not have any program to operate it.
    The key chime and door chime sound is very loud and I can't find a volume for it, like a sonar in a submarine real cheesy ear piercing crawl up your spine terrible noise and a very loud clock tic sound when turn signal is on, if I ever get one back I will relocate the speaker for it to some remote corner under the dash. Need I say I very much feel jerked around by Ottonavi just to get it out of refund period I clearly said I wanted to return it for refund the first time I called in and emailed because of my prior experience with one I got from Amazon and their lack of response? I have regrets of ever getting this unit.:mad: Just in case I ever do get the replacement does anyone know what the red speed wires are for and if there is a volume control for the door chime it does not use the factory chime and I do want it to chime in case I leave the lights on or something.
     
  2. Dec 8, 2012 at 3:17 PM
    #2
    Rich91710

    Rich91710 Well-Known Member

    Joined:
    Feb 23, 2012
    Member:
    #73470
    Messages:
    16,493
    Gender:
    Male
    First Name:
    Rich
    Los Angeles
    Vehicle:
    08 Base
    Satoshi with FJ badge, factory cruise, factory intermittent wipers, Redline Tuning hood-lift struts, Hellwig Swaybar, Rosen DVD-Nav
    Different units are.... different.

    I have the Rosen (Caska hardware, Rosen software) and the entertainment system does NOT automatically pull it's time from the GPS receiver.
    The two programs are 100% separate and isolated apps.
     
  3. Dec 9, 2012 at 4:27 AM
    #3
    abrg

    abrg [OP] Member

    Joined:
    Dec 8, 2012
    Member:
    #92663
    Messages:
    22
    Gender:
    Male
    when ever I set the radio time to display correctly the GPS would go to 24 hr if I got the gps time to display 12 hr with am pm the display in the radio changed to 24 hr with no good instructions I do not know how yet if it will .
    I will try to if I ever get it back to seperate and I was not able to find a different radio time setting one always effected the other. The thing really had no central time US setting I found yet whenever I selected what I think is central time us and canada the small bar that displayed time zones only had a limited amount of text it displays it could be central America does not display much it always switches back on it's own to International Time after saving I am about to bite the bullet and buy factory systemor trade the vehicle offtired of all the wires danglind around .:confused:
     
  4. Dec 9, 2012 at 5:16 AM
    #4
    fau8823

    fau8823 Well-Known Member

    Joined:
    Mar 8, 2010
    Member:
    #32771
    Messages:
    271
    Gender:
    Male
    First Name:
    Tom
    Hampton Roads, VA
    Vehicle:
    2010 Tacoma Sport 4x4
    Tint-20%, Kenwood 2 meter radio, firestik 2 meter antenna on a BAMF tailgate mount, Extang Solid Fold , Pioneer bhs-3500 HU, clazzio leather seats, Scangauge II
    Wow. Sorry about your luck man. Anyone else having these issues? I was seriously considering this unit. Lemon, or common problems?
     
  5. Dec 10, 2012 at 10:04 AM
    #5
    abrg

    abrg [OP] Member

    Joined:
    Dec 8, 2012
    Member:
    #92663
    Messages:
    22
    Gender:
    Male
    So this is Monday I emailed them asking about my replacement about them saying they would ship last Friday waited half the day no response so I called on the phone said I was promised it would go out Friday and I would get a tracking number I did not get a tracking number
    Today they say it will ship tomorrow because they are out of stock but Friday I was promised it would go out was ready and waiting on UPS, they say they are out of stock because of a strike at the port I a not real happy now.
    I am starting the process to protest the charge on the credit card and filing a complaint with the Attorney General there and here and the Better Business Bureau and every forum I can find , Wednesday if I do not have tracking info tomorrow BEWARE THEY CAN DANCE.

    :mad::(:sadviolin::sadviolin:
     
  6. Dec 10, 2012 at 10:38 AM
    #6
    abrg

    abrg [OP] Member

    Joined:
    Dec 8, 2012
    Member:
    #92663
    Messages:
    22
    Gender:
    Male
    oh yeah they expected me to be comforted by telling me I was not the only customer waiting keep this in mind:rolleyes:
     
  7. Dec 11, 2012 at 2:03 PM
    #7
    abrg

    abrg [OP] Member

    Joined:
    Dec 8, 2012
    Member:
    #92663
    Messages:
    22
    Gender:
    Male
    no shipment yet I called no one there could find anything about my order for 20 minutes on hold then after I told them the return tracking number and had several copies of their emails with the managers name that they have promised me in the emails I got another promise I was again promised it will ship you can't make this crap up. Funny thing is the guy I talked to today was shocked to hear the other guy said they were out of stock so maybe they were not.
     
  8. Dec 11, 2012 at 4:19 PM
    #8
    Aw9d

    Aw9d That one guy

    Joined:
    Nov 7, 2011
    Member:
    #66635
    Messages:
    12,087
    Gender:
    Male
    Common issues. A buddy had one of these for about 5 months before he ditched it. Great idea, just seems like it was built with the cheapest parts made known to man.

    Good luck OP! I know for a fact the company is hard to deal with.
     
  9. Dec 12, 2012 at 7:12 AM
    #9
    abrg

    abrg [OP] Member

    Joined:
    Dec 8, 2012
    Member:
    #92663
    Messages:
    22
    Gender:
    Male
    The company seems to be a small rag tag operation with a small inventory with 3 or 4 different people who do not speak English very well, and have poor record keeping and inner office/shipping communication they do answer the phone well enough and seems like they want to help with tech support or they just want to say anything and get you off the phone cause most things they say do not work, they just have not had anyone answer for me that knew much and spoke English very well, but often I have been on hold for 20 minutes at a time while they try to find the info.
    I have a shipment notification I think they are tired of me calling and have shipped it 2 day air back to me but it only took 3 days when they first used UPS for the other 2.
    I do have to sign for it so I will have to be here or get someone to hang out till it gets delivered though.
    I guess that is just a little last vendetta on their part UPS would have a record of delivery regardless we are rural not like we have a lot of thieves in these parts and the UPS driver knows the hidden place to put stuff here he hunts on my property.
    Looking them up on Google earth and Google Maps they appear to have a small office in the back of a bigger Company that sells pipe threading tools.
     
  10. Dec 12, 2012 at 6:59 PM
    #10
    Rich91710

    Rich91710 Well-Known Member

    Joined:
    Feb 23, 2012
    Member:
    #73470
    Messages:
    16,493
    Gender:
    Male
    First Name:
    Rich
    Los Angeles
    Vehicle:
    08 Base
    Satoshi with FJ badge, factory cruise, factory intermittent wipers, Redline Tuning hood-lift struts, Hellwig Swaybar, Rosen DVD-Nav
    Ottonavi is a vendor here.
    You need to get the moderators involved.
     
  11. Dec 13, 2012 at 9:54 AM
    #11
    abrg

    abrg [OP] Member

    Joined:
    Dec 8, 2012
    Member:
    #92663
    Messages:
    22
    Gender:
    Male
    Ok I got the replacement today at Ottonavi they promised to include a new rear camera for my trouble but did not get it; it seems to work ok with one exception in the driveway.
    I have not yet driven it yet I am waiting for their tech support to get one out and see if they can figure out how to set the time on it. I set the time on it where the sort of owner’s operators manual that comes with it says to set it and it displays the time there correctly but then when I go to the radio it is 12 hours off. GPS isn’t even on a time zone of this planet I think.
    I cannot find any other place to set the time so their tech support guy is supposed to be getting one out and trying to figure it out at Ottonavi.
    They say on their web page you get a brand new unit, if you have a defective unit and they send a replacement. I do not think this one is “BRAND NEW” there is wear signs on the knobs kind of like looking at a used car in the old days before digital odometers and states keeping track of mileage on titles you always looked at the wear on the pedals and carpet to see if it looks like it only had low mileage wear on it, so the touch screen had finger smudges on the screen under the sticky clear cover they put over screen for shipping.
    I read Chinese companies will recycle parts and claim it as new. I can’t say that happened but it is in my mind, and I do not think anyone could convince me otherwise but if I can get the time set I will be happy if it continues to work.
     
  12. Dec 13, 2012 at 11:37 AM
    #12
    abrg

    abrg [OP] Member

    Joined:
    Dec 8, 2012
    Member:
    #92663
    Messages:
    22
    Gender:
    Male
    Another follow up I have it set up the tech guy never called back. I called back and if you ever need tech help there ask for Jose Sanchez he got me lined out, he actually did something, he understood the problem which is because there is lousy instructions manual included that is a joke, he helped with a link to a video they have made up for technical help they posted on You tube :D
     
  13. Dec 14, 2012 at 5:23 AM
    #13
    abrg

    abrg [OP] Member

    Joined:
    Dec 8, 2012
    Member:
    #92663
    Messages:
    22
    Gender:
    Male
    I was looking over the correspondence to Ottonavi I have 28 recent emails back and forth with them to get this replaced and 12 the month before with about as many phone calls
     
  14. Dec 19, 2012 at 1:45 PM
    #14
    abrg

    abrg [OP] Member

    Joined:
    Dec 8, 2012
    Member:
    #92663
    Messages:
    22
    Gender:
    Male
    SO I GOT THE NEWEST ONE OFF THE BOAT FROM CHINA IT JUST ARRIVED A NEW BATCH TO THE US AND THEY SHIPPED ONE OUT FAST IT HAD ISSUES RIGHT OFF FROM WHEN I FIRST TURNED IT ON AND THE GUYS AT OTTONAVI DID HELP A LOT AND EMAILED A PATCH FOR THE MAP THAT I HAD TO DELETE FILES OFF THE SD CARD ON MY COMPUTER AND REPLACE THEM WITH THE ONES THEY SENT THAT FIXED THAT PROBLEM BUT THIS UNIT CANNOT BE SET TO 12 HOUR TIME WITH AM AND PM ON THE RADIO IT JUST DISPLAYS MILITARY TIME . OTTONAVI EMAILED THE MANUFACTURER YESTERDAY THEY TOLD ME ABOUT THIS AND PROMISED TO EMAIL ME WHEN THEY FIND SOMETHING OUT. THIS REALLY HAS NOT BEEN PLUG AND PLAY AND SOON IT MAY FIND A TARGET TAPED TO IT.
     
  15. Jan 4, 2013 at 8:46 AM
    #15
    abrg

    abrg [OP] Member

    Joined:
    Dec 8, 2012
    Member:
    #92663
    Messages:
    22
    Gender:
    Male
    well I still have not received any software update for the software bug the one they sent the last time created an entirely new problem and they were supposed to fix this which I was promised I would get , apparently they are not attempting to fix the bug in the software or lack the intelligence to do it. This is pretty much a bust all around so beware of you are considering one of these units I am seriously considering the trash can for this might mount it in the cuddy of my boat use it to watch movies on sleep over nights I would not sell it unless I disclosed all the issues and who would want it so it is basically trash wasted time and money
     
  16. Jan 30, 2013 at 5:40 AM
    #16
    abrg

    abrg [OP] Member

    Joined:
    Dec 8, 2012
    Member:
    #92663
    Messages:
    22
    Gender:
    Male
    Still no software update on 1-30-13 but I am awaiting another replacement unit they were supposed to have sent but did 2 days after they said they did the one I now have just about quit receiving radio all together very poor progressively getting worse reception so I started using my iphone awaiting a delivery of an antenna booster ,which this unit it got to where it quit working with the iphone too so again I have another failed unit .This is number 4 coming . I cannot believe the problems with this . I have a very cheap aftermarket I think it is an OUKU or something it cost about 169 brand new is a few years old and it works circles around this one in my other truck. The only thing is it is not a factory look it is 7 inch and a motorized front that tilts out to put a cd in .
     
  17. Feb 6, 2013 at 5:39 AM
    #17
    abrg

    abrg [OP] Member

    Joined:
    Dec 8, 2012
    Member:
    #92663
    Messages:
    22
    Gender:
    Male
    well unit number four has arrived and the problem with radio reception is gone will stream music from Iphone with bluetooth however this one has a problem with GPS navigation. Problems right off with that they sent a download for a different map but it is cheesy plain jane does not show anything other than the direction and does have a small arrow indication where to turn, but the print is tiny and very difficult to read . I am convinced they do not have any thta works as describedall four has had issues one way or the other not what a new system should do
     
  18. Feb 6, 2013 at 6:06 AM
    #18
    fletch97

    fletch97 Professional Window Licker

    Joined:
    Oct 18, 2012
    Member:
    #89248
    Messages:
    259
    Gender:
    Male
    First Name:
    Steve
    NJ
    Vehicle:
    2013 Tacoma SR5
    Wow!!

    Just take a sledge hammer to it already and mail it back to them.

    Go get yourself something better from Alpine, Kenwood or Pioneer.

    Good Luck and post any pics when you finally decide to destroy it!
     
  19. Feb 6, 2013 at 5:10 PM
    #19
    Justroc

    Justroc Active Member

    Joined:
    Jan 2, 2013
    Member:
    #94232
    Messages:
    40
    Gender:
    Male
    First Name:
    Justin
    Southern Ontario
    Vehicle:
    2011 Tacoma TRD DCLB
    Smittybilt Nerf Bars Blacked out Emblems K&N Air Intake Flowmaster Dual Exhasut Total Chaos UCA OME Full 3" Lift Dakar Rear Leaf Pack 275/70/17 General Grabber AT2
    Thank god I stumbled across this thread, was seriously considering and narrowed my options down to the OttoNavi unit. This has stopped my purchase hands down, and thankfully the unit is currently out of stock, or else it would have been ordered already.
    Thanks for the notice.
     
  20. Feb 6, 2013 at 7:16 PM
    #20
    Rich91710

    Rich91710 Well-Known Member

    Joined:
    Feb 23, 2012
    Member:
    #73470
    Messages:
    16,493
    Gender:
    Male
    First Name:
    Rich
    Los Angeles
    Vehicle:
    08 Base
    Satoshi with FJ badge, factory cruise, factory intermittent wipers, Redline Tuning hood-lift struts, Hellwig Swaybar, Rosen DVD-Nav
    I'm pushing a year with my Rosen/Caska unit and it's starting to give me issues with the touch screen sticking in areas that it hasn't been pressed. Sometimes wiping it off with microfiber clears it, other times not, but I'm getting ready to pitch it and move up to a Kenwood or Alpine.
     
To Top