1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Overhead console

Discussion in '2nd Gen. Tacomas (2005-2015)' started by webfishn2, Apr 29, 2011.

  1. Apr 29, 2011 at 12:23 PM
    #1
    webfishn2

    webfishn2 [OP] New Member

    Joined:
    Apr 29, 2011
    Member:
    #55761
    Messages:
    2
    Gender:
    Male
    Vehicle:
    05 TRD Double cab
    Anybody experienced a problem with the overhead console temp and compass "going blank?" Mine is that way now on an 05 Double Cab.
     
  2. Apr 29, 2011 at 12:28 PM
    #2
    Hunter500ky

    Hunter500ky Well-Known Member

    Joined:
    Dec 2, 2010
    Member:
    #47031
    Messages:
    2,523
    Gender:
    Male
    E-Town Ky
    Vehicle:
    06 Tacoma 4x4 SR5
    Weathertech Mats, Toolbox, 6k HID fogs, Hardwire Escort 8500 x50,
  3. Apr 29, 2011 at 12:28 PM
    #3
    TerryS

    TerryS Well-Known Member

    Joined:
    Aug 26, 2010
    Member:
    #42275
    Messages:
    250
    Gender:
    Male
    First Name:
    Terry
    Cape Cod, Mass.
    Vehicle:
    '10 SR5 AC 4x4
    WeatherTech floor liners and wind deflectors; shorty antenna; OEM tow hitch & wiring; bed mat; accessory meter console w/temp & compass; 4WD switch lighting mod; Viper 5301 Remote Start; TRD front tow hook and aluminum skid plate; color matched door handles & grille; FJ fog light switch with on/off indicator light; fog light anytime mod; N-Fab steps; Extang tonneau; Blu-Logic bluetooth, and; TRD OR alloy wheels.
  4. Apr 29, 2011 at 12:28 PM
    #4
    Toolex

    Toolex Member

    Joined:
    Jun 25, 2009
    Member:
    #18914
    Messages:
    22
    Gender:
    Male
    ya theres a chip on the circuit board that comes lose. You need to pull the console off, which is very easy (one screw i think), then look at the board and you should see one of the small chips has come off the board. sodder it back together. There should be a thread with pics if you search.
     
  5. Apr 29, 2011 at 12:56 PM
    #5
    sam_i02

    sam_i02 Well-Known Member

    Joined:
    Mar 15, 2010
    Member:
    #33304
    Messages:
    144
    Gender:
    Male
    First Name:
    Samir
    Kanata, Ontario
    Vehicle:
    05 PreRunner AccessCab
    BHLM, Satoshi grill, D-rings, Relentless Fab recovery shackle, DRL, Firestone RideRite airbags, WO seatcovers, added temp gauge, custom interior lights.
    not hard to do if you (or a friend) have used a soldering iron before
     
  6. Apr 29, 2011 at 12:58 PM
    #6
    Sleeper362

    Sleeper362 One Convenient Locations ......In Africa

    Joined:
    Mar 20, 2011
    Member:
    #53374
    Messages:
    647
    Gender:
    Male
    First Name:
    Corporal
    K-Vegas NC
    Vehicle:
    06 SR5 4X4 DC Shortbed
    Can you retro fit one of these overhead consoles into a truck that doesn't have one fairly easily? Forgive my lazyness. When I search all I get are fix threads not install threads.
     
  7. Apr 29, 2011 at 1:04 PM
    #7
    TerryS

    TerryS Well-Known Member

    Joined:
    Aug 26, 2010
    Member:
    #42275
    Messages:
    250
    Gender:
    Male
    First Name:
    Terry
    Cape Cod, Mass.
    Vehicle:
    '10 SR5 AC 4x4
    WeatherTech floor liners and wind deflectors; shorty antenna; OEM tow hitch & wiring; bed mat; accessory meter console w/temp & compass; 4WD switch lighting mod; Viper 5301 Remote Start; TRD front tow hook and aluminum skid plate; color matched door handles & grille; FJ fog light switch with on/off indicator light; fog light anytime mod; N-Fab steps; Extang tonneau; Blu-Logic bluetooth, and; TRD OR alloy wheels.
    Yes, probably. I was able to do it and in my case, the wiring and temperature sensor were already there, so it was a 5 minute plug-in job. The console is hard to find used and expensive though.
     
  8. Apr 29, 2011 at 1:05 PM
    #8
    Normco

    Normco Member

    Joined:
    Feb 27, 2011
    Member:
    #51970
    Messages:
    10
    Gender:
    Male
    First Name:
    Norm
    Spokane
    Vehicle:
    2011 Tacoma
    4WD indicator led, Intermittant wiper, Cruise control, Gentex temp/Compass mirror, TracRac, WeatherTec Power mirrors
    I tried this and decided it was not worth it. For a LOT less money and a LOT less hassle, you can get a Gentex mirror. Install was a breeze. Hardest part was getting the wire from the sensor through the firewall grommet.
    And...I still have the hidey-hole in the console for the G-door opener.

    If you do decide to do it, be sure to check the pins on the plug in the overhead. There are two kinds, 5-pin and 8-pin. You want to make sure your display unit matches. They are NOT plug-and-play compatible.

    Gentex.JPG
     
  9. Apr 29, 2011 at 1:14 PM
    #9
    TerryS

    TerryS Well-Known Member

    Joined:
    Aug 26, 2010
    Member:
    #42275
    Messages:
    250
    Gender:
    Male
    First Name:
    Terry
    Cape Cod, Mass.
    Vehicle:
    '10 SR5 AC 4x4
    WeatherTech floor liners and wind deflectors; shorty antenna; OEM tow hitch & wiring; bed mat; accessory meter console w/temp & compass; 4WD switch lighting mod; Viper 5301 Remote Start; TRD front tow hook and aluminum skid plate; color matched door handles & grille; FJ fog light switch with on/off indicator light; fog light anytime mod; N-Fab steps; Extang tonneau; Blu-Logic bluetooth, and; TRD OR alloy wheels.
    Well, it's another way, I don't know whether it's necessarily better. :rolleyes:
     
  10. Apr 29, 2011 at 1:26 PM
    #10
    Normco

    Normco Member

    Joined:
    Feb 27, 2011
    Member:
    #51970
    Messages:
    10
    Gender:
    Male
    First Name:
    Norm
    Spokane
    Vehicle:
    2011 Tacoma
    4WD indicator led, Intermittant wiper, Cruise control, Gentex temp/Compass mirror, TracRac, WeatherTec Power mirrors
    The console display is a good-looking unit, and my first choice. I went with the Gentex because I couldn't find all the necessary parts for less than an arm and a leg.

     
  11. Apr 29, 2011 at 1:33 PM
    #11
    TerryS

    TerryS Well-Known Member

    Joined:
    Aug 26, 2010
    Member:
    #42275
    Messages:
    250
    Gender:
    Male
    First Name:
    Terry
    Cape Cod, Mass.
    Vehicle:
    '10 SR5 AC 4x4
    WeatherTech floor liners and wind deflectors; shorty antenna; OEM tow hitch & wiring; bed mat; accessory meter console w/temp & compass; 4WD switch lighting mod; Viper 5301 Remote Start; TRD front tow hook and aluminum skid plate; color matched door handles & grille; FJ fog light switch with on/off indicator light; fog light anytime mod; N-Fab steps; Extang tonneau; Blu-Logic bluetooth, and; TRD OR alloy wheels.
    It wasn't a bad choice, Norm. Tell me though, did you have to give anything up, like the backup screen or auto dimming?
     
  12. Apr 29, 2011 at 1:36 PM
    #12
    North Star

    North Star Well-Known Member

    Joined:
    Apr 12, 2011
    Member:
    #54778
    Messages:
    1,073
    Gender:
    Male
    Southern California
    Vehicle:
    07' Double Cab 4x4
    N-fab side steps, Extang hard tonneau cover, Terra Grappelers
    Take it to the dealership. They'll help you out. :boink:
     
  13. Apr 29, 2011 at 1:50 PM
    #13
    Normco

    Normco Member

    Joined:
    Feb 27, 2011
    Member:
    #51970
    Messages:
    10
    Gender:
    Male
    First Name:
    Norm
    Spokane
    Vehicle:
    2011 Tacoma
    4WD indicator led, Intermittant wiper, Cruise control, Gentex temp/Compass mirror, TracRac, WeatherTec Power mirrors
    Didn't give up anything. My truck was a base model Access Cab. No camera, no auto dim. I gained the auto dim, and the temp/compass.

    So... if you have the same set-up I had....

     
  14. Apr 29, 2011 at 2:12 PM
    #14
    TerryS

    TerryS Well-Known Member

    Joined:
    Aug 26, 2010
    Member:
    #42275
    Messages:
    250
    Gender:
    Male
    First Name:
    Terry
    Cape Cod, Mass.
    Vehicle:
    '10 SR5 AC 4x4
    WeatherTech floor liners and wind deflectors; shorty antenna; OEM tow hitch & wiring; bed mat; accessory meter console w/temp & compass; 4WD switch lighting mod; Viper 5301 Remote Start; TRD front tow hook and aluminum skid plate; color matched door handles & grille; FJ fog light switch with on/off indicator light; fog light anytime mod; N-Fab steps; Extang tonneau; Blu-Logic bluetooth, and; TRD OR alloy wheels.
    LOL, I might have gone your route, Norm, but we'll never know. As I said before, yours wasn't a bad choice.

    Sorry for the hijack, OP. Hope you found the answers you were looking for.
     
  15. Apr 29, 2011 at 2:54 PM
    #15
    MountainEarth

    MountainEarth Well-Known Member

    Joined:
    Feb 1, 2010
    Member:
    #30519
    Messages:
    2,494
    Gender:
    Male
    First Name:
    Bryan
    CO
    Vehicle:
    2010 TRD OR Access
    Leer 100XR Shell, BedRug mat - comfy sleeping, GT Covers microfiber seat covers, BFG All Terrains 265/70r16, Dashmat, Antennax 13" shorty antenna, Weathertech liners, Ultra Gauge, Avid Light Bar, PIAA 520 ATPs, one old dog
    My understanding is that 2009 and up use a different plug than 05-08. So if you're a 2006, don't get a 2009 - 11 console as it won't work.

    As for the blank console, yeah it's an easy and quick solder fix. In fact this problem apparently is so prevalent on the 05-06 consoles, there are people on Ebay who sell the service of a resolder .. send it to them & they'll do it for you for like $30. But you can easily do it yourself.
     
  16. Apr 29, 2011 at 7:12 PM
    #16
    maxpower29

    maxpower29 Well-Known Member

    Joined:
    Mar 7, 2011
    Member:
    #52525
    Messages:
    5,899
    Gender:
    Male
    First Name:
    Jordan
    Nova Scotia, Canada
    Vehicle:
    2011 Tacoma 4x4 2.7 5 speed SWB
    All season mats, 2nd filter delete, DT header, Jardine cat-back, URD shifter, Bilstein 5100's all around at .85 front with Eibachs + .25 passenger/.5 drivers spacers and 1.5 AAL, 0w20 synthetic, Scanguage II, extra D rings, OEM backup camera+Mirror, bed mat, Extang Solid Fold, Popnlock 5300, Pro Comp 7089's 4.5bs 285/70/17 Revo 2s, De-badged
    how do you know if the wiring is already there? Any tips on how to do this or where to buy?
     
  17. May 1, 2011 at 6:43 AM
    #17
    webfishn2

    webfishn2 [OP] New Member

    Joined:
    Apr 29, 2011
    Member:
    #55761
    Messages:
    2
    Gender:
    Male
    Vehicle:
    05 TRD Double cab
    Thanks for the advice and fix!
     
  18. May 1, 2011 at 7:08 AM
    #18
    TerryS

    TerryS Well-Known Member

    Joined:
    Aug 26, 2010
    Member:
    #42275
    Messages:
    250
    Gender:
    Male
    First Name:
    Terry
    Cape Cod, Mass.
    Vehicle:
    '10 SR5 AC 4x4
    WeatherTech floor liners and wind deflectors; shorty antenna; OEM tow hitch & wiring; bed mat; accessory meter console w/temp & compass; 4WD switch lighting mod; Viper 5301 Remote Start; TRD front tow hook and aluminum skid plate; color matched door handles & grille; FJ fog light switch with on/off indicator light; fog light anytime mod; N-Fab steps; Extang tonneau; Blu-Logic bluetooth, and; TRD OR alloy wheels.
    Jordan,

    Here's a link to a thread that will help you and answer your questions. There are also others, but I didn't bookmark them:

    http://www.tacomaworld.com/forum/2n...stall-overhead-compass-temperature-gauge.html

    If you find that the wiring is there, it's dead simple to do. After viewing the thread, if you find the wiring is there, but not the temperature sensor, give me a shout as I have an extra sensor.

    Finding the console is not so easy. You'll need one from a '09, '10 or '11. Older models won't work in your '11. I suggest that you keep an eye on eBay and the buy/sell section here (where I found mine). You could also buy it new and junk yards are always a possiblity. Remember that Toyota calls it an "Accessory Meter".

    Good luck!
     
  19. May 1, 2011 at 10:58 AM
    #19
    maxpower29

    maxpower29 Well-Known Member

    Joined:
    Mar 7, 2011
    Member:
    #52525
    Messages:
    5,899
    Gender:
    Male
    First Name:
    Jordan
    Nova Scotia, Canada
    Vehicle:
    2011 Tacoma 4x4 2.7 5 speed SWB
    All season mats, 2nd filter delete, DT header, Jardine cat-back, URD shifter, Bilstein 5100's all around at .85 front with Eibachs + .25 passenger/.5 drivers spacers and 1.5 AAL, 0w20 synthetic, Scanguage II, extra D rings, OEM backup camera+Mirror, bed mat, Extang Solid Fold, Popnlock 5300, Pro Comp 7089's 4.5bs 285/70/17 Revo 2s, De-badged
    Alright, I checked and there are 2 wires going to that place. One is the light, and the other I THOUGHT was for a garage door opener? Maybe I was wrong. I will take a pic soon and see if you can tell. I hope its it. I really want this mod. My favourite part about modding vehicles is getting all the OEM mods. Love it
     
  20. May 1, 2011 at 11:55 AM
    #20
    maxpower29

    maxpower29 Well-Known Member

    Joined:
    Mar 7, 2011
    Member:
    #52525
    Messages:
    5,899
    Gender:
    Male
    First Name:
    Jordan
    Nova Scotia, Canada
    Vehicle:
    2011 Tacoma 4x4 2.7 5 speed SWB
    All season mats, 2nd filter delete, DT header, Jardine cat-back, URD shifter, Bilstein 5100's all around at .85 front with Eibachs + .25 passenger/.5 drivers spacers and 1.5 AAL, 0w20 synthetic, Scanguage II, extra D rings, OEM backup camera+Mirror, bed mat, Extang Solid Fold, Popnlock 5300, Pro Comp 7089's 4.5bs 285/70/17 Revo 2s, De-badged
    Heres the two plugs. Small one was the light, then the other was just there not plugged into anything. Its NOT the camera one either, because that one is there tucked up also.
    [​IMG]
    Heres the sensor I think I found on the frame in the center behind the grill. Is this it?
    [​IMG]
     
To Top