1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Overhead Temp Display Still broken not the 510 resistors

Discussion in '2nd Gen. Tacomas (2005-2015)' started by SanJuanTacoma06, Feb 19, 2013.

  1. Feb 19, 2013 at 2:47 PM
    #1
    SanJuanTacoma06

    SanJuanTacoma06 [OP] Member

    Joined:
    Feb 18, 2013
    Member:
    #97861
    Messages:
    10
    Gender:
    Male
    Lake City, CO
    Vehicle:
    2006 TRD Off Road
    Anytime differential lock.
    The temperature/compass display just went out on my 06. I opened it up and took a look at the 510 resistors which were still attached. I tried resoldering them anyway, and it still doesn't work. There is power coming to the circuit board. Everything else looks OK except a small burn mark in the top left hand corner of the display, which from what I've read doesn't matter. Any ideas?
     
  2. Feb 19, 2013 at 5:55 PM
    #2
    BUZZCUT

    BUZZCUT Well-Known Member

    Joined:
    Mar 6, 2011
    Member:
    #52417
    Messages:
    609
    Gender:
    Male
    Georgia
    Vehicle:
    2007 AC TRD OFFROAD

    get a new one. mine died the same way
     
  3. Feb 19, 2013 at 6:21 PM
    #3
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    13,740
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2007 4.0L 4x4 TRD Sport Access Cab A
    Advantage Torza top (tri-fold), Husky floor mats, RuffTuff seat covers, C2C hood struts, Homelink mirror, USA Spec PA15-Toy (120gig Classic & 8gig nano), Garmin Nuvi 660, Protecta Bed mat, Pop-n-lock, TSB Springs, Scangauge II, Heated drivers seat, Fumoto drain valve, Aries pushbar, PIAA 540 fog lights, Hood scoop grahics, Flowmaster 50 series dual catback exhaust, RainX Latitude windshield wipers, Husky rear floor liner (ontop of folded down seats). Console Vault.
    Did you try to solder some of the other circuits/pads?

    My husband builds circuit boards for a living and when he opened up and looked at my overhead compass circuitry, he was amazed by the really poor quality solder joints and overall poor quality.

    He took his soldering iron and went over ALL the pads he could reach.
     
  4. Feb 20, 2013 at 2:37 PM
    #4
    SanJuanTacoma06

    SanJuanTacoma06 [OP] Member

    Joined:
    Feb 18, 2013
    Member:
    #97861
    Messages:
    10
    Gender:
    Male
    Lake City, CO
    Vehicle:
    2006 TRD Off Road
    Anytime differential lock.
    I haven't tried re-soldering anything else. I tested the resistors with my multimeter and they both were around 68 ohms. Think that could be the problem? I ordered some new ones. I will install and see if it works then.
     
  5. Feb 24, 2013 at 3:28 PM
    #5
    SanJuanTacoma06

    SanJuanTacoma06 [OP] Member

    Joined:
    Feb 18, 2013
    Member:
    #97861
    Messages:
    10
    Gender:
    Male
    Lake City, CO
    Vehicle:
    2006 TRD Off Road
    Anytime differential lock.
    I put the new resistors on. It doesn't work. Also there's no power to it anymore. I checked the fuses everything's good, I'm so confused. Anyone have similar problems?
     
  6. Sep 23, 2013 at 9:47 AM
    #6
    jr114

    jr114 Well-Known Member

    Joined:
    Nov 18, 2009
    Member:
    #26147
    Messages:
    1,185
    Gender:
    Male
    First Name:
    Jon
    SoCal
    Vehicle:
    Truck
    Icon Ext travel CO, Icon tubular uniball UCAs, Maxtrac Spindles, Icon RR rear w 2"aal.
    I'm having the same problem. Have replaced the resistors and added new solder. Still does not work. Anyone know of the best (cheapest) place to get a replacement?
     
  7. Sep 23, 2013 at 12:44 PM
    #7
    Danno 1948

    Danno 1948 Well-Known Member

    Joined:
    Feb 26, 2012
    Member:
    #73651
    Messages:
    231
    Gender:
    Male
    First Name:
    Dan
    Ocala,Fl.
    Vehicle:
    08 SR5 Prerunner
    Added front spacers to bring front end up to match rear
    I got one for a 05 up to a 08 that I will sell for 40.00 plus shipping I live in florida 34479
     
To Top