1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Overhead Temperature Display Stuck?

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Gritesh, Apr 22, 2012.

  1. Apr 22, 2012 at 5:48 PM
    #1
    Gritesh

    Gritesh [OP] Well-Known Member

    Joined:
    Jul 7, 2011
    Member:
    #59455
    Messages:
    46
    Gender:
    Male
    It is 17 degrees celsius outside today, and I was working on my stereo, adding in the metra Axxess steering wheel controls.

    Anyways after much messing around and re-wiring my stereo harness all is well.

    When I took it for a drive I noticed my overhead temperature indicator is apparently "stuck" on 7 Degrees or 46 degrees F


    Anyone else ever had this issue? It's been hours and the temperature hasn't moved at all.

    Thanks.
     
  2. Apr 22, 2012 at 6:12 PM
    #2
    Gritesh

    Gritesh [OP] Well-Known Member

    Joined:
    Jul 7, 2011
    Member:
    #59455
    Messages:
    46
    Gender:
    Male
    Well I took it for a longer drive, and after about 10 minutes it started working again.

    Weird, but it seems to be fine now.
     
  3. Apr 22, 2012 at 6:13 PM
    #3
    Raylo

    Raylo Well-Known Member

    Joined:
    Nov 19, 2008
    Member:
    #10878
    Messages:
    430
    Gender:
    Male
    MD, USA
    Vehicle:
    2009 4x4 Access Cab, TRD Sport
To Top