1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

p0420 code

Discussion in '1st Gen. Tacomas (1995-2004)' started by wildjerseyfirefighter, Oct 31, 2010.

  1. Oct 31, 2010 at 9:15 PM
    #1
    wildjerseyfirefighter

    wildjerseyfirefighter [OP] I sell fishing and fishing accessories

    Joined:
    Dec 17, 2008
    Member:
    #11677
    Messages:
    7,958
    Gender:
    Male
    First Name:
    Joe
    NJ
    Vehicle:
    05 Tacoma TRD Sport
    stock, for now
    pops comes home and says check engine lights on..I scan it and it comes up with p0420 code, catalyst something..I forget now.

    2002 3.4L 100K miles.
    already replaced the first (02?) sensor upstream
    Could it be the one thats behind the cat gone bad now?
     
  2. Nov 1, 2010 at 1:21 AM
    #2
    pdxwhiteout

    pdxwhiteout monster taco in the snow

    Joined:
    Dec 24, 2009
    Member:
    #28120
    Messages:
    101
    Gender:
    Male
    First Name:
    coty
    pdx
    Vehicle:
    monster tacoma
    3-inch body lift, 6-inch fabtech lift, 17-inch procomp black alloys wrapped in bfg 37s. trd v-6.
    sorry to tell you bro but thats a cat failure code. best thing to do is clear it and see how long it takes for it to come back. if the 02 sensors are good the only thing that will make that code pop is the cat itself and thats $$$$$
     
  3. Nov 27, 2010 at 8:40 AM
    #3
    kingston73

    kingston73 Well-Known Member

    Joined:
    Aug 8, 2009
    Member:
    #20845
    Messages:
    2,453
    Gender:
    Male
    eastern MA
    Vehicle:
    09 SR5 4.0L 4x4
    That's actually not true. The shop manual says to check for exhaust leaks before doing anything else, that's what caused my code last year. I asked this question almost the same time last year:
    http://www.tacomaworld.com/forum/1s...eck-engine-light-after-frame-replacement.html
     
To Top