1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

P0606... Am I SOL?

Discussion in 'Technical Chat' started by memario1214, Apr 26, 2012.

  1. Apr 26, 2012 at 9:30 AM
    #1
    memario1214

    memario1214 [OP] Vivid Illumination Vendor

    Joined:
    Oct 1, 2009
    Member:
    #23628
    Messages:
    13,772
    Gender:
    Male
    First Name:
    Colton
    Gillette, WY
    Vehicle:
    05 Dub Cab TRD Sport 4x4
    Yeah, I gots boost
    So this morning I turned the truck on and started driving. I noticed that my CEL was on, so I checked my Ultragauge to see what it was. The code was P0606, which upon using Google was discovered to be a PCM / ECM Processor Fault. So am I pretty much effed here? Gonna have to buy a new ECM? Can you just swap them in and out?
     
  2. Apr 26, 2012 at 11:33 AM
    #2
    BlueT

    BlueT Well-Known Member

    Joined:
    Mar 30, 2009
    Member:
    #15341
    Messages:
    5,645
    Gender:
    Male
    NorthEast
    Vehicle:
    07 Dbl Cab LB with LSD
    I moded 1999 Taco so much it had turned to Land Cruiser
    reset code and see if comes back. still factory battery?
     
  3. Apr 26, 2012 at 11:34 AM
    #3
    T@co_Pr3runn3r

    T@co_Pr3runn3r XXXXXXXXXXXXXXXXXXX

    Joined:
    Jan 20, 2009
    Member:
    #12767
    Messages:
    11,923
    Gender:
    Male
    <----------------->
    Vehicle:
    08 RC Prerunner SR5
    It's windows OS and just needs a reboot..........
     
  4. Apr 26, 2012 at 11:37 AM
    #4
    Ga tacoguy

    Ga tacoguy Well-Known Member

    Joined:
    Mar 2, 2012
    Member:
    #74020
    Messages:
    311
    Gender:
    Male
    First Name:
    Rudy
    Augusta Ga.
    Vehicle:
    Extended cab Base model 4 cyl
    Tailgate mod, horn mod,storage door mod
    I am sorry to read about your P0 606 code. Yes it is a PCM problem, but it always doesn't mean it is the computer. My book says that you should let the dealer hook it up and see what the problems is. I see that you are out of warranty, so if you know of a good repair shop that has invested in a good PCM diaganostic machine. I don't know how the truck has been driven and I can't say why the PCM is failing, but it will fail soon if it is not fixed.

    You may want to check the electrical connections going into the PCM to see if they are Corroded or frayed. Sorry about the bad news, I hope it can be fixed. Good Luck.
     
  5. Apr 26, 2012 at 11:39 AM
    #5
    XXXX

    XXXX Well-Known Member

    Joined:
    Sep 1, 2011
    Member:
    #62715
    Messages:
    20,913
    Gender:
    Male
    First Name:
    sKiP
    Vehicle:
    05 Prius

    this


    I shot a code a few months ago and once it was reset it never came back.

    It was saying I had an over-retarded diff censor or some crap.
     
To Top