1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Persistant Undiagnosable Miss

Discussion in '4 Cylinder' started by josh., Sep 30, 2012.

  1. Nov 7, 2012 at 7:47 AM
    #21
    josh.

    josh. [OP] Member

    Joined:
    Sep 30, 2012
    Member:
    #88000
    Messages:
    13
    Gender:
    Male
    First Name:
    Joshua
    New Hampshire
    Vehicle:
    95 Tacoma
    Okay- After over a week later the tech I brought my truck to has finally found the problem- it appears that the ignitor module was failing at higher RPMs and he also mentioned that the miss was still occuring with the MAF disconnected, because the engine was running rich it masked the problem. Thank you for you support and suggestions.
     
  2. May 27, 2014 at 8:27 PM
    #22
    LFTDJEEP426

    LFTDJEEP426 Well-Known Member

    Joined:
    Mar 31, 2014
    Member:
    #126689
    Messages:
    145
    Gender:
    Male
    First Name:
    Jonathan
    Frisco, TX
    Vehicle:
    1995.5 Tacoma 4x4
    Been going through what sounds like the same issues you were here. Wanted to follow up and see if the problem never returned and the ICM was in fact the final fix to the problem.

    Thanks :confused:
     
To Top