1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Piaa 5454 Driving lights

Discussion in '2nd Gen. Tacomas (2005-2015)' started by darkgohan, Apr 9, 2010.

  1. Apr 9, 2010 at 1:48 PM
    #1
    darkgohan

    darkgohan [OP] Well-Known Member

    Joined:
    Sep 9, 2009
    Member:
    #22498
    Messages:
    263
    Gender:
    Male
    Just tried mounting these in my 2010,not a nice fit at all. Disapointed with the crude mounting hardware,as it attempts to use the side holes in the existing holder. At the front of this mounting bracket are two silver screws that will rub on the bumper hole,and because they stick out like a sore thumb on each side,they really are the first thing you see,and appearance looks amateurish. Unit does not recess properly,sticks out too much. Plain and simple they are not going on my truck!! Anyone got a light that mounts well and looks somewhat professional??
     
  2. Apr 9, 2010 at 8:07 PM
    #2
    darkgohan

    darkgohan [OP] Well-Known Member

    Joined:
    Sep 9, 2009
    Member:
    #22498
    Messages:
    263
    Gender:
    Male
    Been looking on ebay. If you can point me to a good kit with wiring harness that installs like the factory ones I would appreciate it. Should have taken the earlier advice from someone here a while back who said he had purchased his there.. Thanks
     
  3. Apr 9, 2010 at 8:45 PM
    #3
    Andrew H

    Andrew H What is this "search" you speak of?

    Joined:
    Nov 6, 2008
    Member:
    #10545
    Messages:
    4,281
    Gender:
    Male
    Dirty Tucson
    Vehicle:
    2010DCSB4X4TRDORMGM
    See build thread.
    Try searching in the "Lighting" thread on this site. If you can't find it try posting this question in that thread.

    GL!
     
  4. Apr 9, 2010 at 8:52 PM
    #4
    darkgohan

    darkgohan [OP] Well-Known Member

    Joined:
    Sep 9, 2009
    Member:
    #22498
    Messages:
    263
    Gender:
    Male
    Thank you
     
  5. Apr 18, 2011 at 12:42 PM
    #5
    bc_tacoma10

    bc_tacoma10 Well-Known Member

    Joined:
    Aug 6, 2010
    Member:
    #41334
    Messages:
    46
    Gender:
    Male
    First Name:
    Rick
    Kelowna, BC
    Vehicle:
    10 Access Cab SR5 Black
    I just installed and they came out awesome. I have heard a couple of people that said they didn't fit well. I don't know what that is all about but take a look at my profile pictures and you'll see they are clean. Here is a link to my thread.

    http://www.tacomaworld.com/forum/2nd-gen-tacomas/152167-piaa-5454-kit.html
     
To Top