1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Pioneer AVH-2300NEX w\ backup cam install in 2005 Tacoma

Discussion in 'Audio & Video' started by drewbert41, Jan 15, 2019.

  1. Jan 15, 2019 at 6:55 AM
    #1
    drewbert41

    drewbert41 [OP] Well-Known Member

    Joined:
    Nov 20, 2018
    Member:
    #273330
    Messages:
    384
    Gender:
    Male
    Champaign, IL
    Vehicle:
    05 Silver DCSB 4x4 TRD
    I fumbled my way through this so I figured I would post some lessons learned for people. I also have a few questions for the experts on here. I am going to do the same to my buddy's 08 soon. I learned a lot of this from different threads on here and I am kind of putting it all together.

    Parts list from Amazon:

    Head Unit:
    https://www.amazon.com/d/Dash-DVD-V...1547563845&sr=1-1-fkmr1&keywords=nex+2300+AVH

    Scosche Dash Kit:
    https://www.amazon.com/gp/product/B0014KOA42/ref=ppx_yo_dt_b_asin_title_o09__o00_s00?ie=UTF8&psc=1

    Tailgate handle w\ cam:
    https://www.amazon.com/gp/product/B01DCRIS1U/ref=ppx_yo_dt_b_asin_title_o00__o00_s00?ie=UTF8&psc=1

    Wiring Harness:
    https://www.amazon.com/gp/product/B0002BEQJ8/ref=ppx_yo_dt_b_asin_title_o09__o00_s00?ie=UTF8&psc=1

    T-Connectors:
    https://www.amazon.com/gp/product/B07CP987BN/ref=ppx_yo_dt_b_asin_title_o02__o00_s01?ie=UTF8&psc=1

    Tiny USB Cable for Phone:
    https://www.amazon.com/gp/product/B012V56D2A/ref=ppx_yo_dt_b_asin_title_o09__o00_s00?ie=UTF8&psc=1

    If you screw up the Pioneer harness:
    https://www.amazon.com/gp/product/B07MH3GZ1S/ref=ppx_yo_dt_b_asin_title_o04__o00_s00?ie=UTF8&psc=1

    Blue butt connectors from auto parts store.
     
    Last edited: Jan 15, 2019
  2. Jan 15, 2019 at 8:28 AM
    #2
    drewbert41

    drewbert41 [OP] Well-Known Member

    Joined:
    Nov 20, 2018
    Member:
    #273330
    Messages:
    384
    Gender:
    Male
    Champaign, IL
    Vehicle:
    05 Silver DCSB 4x4 TRD
    Brackets: I reused the stock brackets with the Scosche housing and it works well. They key thing I found is to put the head unit and the dash kit on at the same time. I had fitment issues when I tried to snap the kit on over the already bolted in head unit.

    Mic: I have heard people complain about sound clarity when mounting the mic on the A-pillar. I mounted mine here and tested it and I have had no issues.

    USB out for Phone\Android Auto: The little tray by your right knee. I took it out and drilled a hole in it. I ran the USB extension that came with the CD player into that tray. Then I use that little phone cable in the parts list to plug my phone in and sit it in that tray.

    Parking Brake: You NEED this for Android Auto. Don't rip it out of the harness like I did or you will need to buy a new one! I grounded the parking brake to the lovely bolt behind the kick panel. This will not allow you to watch DVDs but it will allow you to use Android auto and configure the head unit. (background, etc.)

    Tailgate Camera: I had to drill a hole in the bottom of the tailgate to feed the wires and connector through. Later models have a drain hole you can use. Mine did not. I used a T connector to tap into the red reverse light wire right behind my reverse lamp (pull the tail light). I grounded the ground wire to the metal part of the bed behind the tail light after wire brushing off some paint. I ran the video wire for the camera along the frame and up through a rubber grommet under the drivers seat. I stabbed it with a screwdriver and shoved it through. Then I ran it under the door sill\ kick plate up to the head unit.

    Harness: The colors literally match up perfectly. Cap the wires you don't use.
     
    skatefreak282 likes this.
  3. Jan 15, 2019 at 8:31 AM
    #3
    drewbert41

    drewbert41 [OP] Well-Known Member

    Joined:
    Nov 20, 2018
    Member:
    #273330
    Messages:
    384
    Gender:
    Male
    Champaign, IL
    Vehicle:
    05 Silver DCSB 4x4 TRD
  4. Jan 15, 2019 at 8:36 AM
    #4
    drewbert41

    drewbert41 [OP] Well-Known Member

    Joined:
    Nov 20, 2018
    Member:
    #273330
    Messages:
    384
    Gender:
    Male
    Champaign, IL
    Vehicle:
    05 Silver DCSB 4x4 TRD
    My question for the Pioneer experts:

    My backup cam only works when I am in reverse AND I touch the camera button (the two squares). That's fine, I get it, I probably should have ran a wire to the reverse signal input wire on the stereo harness. BUT WAIT. Sometimes when I go into reverse the image automagically pops up on my screen. So it works auto sometimes and needs manual intervention other times. Thoughts?
     
  5. Jan 15, 2019 at 10:44 AM
    #5
    Do58

    Do58 Well-Known Member

    Joined:
    Oct 11, 2015
    Member:
    #166373
    Messages:
    594
    Gender:
    Male
    Vehicle:
    2015 white tacoma limited
    so what wire do you have going to the pioneer reverse signal wire ( purple/white ) if any? if you do what is it or where is it coming from?
     
  6. Jan 15, 2019 at 12:51 PM
    #6
    drewbert41

    drewbert41 [OP] Well-Known Member

    Joined:
    Nov 20, 2018
    Member:
    #273330
    Messages:
    384
    Gender:
    Male
    Champaign, IL
    Vehicle:
    05 Silver DCSB 4x4 TRD
    None. It is capped.
     
  7. Jan 15, 2019 at 1:07 PM
    #7
    Do58

    Do58 Well-Known Member

    Joined:
    Oct 11, 2015
    Member:
    #166373
    Messages:
    594
    Gender:
    Male
    Vehicle:
    2015 white tacoma limited
    if you don't have that wire hooked up then it doesn't know when your in reverse.
    you need to hook it up to a red/white stripe in the drivers kick 12 pin gray plug pin 1.
    that's for starters.
    I always hook power up to the radio for the camera and your ground can cause you issues because the bed is not always a good ground per say. I always try to install them to the frame rail. ( I do this professionally for a living ). by doing this my way you can use the camera source so you can watch the camera while you in any position not just reverse
     
  8. Jan 15, 2019 at 1:15 PM
    #8
    drewbert41

    drewbert41 [OP] Well-Known Member

    Joined:
    Nov 20, 2018
    Member:
    #273330
    Messages:
    384
    Gender:
    Male
    Champaign, IL
    Vehicle:
    05 Silver DCSB 4x4 TRD
    This tailgate handle came with a short power cable meant to hook to the reverse light for power. Are you saying extend that up into the cab to the kick panel or no? Or just leave it and run a wire from the back of the headunit to the red\white in the kick panel? I figured that someone would mention something about my ground being suspect and I had hoped that would be the issue. I will change that chassis ground for sure.
     
  9. Jan 15, 2019 at 2:40 PM
    #9
    Do58

    Do58 Well-Known Member

    Joined:
    Oct 11, 2015
    Member:
    #166373
    Messages:
    594
    Gender:
    Male
    Vehicle:
    2015 white tacoma limited
    “If” you power your camera via reverse only, then you won’t get use the camera source feature of the radio. That’s your call but I’m not a fan of powering cameras by the reverse signal because it cane be “dirty power”.
    Pm me your phone number.
     
  10. Jun 3, 2021 at 11:55 AM
    #10
    OCMDTaco

    OCMDTaco Member

    Joined:
    Nov 13, 2019
    Member:
    #310654
    Messages:
    6
    Gender:
    Male
    First Name:
    Corey
    Vehicle:
    2008 Silver Tacoma 4x4 Doublecab
    Hey did you ever figure out how to wire your backup camera? I have a pioneer as well and the same backup camera. I can’t figure out if I wire to the reverse light or the purple/white wire or both?
     
  11. Jun 3, 2021 at 12:56 PM
    #11
    drewbert41

    drewbert41 [OP] Well-Known Member

    Joined:
    Nov 20, 2018
    Member:
    #273330
    Messages:
    384
    Gender:
    Male
    Champaign, IL
    Vehicle:
    05 Silver DCSB 4x4 TRD
    I got it working, but this was a long time ago. I hooked the purple up so that it changes the screen to video when you put it in reverse. I tapped into the reverse light wire for camera power. My camera is only on when in reverse and that is fine for me.
     
  12. Jun 3, 2021 at 1:05 PM
    #12
    OCMDTaco

    OCMDTaco Member

    Joined:
    Nov 13, 2019
    Member:
    #310654
    Messages:
    6
    Gender:
    Male
    First Name:
    Corey
    Vehicle:
    2008 Silver Tacoma 4x4 Doublecab
    Yea sorry I realize this is old but it is the closest thread I’ve found to my situation. So you still tapped your power wire into the tail light, but what did you connect the purple white wire to? And did you ground it behind the tail light?
     
  13. Jun 3, 2021 at 8:55 PM
    #13
    drewbert41

    drewbert41 [OP] Well-Known Member

    Joined:
    Nov 20, 2018
    Member:
    #273330
    Messages:
    384
    Gender:
    Male
    Champaign, IL
    Vehicle:
    05 Silver DCSB 4x4 TRD
    Yeah no problem I was just trying to remember without tearing it apart again. I believe the purple taps into the red/white in the kick panel. The camera is grounded behind my taillight housing.
     
    Bond248 likes this.
  14. Jun 3, 2021 at 9:27 PM
    #14
    OCMDTaco

    OCMDTaco Member

    Joined:
    Nov 13, 2019
    Member:
    #310654
    Messages:
    6
    Gender:
    Male
    First Name:
    Corey
    Vehicle:
    2008 Silver Tacoma 4x4 Doublecab
    Ok thanks for the info!
     
To Top