1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

please help p0401 code

Discussion in '4 Cylinder' started by gixxer1, Jun 12, 2010.

  1. gixxer1

    gixxer1 [OP] Member

    Joined:
    Jan 14, 2008
    Member:
    #4245
    Messages:
    18
    Gender:
    Male
    Vehicle:
    03 reg cab 2.7L 4x4
    03 4x4 2.7L 5spd.......so i was driving the other day and got a check eng. light on p0401.......took it to the dealer and a master tech took a look....he said replace the egr valve and vsv solinoid . so i did this and the light came back on.

    prior to replacing these parts i checked out the egr with a vacuum gauge(applied vacuum and engine wanted to stall, so i figured it was ok)
    removed the vsv and applied vacuum then actuated it with battery voltage , vacuum released- figured that was ok too)
    looked inside egr to exhaust manifold tube and its completely clear!....wtf!

    anybody have this problem?

    thank you
     
  2. swdockter

    swdockter Well-Known Member

    Joined:
    Apr 5, 2010
    Member:
    #34669
    Messages:
    57
    Gender:
    Male
    Northwest Burbs, IL
    2" lift, 5100s, AAL, K&N, Deck Plate

    lmao, I have the same code right now. Hope we can find someone here with the same issues and got them fixed. :D
     
  3. gixxer1

    gixxer1 [OP] Member

    Joined:
    Jan 14, 2008
    Member:
    #4245
    Messages:
    18
    Gender:
    Male
    Vehicle:
    03 reg cab 2.7L 4x4
  4. nagelg

    nagelg Well-Known Member

    Joined:
    Mar 9, 2008
    Member:
    #5184
    Messages:
    444
    Gender:
    Male
    First Name:
    George
    Northern Wisconsin
    Vehicle:
    '08 Black, acc. cab, 4x4, 2.7
  5. swdockter

    swdockter Well-Known Member

    Joined:
    Apr 5, 2010
    Member:
    #34669
    Messages:
    57
    Gender:
    Male
    Northwest Burbs, IL
    2" lift, 5100s, AAL, K&N, Deck Plate
  6. nagelg

    nagelg Well-Known Member

    Joined:
    Mar 9, 2008
    Member:
    #5184
    Messages:
    444
    Gender:
    Male
    First Name:
    George
    Northern Wisconsin
    Vehicle:
    '08 Black, acc. cab, 4x4, 2.7
    Yer talking to a dummy here bud. I can sure fix a truck that don't have a computer, try me on carburetors, distributers and points and I'm ok. Throw a "code" at me and I'm,,,, WTF??????

    There some pretty smart people on here (Chris 4X4 and a bunch more) who can answer your questions....good luck.
     
  7. 98tacoma27

    98tacoma27 :POOPCORN: Staff Member

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,253
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
  8. HomerTaco

    HomerTaco That "grill guy" Vendor

    Joined:
    Mar 28, 2010
    Member:
    #34129
    Messages:
    26,801
    Gender:
    Male
    First Name:
    Craig
    Bucks County Pa.
    Vehicle:
    07' DCSB cut to pieces...
    Core-Hurst short throw shifter & T-handle / Carbon Fiber Interior / custom console light / De-badged / leather interior / Heated Front seats / Red Line Hood Struts / Painted speaker grills /one-off TRD Satoshi Grill/ Pioneer AVIC-X920BT HU / Scangauge II / Black LED Tails / Dash Mount for iPad / Safari Snorkel / Illuminated 4x4 switch / Leer 100XQ Cap / 4x Innovations sliders / Rear Diff Breather Mod / front windows tinted to 35% / Brute Force Fab Hybrid Front Bumper / BAMF Rear Diff Skid / Budbuilt Skids / CBI Trail Master 2.0 rear hybrid bumper / Fox rr coils/ TC UCA's/ TC spindle gussets/ TC Cam Tab gussets / Dakar leafs / Defined Engineering shackles / All pro U bolt flip / Timbren Rear Bumpstops / BAMF LCA skids / Exhaust Dump / Fog Light anytime Mod / LowRange Off Road extended rear brake lines / ATO Shackle Flip / sectioned Bushwhacker flares / re-geared to 4.56 / ARB Front & Rear Locking Diff / ARB CKMA12 compressor / PrInSu full rack system / 1" body lift
  9. 98tacoma27

    98tacoma27 :POOPCORN: Staff Member

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,253
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
  10. gixxer1

    gixxer1 [OP] Member

    Joined:
    Jan 14, 2008
    Member:
    #4245
    Messages:
    18
    Gender:
    Male
    Vehicle:
    03 reg cab 2.7L 4x4
    Thank you Ben so much!
    I'll mess with it tomorrow.......
    Do you have a vacuum diagram also?
     
  11. 98tacoma27

    98tacoma27 :POOPCORN: Staff Member

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,253
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
  12. gixxer1

    gixxer1 [OP] Member

    Joined:
    Jan 14, 2008
    Member:
    #4245
    Messages:
    18
    Gender:
    Male
    Vehicle:
    03 reg cab 2.7L 4x4
    the vacuum ports on top of the throttlebody seem to be the problem......
    two are clogged so i blew them out and checked for vacuum with a gauge.......i have vacuum now and i reset light so now i will post eng. light results in a few days.
     
  13. gixxer1

    gixxer1 [OP] Member

    Joined:
    Jan 14, 2008
    Member:
    #4245
    Messages:
    18
    Gender:
    Male
    Vehicle:
    03 reg cab 2.7L 4x4
    no light yet, its been about 75-100 miles......it was the two throttlebody ports 2nd/3rd from butterfly opening on top.
     
  14. 98tacoma27

    98tacoma27 :POOPCORN: Staff Member

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,253
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
  15. 005Tacoma

    005Tacoma Well-Known Member

    Joined:
    Jun 8, 2008
    Member:
    #7179
    Messages:
    565
    Gender:
    Male
    First Name:
    Mike
    Macon Georgia
    Vehicle:
    2005 Toyota Tacoma
    P0401 Exhaust Gas Recirculation Flow Insufficient Detected
     
  16. hktran

    hktran New Member

    Joined:
    Oct 9, 2010
    Member:
    #44439
    Messages:
    1
    Gender:
    Male
    First Name:
    KT
    LA
    Vehicle:
    2002 Prerunner
    i had this same code for over a year, it would come on and off so i never addressed it. now it just stayed on, and i have dmv reg at the end of the month. spent the afternoon diagnosing.
    found there was vacuum off the throttle body(to port P), but nothing after the vacuum modulator(out of port Q).
    i was pretty sure this was the culprit, decided to crack open the modulator to see. sure enough, the rubber membrane was broken/cracked.

    Photo1121.jpg
     
  17. Racerboy221

    Racerboy221 Well-Known Member

    Joined:
    Mar 19, 2011
    Member:
    #53292
    Messages:
    433
    Gender:
    Male
    First Name:
    Bill
    Litchfield Park, AZ
    Vehicle:
    Tacoma 2.4, Std cab/bed, 18"wheels,airshocks
    18" Wheels & Tires, Airshocks, CB Radio
    I get the P0402 code from time to time as well. I just reset it using the OBD-II computer I keep under the seat and continue driving. The cost of replacing this item at retail is just stooopid expensive. too!
     
To Top