1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

PO 402 EGR excessive flow..

Discussion in 'Technical Chat' started by themaine1, Oct 16, 2009.

  1. Oct 16, 2009 at 11:56 AM
    #1
    themaine1

    themaine1 [OP] Member

    Joined:
    Oct 16, 2009
    Member:
    #24394
    Messages:
    16
    Gender:
    Male
    South Carolina
    Vehicle:
    00 TOY
    alarm, speaker upgrades
    Alread spent $200 on this PO 402 error code to get it repaired and it keeps coming back. I can make it happen though, once the error is cleared. If i start it and drive it immediatly without warming up, the light will come on within a mile. if i let it warmup, the light will stay off, it is just when I am in a hurry and do not let it warm up, the light WILL come on. Runs great otherwise! Any thoughs, send em my way. Truck has 317K miles.
     
  2. Oct 16, 2009 at 11:58 AM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,132
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Does it run rough at start up?
     
  3. Oct 16, 2009 at 12:06 PM
    #3
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,729
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    What motor are we talking about? 2.4/2.7?
     
  4. Oct 16, 2009 at 12:12 PM
    #4
    themaine1

    themaine1 [OP] Member

    Joined:
    Oct 16, 2009
    Member:
    #24394
    Messages:
    16
    Gender:
    Male
    South Carolina
    Vehicle:
    00 TOY
    alarm, speaker upgrades
    Engine does not run rough at all, little loud till warm up, then ok...has exhaust manifold leak which does not help the noise. The engine is the 2.4L 4cyl.
     
  5. Oct 16, 2009 at 12:13 PM
    #5
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,729
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    What exactly was done to "repair" it?
     
  6. Oct 16, 2009 at 12:13 PM
    #6
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,132
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    It could be the Temp Sensor...
     
  7. Oct 16, 2009 at 12:21 PM
    #7
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,729
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    It could also be a simple vacuum leak.
     
  8. Oct 16, 2009 at 12:55 PM
    #8
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,132
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    :thumbsup:
     
  9. Oct 16, 2009 at 1:00 PM
    #9
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,729
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    Are you shaking you fidt at me!?!?!?!










    :rofl:
     
  10. Oct 16, 2009 at 1:01 PM
    #10
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,132
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Yed I am you Sumobitch!
     
  11. Oct 17, 2009 at 4:46 PM
    #11
    themaine1

    themaine1 [OP] Member

    Joined:
    Oct 16, 2009
    Member:
    #24394
    Messages:
    16
    Gender:
    Male
    South Carolina
    Vehicle:
    00 TOY
    alarm, speaker upgrades
    Temp sensor was replaced already...thats the $200 already spent.
     
  12. Oct 17, 2009 at 5:09 PM
    #12
    kevhogaz

    kevhogaz Low Speed, High Drag

    Joined:
    Sep 6, 2008
    Member:
    #9055
    Messages:
    323
    Gender:
    Male
    Queen Creek, Arizona
    Vehicle:
    SR5 PreRunner
    3" lift front & rear, Air Raid Intake System
    What temp sensor did you replace? The one for the EGR valve? If you did, did you test it first? I've been with Toyota a while, and I don't recall replacing too many of those switches.

    You said the light comes on immediately? I show the EGR circuit is a two trip kind of deal. Is everything plugged in? Is the valve functioning?

    Something doesn't seem right.
     
  13. Oct 29, 2009 at 10:40 AM
    #13
    themaine1

    themaine1 [OP] Member

    Joined:
    Oct 16, 2009
    Member:
    #24394
    Messages:
    16
    Gender:
    Male
    South Carolina
    Vehicle:
    00 TOY
    alarm, speaker upgrades
    they replaced the vacuum lines, seems to maybe have doner the trick...I HOPE!!!
     
  14. Oct 29, 2009 at 10:48 AM
    #14
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,729
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    :woot:

    Thanks for the update!
     
To Top