1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Polaris problems

Discussion in 'All Terrain Vehicles' started by Killer Red Taco, May 14, 2009.

  1. May 14, 2009 at 3:09 PM
    #1
    Killer Red Taco

    Killer Red Taco [OP] NorCal Rock Whore

    Joined:
    Aug 25, 2008
    Member:
    #8749
    Messages:
    1,754
    Gender:
    Male
    First Name:
    Whatsurname
    BFE–Norcal
    Vehicle:
    007 Tacoma A/C TRD O/R Impulse Red 4x4
    Bilstein 5100 on front at 1.75 setting • 5100 on back• K&N Air Filter• TRD Seat Covers• Day Time Running Lights• Foglights Anytime• Hella 500 lights in grille• Rear TSB Springs• Alternative Locker Mod• CB and 4 ft firestick II• Billet Grille• Kid puke in the back!• 265/75R16 Goodyear MT/R• 16" Devino wheels• Hose Clamp Mod• Revenge Fab Sliders• No Sway Bar• A Hottie as Copilot
    2001 Polaris Magnum RMK 500.

    It will run ok when is Idling and up to about half throttle. After that it bogs down and try's to die, there also seems to be a lot of back pressure in the intake because it spit gas back out of the carb.

    I just rebuilt the carb and have no ideas what to do next.
    It seems to be like the exhaust isn't opening completely.
     
  2. May 14, 2009 at 7:22 PM
    #2
    Killer Red Taco

    Killer Red Taco [OP] NorCal Rock Whore

    Joined:
    Aug 25, 2008
    Member:
    #8749
    Messages:
    1,754
    Gender:
    Male
    First Name:
    Whatsurname
    BFE–Norcal
    Vehicle:
    007 Tacoma A/C TRD O/R Impulse Red 4x4
    Bilstein 5100 on front at 1.75 setting • 5100 on back• K&N Air Filter• TRD Seat Covers• Day Time Running Lights• Foglights Anytime• Hella 500 lights in grille• Rear TSB Springs• Alternative Locker Mod• CB and 4 ft firestick II• Billet Grille• Kid puke in the back!• 265/75R16 Goodyear MT/R• 16" Devino wheels• Hose Clamp Mod• Revenge Fab Sliders• No Sway Bar• A Hottie as Copilot
    Bump for some help, cause I really need it
     
  3. Jul 12, 2009 at 8:12 AM
    #3
    jiles111

    jiles111 Well-Known Member

    Joined:
    May 27, 2009
    Member:
    #17718
    Messages:
    53
    Gender:
    Male
    Abilene, TX
    Vehicle:
    09 RegCab 4x4 Super White
    Did you check the little breather hose that comes off the carb (Tiny rubber hose)? Mine get clogged all the time and when it does my gas dumps in my air filter box and it runs like crap above idle. I have had to do this on both my Timberwolf and Gator.
    The hose has something to do with the pressure in the float area of the carb. When its clogged the float does not work and continues to let gas dump in the carb.
     
To Top