1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Pop and Lock for 09+ Tacoma w/ backup cam - Questions

Discussion in '2nd Gen. Tacomas (2005-2015)' started by rmd0311, Oct 6, 2009.

  1. Oct 6, 2009 at 8:40 AM
    #1
    rmd0311

    rmd0311 [OP] Well-Known Member

    Joined:
    Oct 30, 2007
    Member:
    #3302
    Messages:
    297
    Gender:
    Male
    Dutchess County, NY
    Vehicle:
    2010 Mag Gray TRD Sport
    I have read through the few threads that have this. But I still have a few questions. Plus the info that is available was all over the place. I figured start a thread and put it all in one place.

    I just purchased the POP and LOCK from TruckAlterations. It's on back order and they are suppose to have it by next week. Now, the removal of the back up camera makes me a bit worried. Also have some questions about how it fits.

    In both TN and here people are saying they have issues taking off the backup camera from the OE slot. Can anyone tell me exactly what the issue was? I might use too much force at times just want to make sure I don't break anything....

    Also, someone mentioned that the fit was not quite there? Has anyone else found this to be the case.

    Lastly, Did anyone else run into any other issues like having to recalibrate the backup cam? If so, how much did you have to calibrate it....

    Thanks to all...
     
  2. Oct 6, 2009 at 8:43 AM
    #2
    Capita

    Capita Well-Known Member

    Joined:
    Jun 6, 2009
    Member:
    #18096
    Messages:
    2,673
    Gender:
    Male
    Corner Brook, Newfoundland, Canada
    Vehicle:
    09 TRD Sport Double Cab
    I had no issues getting the camera out. But putting the camera in the Pop and Lock bracket was a bit tricky. I had to drill the holes a bit bigger to get the camera to fit correctly. That was my only issue and it was a very simple fix.

    I have the manual lock. The one you need the key with. PL5300 I think. There is an electricial version as well. I have no experience with that one.
     
  3. Oct 6, 2009 at 9:02 AM
    #3
    rmd0311

    rmd0311 [OP] Well-Known Member

    Joined:
    Oct 30, 2007
    Member:
    #3302
    Messages:
    297
    Gender:
    Male
    Dutchess County, NY
    Vehicle:
    2010 Mag Gray TRD Sport
    Just to keep this in line... This thread is about the MANUAL POP AND LOCK PL5300.

    Capita, when you say you had to drill holes... What size and type drill bit did you use?
     
  4. Oct 6, 2009 at 1:01 PM
    #4
    Capita

    Capita Well-Known Member

    Joined:
    Jun 6, 2009
    Member:
    #18096
    Messages:
    2,673
    Gender:
    Male
    Corner Brook, Newfoundland, Canada
    Vehicle:
    09 TRD Sport Double Cab
    I never really checked the size. It was just a bit bigger then the original holes. I just used a small drill bit and clamed vice grips onto it. Manually drilled it by hand. very easy to do. Sorry I never payed attention to drill bit size. Maybe you'll be lucky and not have to drill the holes. I just figured it was a faulty pop & lock bracket I had.


    Over all I am pleased with the product though. Works great. Sorry I couldn't help you more.
     
  5. Oct 6, 2009 at 1:19 PM
    #5
    otter

    otter Well-Known Member

    Joined:
    Jul 27, 2009
    Member:
    #20249
    Messages:
    265
    Gender:
    Male
    First Name:
    Rob
    MI
    Vehicle:
    09 4 cyl Reg Cab
    I didn't have to do any drilling or modification with my PL5300. Removal/installation was easy. Make sure to lube everything with white lithium grease before you close everything up. The Pop'n'lock isn't as smooth as the OEM handle, so any bit of lube helps.
     
To Top