1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Possible bad gas?? now what?

Discussion in '1st Gen. Tacomas (1995-2004)' started by lensal, Jan 29, 2010.

  1. Jan 29, 2010 at 10:23 PM
    #1
    lensal

    lensal [OP] New Member

    Joined:
    Sep 25, 2009
    Member:
    #23318
    Messages:
    3
    Gender:
    Male
    First Name:
    len
    jax,florida
    Vehicle:
    97 tacoma 2x2 2.4l 5spd
    As soon as I filled up (10 gal)my '97 2.4L, I've gotten progressively worsening hard detonation, loss of power, no stalling, but shaking. only driven about 10 miles. Can't go faster than 25 fearing something's gonna pop. Added red line complete fuel system-no help.Plan on emptying tank, adding new gas, changing spark plugs. Don't know if I got bad/dirty/cheap gas or water mix. Tanker wasn't delivering at the time. Any recommendations would be greatly appreciated-thanks
     
  2. Jan 29, 2010 at 10:44 PM
    #2
    cheehab

    cheehab I bleed Black and Gold

    Joined:
    Sep 13, 2008
    Member:
    #9192
    Messages:
    400
    Gender:
    Male
    First Name:
    Adam
    Winter Park, CO
    Vehicle:
    2015 Tundra TRD Pro CrewMax
    Sounds like bad gas to me dude. It happened to me once on a volvo, I drained it, but didn't change the plugs.
     
To Top