1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Possible K&N Intake problem.

Discussion in '2nd Gen. Tacomas (2005-2015)' started by NCTacoma, Apr 14, 2013.

  1. Apr 14, 2013 at 7:39 PM

    NCTacoma [OP] Rather be in the mtns

    Mar 6, 2013
    First Name:
    CLT, NC
    2012 DCLB 4x4
    OME 2.5" lift, 275/70/17 Hankook Dynaprao ATM's, 17" FJ wheels, BAMF sliders, Wicked Flow muffler, Leer 100R Shell, Weathertechs
    I have a strange 'knocking' which seems to be coming from under the glovebox area or under front passenger's feet. It only happens when the truck is being cranked as far as I can tell. When I instaleld my K&N intake, I noticed a slight knock when the trunk is cranked. The only two options are these.

    1- I just cleaned and re-oiled the filter. Possible over oil? I followed the instructions to a T. Or I think I did.

    2- Last night on the way home, a truck blew a tire in front of us. I caught a little shrapnel, all under-carriage. Possible heat shroud bending? I looked under it tonight but it was dark and I was in a parking lot and the exhaust waas hot as heck so I couldn't do much digging.

    I'm just looking for a few tips for in the morning when I start digging. I know this is an out there question, but I'm not the best mechanic so a little help is always appreciated. Thanks once again guys.
To Top