1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

power steering fluid

Discussion in '2nd Gen. Tacomas (2005-2015)' started by pudge151, Dec 7, 2010.

  1. Dec 7, 2010 at 2:32 PM
    #1
    pudge151

    pudge151 [OP] Well-Known Member

    Joined:
    Apr 4, 2010
    Member:
    #34558
    Messages:
    3,391
    Gender:
    Male
    First Name:
    Sean
    Connecticut
    Vehicle:
    2015 Tundra Platinum
    i was checking my fluids today and i noticed that it was low. it says to use Dextron Type ATF. I have a half quart or Dextron III / Mercon Auto Trans Fluid. It is red in color while the fluid in the truck looks like motor oil. Is this the right stuff to use? or is Dextron III ATF not the same as Dextron ATF?
     
  2. Dec 7, 2010 at 3:12 PM
    #2
    TRDKenE

    TRDKenE DAMN GOOD DEAL!!

    Joined:
    Jul 6, 2009
    Member:
    #19348
    Messages:
    698
    Gender:
    Male
    First Name:
    Kenny
    Richmond, Virginia
    Vehicle:
    '10 D-CAB OFF-ROAD 4X4
    TRD CAI, GrillCraft.
  3. Dec 7, 2010 at 3:16 PM
    #3
    pudge151

    pudge151 [OP] Well-Known Member

    Joined:
    Apr 4, 2010
    Member:
    #34558
    Messages:
    3,391
    Gender:
    Male
    First Name:
    Sean
    Connecticut
    Vehicle:
    2015 Tundra Platinum
    yes is the right stuff or yes its Dextron III is not the same at Dextron
     
  4. Dec 7, 2010 at 3:37 PM
    #4
    boonduff

    boonduff Proud American

    Joined:
    Nov 10, 2010
    Member:
    #46008
    Messages:
    14
    Gender:
    Male
    First Name:
    Gordie
    Chandler, AZ
    Vehicle:
    2011 DC TRD OFFROAD
    Bone stock brand new
    Yes its the right fluid. If the fluid in your truck is that dark it should be changed.
     
  5. Dec 7, 2010 at 3:38 PM
    #5
    KenLyns

    KenLyns Lord of War

    Joined:
    May 23, 2010
    Member:
    #37674
    Messages:
    25,163
    Gender:
    Male
    Belly of the Beast
    Vehicle:
    4x4 TRD Off Road Full-Auto
    All-Pro Bumper, CBI Sliders, Icon Coilovers, BudBuilt Skids, aFe Intake, Icon VS Rear Shocks, Timbren Bumpstops, All-Pro UCAs, JDM Steering Wheel, ViAir Compressor, Klearz LED 3rd Brake Light, Pop-N-Lock Tailgate Handle, Husky Front Flaps
    The service manual says Dexron II or III ATF, so you are good to go. The fluid will discolor over time due to moisture, heat, contamination...
     
  6. Dec 7, 2010 at 3:56 PM
    #6
    pudge151

    pudge151 [OP] Well-Known Member

    Joined:
    Apr 4, 2010
    Member:
    #34558
    Messages:
    3,391
    Gender:
    Male
    First Name:
    Sean
    Connecticut
    Vehicle:
    2015 Tundra Platinum
    its not dark its golden color like new oil
     
  7. Dec 7, 2010 at 3:57 PM
    #7
    pudge151

    pudge151 [OP] Well-Known Member

    Joined:
    Apr 4, 2010
    Member:
    #34558
    Messages:
    3,391
    Gender:
    Male
    First Name:
    Sean
    Connecticut
    Vehicle:
    2015 Tundra Platinum

    thanks
     
  8. Oct 16, 2011 at 8:15 PM
    #8
    BoTacoGA

    BoTacoGA Damit man

    Joined:
    Nov 16, 2010
    Member:
    #46283
    Messages:
    94
    Gender:
    Male
    First Name:
    Bo
    Newnan, GA
    Vehicle:
    08 Rugged OffRoad TRD
    Hid headlights an fog lights, LED blinkers an brake light bulbs. anytime fog light mod, brighter reverse light mod, Access Vanish bed cover, color match grill, black rocker guard painted skid plate, rear TSB, 5100's with front set at 1.75, BF T/A KO 265/75/16, yo mama riding shotgun.
    Anyone ever use Toyota WS trans fluid in the PS?
     
  9. Oct 16, 2011 at 10:48 PM
    #9
    saugus

    saugus Well-Known Member

    Joined:
    Sep 3, 2011
    Member:
    #62820
    Messages:
    340
    Gender:
    Male
    Vehicle:
    2006
    Mine was like that too. I flushed it and added dex.
     
To Top