1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

power steering issues

Discussion in '4 Cylinder' started by 2.7, Jan 2, 2013.

  1. Jan 2, 2013 at 10:43 AM
    #1
    2.7

    2.7 [OP] New Member

    Joined:
    Jan 1, 2013
    Member:
    #94159
    Messages:
    4
    Gender:
    Male
    First Name:
    Adam
    Fort Lauderdale Florida
    Vehicle:
    2.7 liter 4x 4 Tacoma
    new steering pump & new rack still no power steering I've been bleeding like my Haynes manual said but still no power steering?
     
  2. Jan 4, 2013 at 5:50 PM
    #2
    Steves104x4

    Steves104x4 Well-Known Member

    Joined:
    Apr 17, 2010
    Member:
    #35468
    Messages:
    6,422
    Gender:
    Male
    First Name:
    Steve
    Buffalo NY
    Vehicle:
    2010 RC 2.7 4x4
    BUCKLE UP! It makes it harder for Aliens to pull you out of your Truck.
    What the Hell? Anybody? [​IMG]
     
  3. Jan 4, 2013 at 5:53 PM
    #3
    blake5995

    blake5995 Well-Known Member

    Joined:
    Aug 12, 2012
    Member:
    #84632
    Messages:
    2,217
    Gender:
    Male
    First Name:
    Blake
    Truckee, CA
    Vehicle:
    98 Tacoma SR5 4x4 2.7L
    That pic is fucked up...
     
  4. Jan 4, 2013 at 10:50 PM
    #4
    tan4x4

    tan4x4 Well-Known Member

    Joined:
    Nov 30, 2011
    Member:
    #67982
    Messages:
    2,032
    Gender:
    Male
    First Name:
    Rick
    Folsom, CA
    Vehicle:
    99 Tacoma EC 4x4 2.7L Auto
    Bilsteins, OME 881's, 3-leaf AAL, Detroit TruTrac, 31" tires, Michelin LTX AT2, stock gears, Tranny skidplate, TC skidplate, CBI rear bumper, sliders, UltraGauge, PowerTank, CB
    Blocked or kinked hose?
    Air pocket?
     
  5. Jan 5, 2013 at 10:22 AM
    #5
    Ga tacoguy

    Ga tacoguy Well-Known Member

    Joined:
    Mar 2, 2012
    Member:
    #74020
    Messages:
    310
    Gender:
    Male
    First Name:
    Rudy
    Augusta Ga.
    Vehicle:
    Extended cab Base model 4 cyl
    Tailgate mod, horn mod,storage door mod
    :) Adam, you may try this to see if the fluid is reaching the rack. The small hose is the high pressure line from the pump, you may try to loosen the high pressure line connector at the pump and see if it leaks fluid.
    If there is fluid, I would raise the front wheels off the ground, and turn the steering wheel from lock to lock and see if the air will bleed out of the system. Good Luck
     
  6. Jan 5, 2013 at 10:25 AM
    #6
    Cbass38

    Cbass38 Well-Known Member

    Joined:
    Jul 26, 2011
    Member:
    #60562
    Messages:
    898
    Gender:
    Male
    First Name:
    sebastian
    scottsdale
    Vehicle:
    07 pre runner
    projector hids,wheels,small lift,flowmaster
    sometimes the inner plastic sleeve seperates from the p/s line and goes into the rack stopping fulid flow. but generally it makes a loud whining noise
     
  7. Jan 5, 2013 at 10:30 AM
    #7
    98tacoma27

    98tacoma27 :POOPCORN: Staff Member

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,163
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
    I think there is a screen in there somewhere that gets clogged.
     
To Top