1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

power steering problem

Discussion in 'Technical Chat' started by fitryders2, Mar 9, 2011.

  1. Mar 9, 2011 at 6:06 PM
    #1
    fitryders2

    fitryders2 [OP] Well-Known Member

    Joined:
    May 17, 2010
    Member:
    #37308
    Messages:
    56
    Gender:
    Male
    First Name:
    shawn
    virginia
    Vehicle:
    07 trd sport
    so my power steering is whining from the moment i start my truck until i turn it off. when i drive the whine gets louder with rpms. but if i turn the wheel at idle it doesnt increase whining. any ideas? power steering pumps are expensive and i just wanna see if anyone has any ideas before i buy a new pump to find out its something else. thanks
     
  2. Mar 9, 2011 at 6:10 PM
    #2
    Max-4_Yota

    Max-4_Yota The Welfare Cadilac

    Joined:
    Dec 10, 2009
    Member:
    #27357
    Messages:
    4,247
    Gender:
    Male
    First Name:
    Michael
    South Carolina
    Vehicle:
    04 Tacoma 4x4, V6, 5spd
    Squattin'
    Do you see any leaks?
     
  3. Mar 9, 2011 at 6:18 PM
    #3
    fitryders2

    fitryders2 [OP] Well-Known Member

    Joined:
    May 17, 2010
    Member:
    #37308
    Messages:
    56
    Gender:
    Male
    First Name:
    shawn
    virginia
    Vehicle:
    07 trd sport
    fluid level is fine. fluids arent clear but are clean. and i need to get up under it. there is a leak but it looks like the driver side cv axle seal. but i know the steering rack fittings are right over top of that. so yes i do need to look closer at that. but im pretty positive its the axles seal
     
  4. Mar 9, 2011 at 6:24 PM
    #4
    Max-4_Yota

    Max-4_Yota The Welfare Cadilac

    Joined:
    Dec 10, 2009
    Member:
    #27357
    Messages:
    4,247
    Gender:
    Male
    First Name:
    Michael
    South Carolina
    Vehicle:
    04 Tacoma 4x4, V6, 5spd
    Squattin'

    Check for leaks, mine went out a while back, one day it was fine, i crunk it up the next morning and it was whining like a baby, no fluid.
     
  5. Mar 9, 2011 at 6:26 PM
    #5
    fitryders2

    fitryders2 [OP] Well-Known Member

    Joined:
    May 17, 2010
    Member:
    #37308
    Messages:
    56
    Gender:
    Male
    First Name:
    shawn
    virginia
    Vehicle:
    07 trd sport
    k i guess ill keep checking fluid level till the weekend and see if anything changes. hopefully friday ill get some free time to check real good for leaks.
     
  6. Mar 9, 2011 at 7:19 PM
    #6
    fitryders2

    fitryders2 [OP] Well-Known Member

    Joined:
    May 17, 2010
    Member:
    #37308
    Messages:
    56
    Gender:
    Male
    First Name:
    shawn
    virginia
    Vehicle:
    07 trd sport
    Forgot to mention power steering still works fine.
     
To Top