1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Power steering pump issue...

Discussion in '2nd Gen. Tacomas (2005-2015)' started by MGH-PA, Mar 29, 2010.

  1. Mar 29, 2010 at 6:24 PM
    #1
    MGH-PA

    MGH-PA [OP] Well-Known Member

    Joined:
    Mar 19, 2009
    Member:
    #14940
    Messages:
    274
    Gender:
    Male
    Northcentral, PA
    Vehicle:
    05 Tacoma TRD AC 4x4
    265/75/16 Nitto Terra Grapplers, Bestop
    So a while back, I noticed signs of a leak around my power steering pump but the fluid levels were fine, and so was my steering (no whirring turning the wheel). I was in an accident back in Jan, and after the body work was done, I needed an alignment (front end hit). The steering wheel was at 90 degrees when the vehicle was tracking straight before the alignment. After the alignment, the steering wheel was good, but my steering was getting progressively sttiffer and especially worse during cold startup. To top it off, my fluid level dropped, and then I topped it off just to see what happened and the level maintained itself, but the steering was still very stiiff. Fast forward to today, I start the truck this morning, and the steering is 100% back to normal. Steering is easy and smooth and the power steering is working great even during warmup. I have a replacement pump waiting to go in, but now I'm wondering if is in fact the pump. If it was something in the steering linkage from the accident, I wouldn't think it would cure itself (then again, nor would a power steering pump). Is there something I'm missing here? Any suggestions?
     
  2. Mar 30, 2010 at 7:44 AM
    #2
    MGH-PA

    MGH-PA [OP] Well-Known Member

    Joined:
    Mar 19, 2009
    Member:
    #14940
    Messages:
    274
    Gender:
    Male
    Northcentral, PA
    Vehicle:
    05 Tacoma TRD AC 4x4
    265/75/16 Nitto Terra Grapplers, Bestop
    Bump for some help...
     
To Top