1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

power steering pump?

Discussion in '1st Gen. Tacomas (1995-2004)' started by jamey, Dec 25, 2012.

  1. Dec 25, 2012 at 12:04 AM
    #1
    jamey

    jamey [OP] Well-Known Member

    Joined:
    Jul 23, 2011
    Member:
    #60384
    Messages:
    136
    Gender:
    Male
    Mayport, FL
    Vehicle:
    2003 TRD Taco
    OME complete 3" lift with dakar leaf pack and AAL's Relentless fab sliders Uniden CB dynomat'd everything Focal 6" speakers 2 Kicker 10" subs JL Audio HD amp Kicker amp HID headlights LED lights in cab, bed of truck, and under hood. raptor lined bed sliders, and skids
    When i first crank my truck up in the morning it makes a humming sound that increases when i turn the wheel or accelerate. At first i thought loose belt but it's not a screeching high pitch sound (more of a hum) and it doesn't do it all the time. It stops after a couple of miles when the truck warms up. what do you guys think?
     
  2. Dec 26, 2012 at 9:58 PM
    #2
    jamey

    jamey [OP] Well-Known Member

    Joined:
    Jul 23, 2011
    Member:
    #60384
    Messages:
    136
    Gender:
    Male
    Mayport, FL
    Vehicle:
    2003 TRD Taco
    OME complete 3" lift with dakar leaf pack and AAL's Relentless fab sliders Uniden CB dynomat'd everything Focal 6" speakers 2 Kicker 10" subs JL Audio HD amp Kicker amp HID headlights LED lights in cab, bed of truck, and under hood. raptor lined bed sliders, and skids
    this must be a new record, 89 views with no replies!
     
  3. Dec 27, 2012 at 5:06 AM
    #3
    Aquatic Tacoma

    Aquatic Tacoma The bees know...

    Joined:
    Mar 10, 2011
    Member:
    #52776
    Messages:
    149
    Gender:
    Male
    Clearwater, Fl.
    Vehicle:
    99 Reg Cab 4x4 SR5, 2.7ltr, 5spd
    K&N, header, highflow cat
    Yep, most likely the pump. Mines been doing that for about 1 1/2 years. Getting worse recently though. If I turn fast like a quick U turn, it starts whinning for a few minutes until it calms down. Actually finally thinking about R & R.
     
To Top