1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

power steering screen cleaning

Discussion in '1st Gen. Tacomas (1995-2004)' started by dustinclm, May 17, 2011.

  1. May 17, 2011 at 10:00 AM
    #1
    dustinclm

    dustinclm [OP] Well-Known Member

    Joined:
    Apr 4, 2010
    Member:
    #34553
    Messages:
    500
    Gender:
    Male
    Thibodaux, La
    Vehicle:
    2012 Super White DC 4x4 V6
    Bilstein 5100 set at .85" WeatherTech Floor Mats
    how do you clean the screen on a 1st gen power steering pump?

    nevermind, fixed it.

    mods can delete ths
     
  2. May 17, 2011 at 10:56 AM
    #2
    NegroTundra

    NegroTundra Well-Known Member

    Joined:
    Oct 25, 2010
    Member:
    #45227
    Messages:
    652
    Gender:
    Male
    Land of Enchantment
    Vehicle:
    03 Tacoma TRD 4WD 5 spd
    why don't you tell us how you did it so this is a contributing thread?
     
  3. Oct 25, 2014 at 7:50 PM
    #3
    thunderone

    thunderone Trollin' TW since '09

    Joined:
    May 20, 2009
    Member:
    #17473
    Messages:
    2,097
    Gender:
    Male
    First Name:
    Mitchell
    Nashville, TN
    Vehicle:
    Not a Tacundra
  4. Oct 25, 2014 at 8:29 PM
    #4
    RAT PRODUCTS

    RAT PRODUCTS RAT Products

    Joined:
    Apr 12, 2010
    Member:
    #35140
    Messages:
    13,769
    Gender:
    Male
    First Name:
    Ryan
    Farmington, MN
    Vehicle:
    01 CUMTOY and 16 Sierra Denali
    View the build. Too much to list.
    Back flush the reservoir with mineral spirits. Rinse with clean atf.
     
  5. Oct 26, 2014 at 1:16 PM
    #5
    keakar

    keakar Well-Known Member

    Joined:
    Oct 2, 2014
    Member:
    #139537
    Messages:
    4,914
    Gender:
    Male
    First Name:
    karl
    louisiana
    Vehicle:
    2004 SR5 Tacoma 2wd Prerunner 3.4L v6 ext cab (white)
    hate it when people ask for help then not post the solution when they find it so others who might have a similar problem don't get the benefit of what was discovered to solve the problem.

    the point of a community forum is to help and share with others and not just get the help YOU need then keep it to your self and don't give the same form of help in passing on needed helpful info of the kind you were seeking when you came here
     
To Top