1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

powertrax issue

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Bigd1634, Jul 13, 2011.

  1. Jul 13, 2011 at 3:31 PM
    #1
    Bigd1634

    Bigd1634 [OP] Member

    Joined:
    Aug 11, 2009
    Member:
    #21000
    Messages:
    14
    Gender:
    Male
    First Name:
    Donald
    Kissimmee Florida
    27% tint, Vent Visors, Custom garage door opener, storage bin locks, 6000K HID headlights and foglights, Powertrax,
    I just finished installing the powertrax no-slip locker in my 2010 trd sport. The install went very well and easy. Now I am feeling a driveline bang or thump when I start from a stop, or accelerate from a coast. Also shifting from park or nuetral to reverse or drive is a little bit more rough then it used to be. Has anyone had this issue or is it normal?
     
  2. Jul 13, 2011 at 4:02 PM
    #2
    TanSR5x4

    TanSR5x4 Hold my beer and watch this

    Joined:
    Jul 24, 2010
    Member:
    #40669
    Messages:
    996
    Gender:
    Male
    First Name:
    William
    Houston TX
    Vehicle:
    00 Tacoma SR5 4x4
    Deckplate mod, black KC slimlight fogs, hurculined bed, NRA sticker mod, painted rear chrome bumper black, black fender flares and front grill surround, HIDs, All-pro rear leafs and UCAs, Eibach coilovers, billys all around, flat black pro comps, 31x10.5x15 BFG KM2s
    i just put a lock right in mine so ive put like maybe 5 miles on it but i havent noticed that yet
     
To Top