1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

prerunner TRD locker will not engage

Discussion in '2nd Gen. Tacomas (2005-2015)' started by MadTaco461, Sep 9, 2010.

  1. Sep 9, 2010 at 11:26 AM
    #1
    MadTaco461

    MadTaco461 [OP] Well-Known Member

    Joined:
    Dec 30, 2009
    Member:
    #28470
    Messages:
    5,629
    Gender:
    Male
    First Name:
    Mike
    Murrieta, CA
    Vehicle:
    99 turbo 5 lug long travel
    Kinda stock
    My brother has a 07 prerunner with the trd locker. We use it often, but a little bit ago the locker quit engaging.

    The problem is there is no sound from it trying to engage. When you hit the button I used to hear the click under the passenger airbag, the sound of the solenoid moving, and the click of the gears popping into place. Now we have none of that. Only thing that works is the ABS turns off. I tried the simple unplug the battery and reconnect later. The fuse is still good.

    Got desperate and check a few other things last week. The button is good and the black box under the passenger airbag is good. I plugged them on my buddy's tacoma and worked on his truck.

    I'm thinking the next place to look is the solenoid. Any ideas????
     
  2. Sep 9, 2010 at 11:39 AM
    #2
    MadTaco461

    MadTaco461 [OP] Well-Known Member

    Joined:
    Dec 30, 2009
    Member:
    #28470
    Messages:
    5,629
    Gender:
    Male
    First Name:
    Mike
    Murrieta, CA
    Vehicle:
    99 turbo 5 lug long travel
    Kinda stock
    I checked all the fuses behind the change holder and all the good.
     
  3. Sep 9, 2010 at 11:49 AM
    #3
    MadTaco461

    MadTaco461 [OP] Well-Known Member

    Joined:
    Dec 30, 2009
    Member:
    #28470
    Messages:
    5,629
    Gender:
    Male
    First Name:
    Mike
    Murrieta, CA
    Vehicle:
    99 turbo 5 lug long travel
    Kinda stock
    It does suck. From what my brother told me all the fuses under the hood are good too. I'll check for myself to make sure. I have a feeling they are good too since fuses are the things I go after first. The diff lock light blinks and turns off the ABS when activated but won't do the things I talked about in the first message
     
To Top