1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Pro Comp Shenanigans !!

Discussion in 'Wheels & Tires' started by evl21, Mar 10, 2013.

  1. evl21

    evl21 [OP] Active Member

    Joined:
    Aug 31, 2011
    Member:
    #62695
    Messages:
    42
    Gender:
    Male
    First Name:
    B
    CNY
    Vehicle:
    TRD OFF ROAD
    Tint,tonneau cover, Wet Okoles, EGR in channel rain gaurds, ATO rear bumper, not enough $$
    For once the weather wasn't horrible so I decided to throw my new rims and tires on. Everything was going good mounted them, test drove it, no shaking or anything. So happy with the results I figured the last step was to put the center caps on. Easy enough... one down no prob.. second one wouldn't thread in fact it was eating threads like a tap. So i grabbed an different cap and realized that 3 of my wheels threaded alike and one was a random shorter course thread !!! SO WTF :mad:!!! I almost stripped the damn thing , quality control... consistent product ?? All in all I love the new look just wanted to rant and point it out so no one else strips theirs out...

    20130310_142739.jpg
    20130310_135854.jpg
    20130310_143329.jpg
    20130310_135900.jpg
     
To Top