1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

question about fuel pump

Discussion in 'Technical Chat' started by Silvert, Jun 27, 2011.

  1. Jun 27, 2011 at 8:36 PM
    #1
    Silvert

    Silvert [OP] Well-Known Member

    Joined:
    May 1, 2011
    Member:
    #55888
    Messages:
    113
    Gender:
    Male
    First Name:
    Jeff
    Wisconsin
    Vehicle:
    2010 Tacoma reg. cab.,5sp., 4 cyl.
    I have a 2010 Tacoma reg. cab, 4 cylinder, 5 speed. Today, a good hour after I parked it in the garage I could hear a humming noise from the left rear. It sounded like the fuel pump was running. I turned the key on and off again and it stopped. Any ideas out there? Thanks, Jeff
     
  2. Jun 27, 2011 at 8:57 PM
    #2
    HondaGM

    HondaGM Roll Tide

    Joined:
    Oct 28, 2009
    Member:
    #25056
    Messages:
    5,804
    Gender:
    Male
    First Name:
    James
    South-Pole
    Vehicle:
    09 DC 4x4 Blown Honda VTEC V8
    trd exhaust,step bars,vent visors,bed lights,tailgate mod
    next time you hear it,loosen the gas cap and see if it goes away.it maybe venting the pressure from the fuel tank.
     
  3. Jun 28, 2011 at 5:39 AM
    #3
    Hardscrabble

    Hardscrabble Well-Known Member

    Joined:
    Feb 9, 2011
    Member:
    #50838
    Messages:
    1,464
    Gender:
    Male
    First Name:
    Scott
    McDonough, GA
    Vehicle:
    Timberland Mica 4X4
    Leather seats, WeatherTech's, Access LiteRider tonneau cover, extra D-rings in bed & tailgate. Pelley lightbar with Hella 700FF's. Temp./compass O/H console.
    I've had this happen to me on my 2011. Similar senario, parked in the garage on a warm day. I'm pretty sure it was the fuel pump venting the tank. I loosened the gas cap and a rush of air came out. The pump stopped immediately. I've wanted to look it up on a schematic to verify, just haven't taken the time.
     
  4. Jun 28, 2011 at 5:47 AM
    #4
    skytower

    skytower Well-Known Member

    Joined:
    Jun 7, 2010
    Member:
    #38505
    Messages:
    3,221
    Gender:
    Male
    First Name:
    Dave
    virginia
    Vehicle:
    08 Tacoma 4x4
    Hitch and wiring, aux back-up light, rear strobe lights, radio and underseat sub.
    That is the EVAP system working, not the fuel pump. It tests the vaccuum of the fuel system, checking for leaks.
     
  5. Jun 29, 2011 at 8:26 PM
    #5
    Silvert

    Silvert [OP] Well-Known Member

    Joined:
    May 1, 2011
    Member:
    #55888
    Messages:
    113
    Gender:
    Male
    First Name:
    Jeff
    Wisconsin
    Vehicle:
    2010 Tacoma reg. cab.,5sp., 4 cyl.
    Thanks for the great tips!
    Silvert
     
  6. Jun 29, 2011 at 8:27 PM
    #6
    whippersnapper02

    whippersnapper02 Well-Known Member

    Joined:
    Dec 20, 2009
    Member:
    #27905
    Messages:
    35,266
    Gender:
    Male
    First Name:
    Christian
    Yorba Linda, CA
    Vehicle:
    10 MGM TRD OR 4wd Auto DCSB
    Banks Monster Exhaust, Pop n Lock tailgate lock, Hook-Ups tie down brackets, USA Spec Ipod adaptor, WO seat covers, color matched grill with Grillcraft insert, Tuffy locking bed box
    X2. It does it after about 7 hours. It even says so in the manual.
     
To Top