1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Questions about the TRD CAI

Discussion in 'Performance and Tuning' started by Tebo, Apr 14, 2011.

  1. Apr 14, 2011 at 11:40 PM
    #1
    Tebo

    Tebo [OP] Active Member

    Joined:
    Jan 9, 2011
    Member:
    #48986
    Messages:
    34
    Gender:
    Male
    First Name:
    Esteban
    North Hills
    Vehicle:
    08 TRD 4dr Longbed
    So i keep searching it up and couldnt find anything about how to install a TRD CAI, so sorry if there is a thread out there. My question is, is it hard to install it yourself? Or who installed for you? Just interested in the process of it before i actually purchase it. Thanks guys!
     
  2. Apr 14, 2011 at 11:46 PM
    #2
    ktmrider

    ktmrider Senior Member

    Joined:
    Jul 20, 2009
    Member:
    #19933
    Messages:
    4,969
    Gender:
    Male
    Vehicle:
    07 DCLB 4x4 Sport S/C
    Junk
    Its super easy, dont even think about having a shop do it. The instructions included are pretty good and its self explanatory, rip stock crap off, put new stuff on.
     
  3. Apr 14, 2011 at 11:51 PM
    #3
    Tebo

    Tebo [OP] Active Member

    Joined:
    Jan 9, 2011
    Member:
    #48986
    Messages:
    34
    Gender:
    Male
    First Name:
    Esteban
    North Hills
    Vehicle:
    08 TRD 4dr Longbed
    Nice man i appreciate the quick response :D Im gonna get it then!!!
     
  4. Apr 16, 2011 at 8:18 PM
    #4
    Tebo

    Tebo [OP] Active Member

    Joined:
    Jan 9, 2011
    Member:
    #48986
    Messages:
    34
    Gender:
    Male
    First Name:
    Esteban
    North Hills
    Vehicle:
    08 TRD 4dr Longbed
    So it was only two days since i asked the question but i said fuck it i gotta grow some balls, so i bought it yesterday and received it today and the install took me about 2 hours only cause i needed to find the tools and i got frustrated finding the tools i needed and i took my time so here are the pics thanks again TW!!!! Sorry about the crappy evo pics
    Before
    [​IMG]
    Taking it off
    [​IMG]
    The finished product
    [​IMG]
     
To Top