1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Radio problems

Discussion in '2nd Gen. Tacomas (2005-2015)' started by upthemaiden, May 27, 2012.

  1. May 27, 2012 at 7:05 AM
    #1
    upthemaiden

    upthemaiden [OP] Well-Known Member

    Joined:
    Aug 26, 2011
    Member:
    #62408
    Messages:
    169
    Gender:
    Male
    First Name:
    Josh
    Pittsburgh PA
    Vehicle:
    06 Access cab SR5
    Just bought it!
    Found a bunch of people on here saying their radios just stopped working one day when they started their truck, or as they were driving, but I couldn't find much on my situation, hopefully someone will help.

    Been having constant problems with my Grom aux adapter not working, and the only thing that seems to fix it is pulling the stereo, removing it, and reinstalling it. I did that the other day, saw the little red led inside the adapter come on for a second, and then it sent out. Tried to turn the ignition on to see what it was doing and the entire stereo wouldn't turn on, including the clock. Airbag light still works fine. I know I should've disconnected the battery first but figured figured 'what's the worst that could happen??', obviously this. I checked the fuses, the #1 radio fuse(10) was fried, the #2(30) was fine. I replaced the 10, and still nothing. I checked every single fuse in the box just to make sure I wasn't missing one but all of them say they're good and still no stereo or clock. Anyone have any idea what I might be missing??

    Now I know people say the stereos are junk and stop working, so I started browsing ebay thinking maybe I just fried my stereo and need to replace it, but then I remembered that when people sell the stereos they usually pull out the clocks, which makes me assume the clock must be wired in separately from the rest of the stereo, and even if I replaced that it still wouldn't explain why the clock went out.... unless the clock just plugs into the stereo and that's where it gets it's power from.

    Any ideas as to what else I should check??
     
  2. May 27, 2012 at 7:12 AM
    #2
    Highland Logan

    Highland Logan UBIQUE

    Joined:
    Apr 11, 2011
    Member:
    #54752
    Messages:
    2,801
    Gender:
    Male
    First Name:
    Frank
    Nova Scotia, Canada
    Vehicle:
    2011 Black AC TRD Off Road w/ factory tow pkg
    Icon Stage 2 w/ overload left in, SPC LR UCA, 265/75 16 BFG KO2, front and rear Weathertech floor liners, OEM (Extang) solid fold tonneau, OEM bed mat, OEM front skid plate, OEM billet oil cap, "TOYOYA" tailgate decal
    If someone doesn't have the answer, the FSM (Factory Service Manual) can be found here. Included is the wiring diagram. Best of luck.

    Frank
     
  3. May 27, 2012 at 7:46 AM
    #3
    upthemaiden

    upthemaiden [OP] Well-Known Member

    Joined:
    Aug 26, 2011
    Member:
    #62408
    Messages:
    169
    Gender:
    Male
    First Name:
    Josh
    Pittsburgh PA
    Vehicle:
    06 Access cab SR5
    Just bought it!
    wow, even if I can't use it to fix my stereo, that's still awesome, thanks!
     
  4. May 27, 2012 at 9:29 AM
    #4
    Highland Logan

    Highland Logan UBIQUE

    Joined:
    Apr 11, 2011
    Member:
    #54752
    Messages:
    2,801
    Gender:
    Male
    First Name:
    Frank
    Nova Scotia, Canada
    Vehicle:
    2011 Black AC TRD Off Road w/ factory tow pkg
    Icon Stage 2 w/ overload left in, SPC LR UCA, 265/75 16 BFG KO2, front and rear Weathertech floor liners, OEM (Extang) solid fold tonneau, OEM bed mat, OEM front skid plate, OEM billet oil cap, "TOYOYA" tailgate decal
    Use the image button when setting up your sig, and it will show as a picture rather than a link.

    Frank
     
  5. May 31, 2012 at 8:23 PM
    #5
    upthemaiden

    upthemaiden [OP] Well-Known Member

    Joined:
    Aug 26, 2011
    Member:
    #62408
    Messages:
    169
    Gender:
    Male
    First Name:
    Josh
    Pittsburgh PA
    Vehicle:
    06 Access cab SR5
    Just bought it!
    I've been looking through the wiring diagram and looking at things in the truck better and maybe someone can help now out with what I figured out. The parts that seem to not be working are: radio, clock, cigarette lighter, power socket. As far as the wiring diagram, pages 51 and 54 seem to be what I need, 51 has the cigarette lighter and power socket, page 54 has the radio and clock. My truck is a 2006 access cab sr5. I'm not good with wiring diagrams but I've been trying to copy down the path from the battery to all of these parts to see what they have in common, and they all go from the battery, to (2C), to 140A/120A AH, with the exception of the actual radio receiver which goes from the battery to (2C) to the 10a radio #1 fuse. Now pretty much everything in the wiring diagram says it runs through 2C, so I'm not sure what that even is but I don't think it's the problem. The diagram also makes it look like the hazard lights are wired into the clock, but the hazard lights still work, while the clock doesn't.

    I had previously checked all of the fuses, which seem good. The 10A radio fuse was the one that blew before but I replaced it. What about those other things in the fuse box that that don't look like normal fuses, is there anything to check with one of those?

    If no one else really has an idea I'll just have to take it into the shop and see what that can do for me :(
     
  6. Jul 2, 2012 at 6:46 PM
    #6
    aptech

    aptech Jetfixer

    Joined:
    Apr 6, 2012
    Member:
    #76417
    Messages:
    3,187
    Gender:
    Male
    First Name:
    Adrian
    houston (angleton)
    Vehicle:
    10 dc offroad
    daystar level kit, tsb rear spring, ghostflames, sport hood, tsb steering, trd cai, red map lights. backup cam any time mod, fog light any time mod. bed light mod. 400watt inverter mod. 2857516 dura tracs. beach sand intsall
    if your fuse blow then maybe your wire is gone or shorted. id ring the wire out and then check to see if it is shorted to ground:(
     
  7. Jul 3, 2012 at 6:04 AM
    #7
    paidfor

    paidfor Well-Known Member

    Joined:
    Aug 21, 2009
    Member:
    #21536
    Messages:
    755
    Gender:
    Male
    Austin, TX
    Vehicle:
    2013 TRD OR 4x4
    Hidden GPS tracking system. Backflip cover, weather techs, bed mat, tailgate lock, OME 885 springs, blistein shocks, 2.5 in AAL/
    I had my radio replaced 3 times under warranty. It is out of warranty now and has been for a couple of years. It now turns off by itself - again. Dealership said I was on my own. I am replacing it this week with an aftermarket. JBL is a POS
     
To Top