1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Randomly cuts power while driving

Discussion in '2nd Gen. Tacomas (2005-2015)' started by SubFrozen, Mar 14, 2011.

  1. Mar 14, 2011 at 2:32 PM
    #1
    SubFrozen

    SubFrozen [OP] r00t

    Joined:
    Oct 20, 2009
    Member:
    #24632
    Messages:
    389
    Gender:
    Male
    First Name:
    William
    Sandy, UT
    Vehicle:
    2007 Taco SR5 V6
    3" OME Heavy Duty Lift, 18" Chrome Rimes, ARB Front Bumper, K&N Cold Air Intake
    Hey guys. Was driving for an hour or so last night and the truck started to power off and immediately back on. RPM would drop to zero then bounce back. I would hear grinding when it happened. Speed is about 80mph. There's no seemingly apparent trigger for the event; so long as I'm driving, it happens at random, sometimes half an hour between, other, merely minutes.

    The battery connectors are fine. No check engine light comes on, and it will be difficult to replicate at a dealership. Any ideas where I can start to troubleshoot this?
     
  2. Mar 15, 2011 at 12:54 AM
    #2
    MountainEarth

    MountainEarth Well-Known Member

    Joined:
    Feb 1, 2010
    Member:
    #30519
    Messages:
    2,487
    Gender:
    Male
    First Name:
    Bryan
    CO
    Vehicle:
    2010 TRD OR Access
    Leer 100XR Shell, BedRug mat - comfy sleeping, GT Covers microfiber seat covers, BFG All Terrains 265/70r16, Dashmat, Antennax 13" shorty antenna, Weathertech liners, Ultra Gauge, Avid Light Bar, PIAA 520 ATPs, one old dog
  3. Mar 16, 2011 at 7:52 AM
    #3
    BFA

    BFA Nuttier than squirrel shit.

    Joined:
    Dec 13, 2009
    Member:
    #27447
    Messages:
    2,409
    Gender:
    Male
    First Name:
    Brian
    Phoenix, AZ
    Vehicle:
    2003 3.4 4x4 5spd
    does it do that at lower speeds? id get it checked out as well
     
  4. Mar 16, 2011 at 8:01 AM
    #4
    Cmatt1605

    Cmatt1605 Well-Known Member

    Joined:
    Oct 18, 2010
    Member:
    #44883
    Messages:
    112
    Gender:
    Male
    First Name:
    Cody
    Mount Pleasant, South Carolina
    Squeaky leaf fix
    buddy of mine had a Chevy that this happened on, it was the alternator.
     
  5. Mar 16, 2011 at 8:10 AM
    #5
    BFA

    BFA Nuttier than squirrel shit.

    Joined:
    Dec 13, 2009
    Member:
    #27447
    Messages:
    2,409
    Gender:
    Male
    First Name:
    Brian
    Phoenix, AZ
    Vehicle:
    2003 3.4 4x4 5spd
    yeah but the alt going out on an 07? seems a little soon for that but shit does break.. the belt could possibly be loose so the alt doesnt generate enough power but thats pretty far fetched i think
     
  6. Mar 16, 2011 at 8:47 AM
    #6
    franzcars

    franzcars I'm different, in a different way

    Joined:
    Mar 2, 2011
    Member:
    #52165
    Messages:
    362
    Gender:
    Male
    First Name:
    Justin
    ST.louis MO
    Vehicle:
    08 Base Taco I4
    Plasti-dipped rims, blacked out Taco logos, small interior mods, AFE prodry drop-in, DJM 3/4 drop, Viper alarm, Power locks, Fogs, Viper 305 alarm, Kenwood HU
    i'd check everything upfront. im no expert but maybe the belt could be stretching or you just got a bad alternator. i think autozone does alternator check for free or low cost. also have them check ur obd 2 with their scanner while ur there
     
  7. Mar 16, 2011 at 8:51 AM
    #7
    krimson

    krimson Nothin

    Joined:
    May 17, 2008
    Member:
    #6714
    Messages:
    3,412
    Vehicle:
    TRD Off Road
    OME 3" lift with 885 coils. OME Shocks with TSB 1.5 AAL. 285/75/16 KM2s. XD Hoss 16" wheels. DDM Tuning 6000K HIDs, H10 6000K Fogs. BHLM. Debaged. 20% tint on front windows.
    Could be the alternator. This happened to me in my Ford, i was going up on a bridge then next thing i notice everything on my gauge dropped to zero and my truck died.
     
To Top