1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Rear Icon suspension squeak...Help needed

Discussion in 'Suspension' started by lvcarguy, Jul 8, 2012.

  1. Jul 8, 2012 at 11:55 AM
    #1
    lvcarguy

    lvcarguy [OP] Well-Known Member

    Joined:
    Nov 19, 2011
    Member:
    #67310
    Messages:
    47
    Gender:
    Male
    First Name:
    David
    Las Vegas
    Vehicle:
    12 4x4 DCSB Debadged
    ICON stage II lift w front coil overs 3" lift with Camburg UCA's and 1 1/2" add a leaf & ICON rear shocks, SS front and rear brake lines, TRD Exhaust, TRD skid plate, 33/12.5/17 MT General Red Labels, 17x8 Centerline wheels in matte, 6000k head and fog lights, 20% tint, 12" black shorty antenna, debadged, TRD oil filler cap, TRD radiator car, TRD shift knob, TRD all weather floor mats
    I have a 12 DCSB TRD Sport 4x4 that I put Icon CO in the front w Cambridge UCAs and the rear has Icon 2.0 aluminum Monotube shocks w 1.5" AAL. My questions is, I have a pretty annoying squeak coming from the rear of my truck. It happens both while driving and if you just hop in the bed of the truck to grab something. My truck only has 4k miles on it and the lift was installed right after I left the dealership when buying it new, i also havent had the time to do any major trails ( pretty much a mall queen at this point ). I moved right after I bought the truck so I can't take it to who I had install my lift, but I took it to Dirty Parts in LA ( not a huge fan of them ) and All they wanted to do was spray liquid grease everywhere, that didn't help at all. The second shop I took it to said they thought the rear shocks were bad, so I called Icon and they said they have had some complaints about squeaking shocks and are replacing them for free, so I got a second pair of shocks from them. I replaced the old shocks with the new ones and the noise is definitely better but is still there. I'm now back in Vegas and had a 3rd shop look at it and they said it was the rear shocks are bad.

    Has anyone else had this problem with Icons? Am I to believe a 3rd set of shocks will work this time? Should I just get a different brand of rear shocks or a different kind? Anyone have any ideas to make the noise go away. It's pretty frustrating. Any advice or help is greatly appreciated.
     
  2. Jul 9, 2012 at 6:19 AM
    #2
    Sublime

    Sublime Well-Known Member

    Joined:
    Nov 14, 2009
    Member:
    #25918
    Messages:
    3,729
    Gender:
    Male
    First Name:
    Mike
    Phoenix, AZ
    Vehicle:
    08 TRD 4x4
    Icon/All Pro.....chopped for 35's
    You sure it's not the springs?.....they do that. Also, check the top nut of the shocks and make sure they're tightned down enough.

    Race trucks parts make race truck noises!
     
  3. Jul 14, 2012 at 5:56 PM
    #3
    lvcarguy

    lvcarguy [OP] Well-Known Member

    Joined:
    Nov 19, 2011
    Member:
    #67310
    Messages:
    47
    Gender:
    Male
    First Name:
    David
    Las Vegas
    Vehicle:
    12 4x4 DCSB Debadged
    ICON stage II lift w front coil overs 3" lift with Camburg UCA's and 1 1/2" add a leaf & ICON rear shocks, SS front and rear brake lines, TRD Exhaust, TRD skid plate, 33/12.5/17 MT General Red Labels, 17x8 Centerline wheels in matte, 6000k head and fog lights, 20% tint, 12" black shorty antenna, debadged, TRD oil filler cap, TRD radiator car, TRD shift knob, TRD all weather floor mats
    Sorry for just responding now, I haven't been able to log on this past week at work. When I took it to Dirty Parts in LA ( wont ever go back ) they sprayed liquid grease up and down the whole underside of my truck, they didn't separate the leaf springs, but had me bouncing on the rear bumper while they sprayed to try and get the grease in between. I'll try the grease again, but it is pretty greased up underneath in the rear.

    As for the rear shocks, sublime and wolfpack, both of those are good ideas and I'll try both of those.

    Thank you for advice/help, I'll let you know the progress. thanks again, I know with lifted trucks, they are rarely ever perfect, but this squeaking is definitely annoying.
     
  4. Jul 17, 2012 at 8:22 AM
    #4
    Zombie Runner

    Zombie Runner Are these black helicopters for me?

    Joined:
    Mar 13, 2008
    Member:
    #5246
    Messages:
    15,077
    Gender:
    Male
    First Name:
    Kevin
    Wichita Falls, TX
    Vehicle:
    Tundra, double cab.
    LED interior lights, stubby antenna, Pioneer in dash screen
    My 2010 has squeaked since day 2... I keep a can of wd40 in the truck and spray my leafs when needed.
     
  5. Sep 21, 2012 at 2:35 PM
    #5
    tacoma jesse

    tacoma jesse New Member

    Joined:
    Sep 21, 2012
    Member:
    #87420
    Messages:
    1
    Gender:
    Male
    lake arrowhead
    Vehicle:
    04 tacoma limited
    2.0 race runner coilovers, k&n intake, magnaflow, locker mod, maglight mod, ect
    Have you checked the hiem joints on them. I have racerunner 2.0 coilovers and hd a bad squeek over every little bump or crack and I took the coilovers off and foundout the hiem joint was bad and it fixed the problem
     
  6. Sep 21, 2012 at 3:14 PM
    #6
    Sublime

    Sublime Well-Known Member

    Joined:
    Nov 14, 2009
    Member:
    #25918
    Messages:
    3,729
    Gender:
    Male
    First Name:
    Mike
    Phoenix, AZ
    Vehicle:
    08 TRD 4x4
    Icon/All Pro.....chopped for 35's
    Your first post was bumping a 2 month old thread? LOL

    Welcome anyways!
     
  7. Jul 7, 2013 at 10:27 PM
    #7
    theYETI

    theYETI Member

    Joined:
    Jul 29, 2012
    Member:
    #83664
    Messages:
    12
    Gender:
    Male
    First Name:
    David
    Grass Valley, CA
    Vehicle:
    2006 Double Cab TRD Off-Road
    I know this is an old thread my my icon 2.0 shocks are also squeaking. It definitely is the shocks not my springs.
     
  8. Jul 7, 2013 at 10:45 PM
    #8
    Mitch

    Mitch Somebody call for a Wambulance?

    Joined:
    Jun 27, 2011
    Member:
    #58964
    Messages:
    5,845
    Gender:
    Male
    First Name:
    Mitch
    Tigard, OR
    Vehicle:
    2007 Access Cab SR5 4x4
    Lights, Siren, Drugs, Needles, Electricity
    David call Icon
     
  9. Jul 7, 2013 at 10:53 PM
    #9
    hondarider215

    hondarider215 Well-Known Member

    Joined:
    Feb 2, 2012
    Member:
    #71969
    Messages:
    281
    Gender:
    Male
    First Name:
    Wes
    Socal
    Vehicle:
    KR Tacoma
    KR Fabrication front and rear bumper ICON 2.5 c/o's All pro leafs Maxtrac Fox rear resi shocks Lr uca 17" methods
    I've had problems with my front icons squeaking since day 1. I called them they did a rebuild under warranty and I got them back and was squeak free for 2 months but its back again. They said its just the seals. So I'm sure the rear has the same seals that are failing. My warranty is up but I'm gonna call and see what they can do for me.
     
  10. Jul 10, 2013 at 9:22 PM
    #10
    ICONRep

    ICONRep Direct Representative Vendor

    Joined:
    Oct 23, 2012
    Member:
    #89638
    Messages:
    225
    Gender:
    Male
    You should always call right away if you feel like you are having an issue with an ICON product. We will def work with you to find the issue, and figure out some sort of solution. Please do not hesitate.

    We are on here to support you and the products we offer. You can call me directly at the shop if you want to talk about anything.

    Brad
    951-689-4266




    ICON Vehicle Dynamics
    www.iconvehicledynamics.com
     
To Top