1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Rear left turn signal brighter than taillight

Discussion in '1st Gen. Tacomas (1995-2004)' started by byrdthomas4x4, Mar 15, 2019 at 3:46 PM.

  1. Mar 15, 2019 at 3:46 PM
    #1
    byrdthomas4x4

    byrdthomas4x4 [OP] New Member

    Joined:
    Friday
    Member:
    #286730
    Messages:
    2
    Gender:
    Male
    First Name:
    Thomas
    Vehicle:
    2004 toyota tacoma sr5 4x4
    When i turn my lights on. My left turnsignal comes on solid and stays on. Im wondering with it
     
  2. Mar 15, 2019 at 3:48 PM
    #2
    cabowabotacoma

    cabowabotacoma Well-Known Member

    Joined:
    Feb 17, 2019
    Member:
    #283327
    Messages:
    227
    Gender:
    Male
    First Name:
    Rob
  3. Mar 15, 2019 at 3:50 PM
    #3
    cabowabotacoma

    cabowabotacoma Well-Known Member

    Joined:
    Feb 17, 2019
    Member:
    #283327
    Messages:
    227
    Gender:
    Male
    First Name:
    Rob
    Trying to think of something but I gotta face it - I ain’t good with that
     
  4. Mar 15, 2019 at 4:00 PM
    #4
    jbrandt

    jbrandt Well-Known Member

    Joined:
    Feb 12, 2011
    Member:
    #51038
    Messages:
    6,954
    Gender:
    Male
    Sacramento, CA
    Vehicle:
    '04 TRD Tacoma 4x4 DC
    King ext travel coils Total Chaos UCAs Sticker mod
    Has this always happened as far as you know, or is this new?

    Have you done some work to it recently?

    My bet is it's a short in the wiring, or maybe a bad switch. Do the turn signals work with the lights on?
     
  5. Mar 15, 2019 at 8:53 PM
    #5
    byrdthomas4x4

    byrdthomas4x4 [OP] New Member

    Joined:
    Friday
    Member:
    #286730
    Messages:
    2
    Gender:
    Male
    First Name:
    Thomas
    Vehicle:
    2004 toyota tacoma sr5 4x4
    The right side works fine but the left side just stays lit and doesnt work
     
  6. Mar 16, 2019 at 3:37 AM
    #6
    RysiuM

    RysiuM Well-Known Member

    Joined:
    Oct 18, 2015
    Member:
    #167004
    Messages:
    1,550
    Gender:
    Male
    First Name:
    Rysiu
    Was Golden State, now Poland EU
    Vehicle:
    1995 4x4 LX Ext Cab, I4 2.7, MT, 320K miles
    DD Deck+backup camera, LED DRL, All LED except H4 Hella
    Standard question: do you have trailer harness adapter installed? If they go bad, they can do $hit to lighting.
     
    cruxofthebisquit likes this.
  7. Mar 16, 2019 at 3:41 AM
    #7
    knayrb

    knayrb Well-Known Member

    Joined:
    Mar 3, 2010
    Member:
    #32473
    Messages:
    1,481
    Gender:
    Male
    Somewhere in the square states
    Vehicle:
    2010 Dbl-Cab Off-Road
    Pure stock
    Have you replaced the bulb? It could be cracked and air got in. The filament is burning away. $2 easy try.
     
  8. Mar 16, 2019 at 3:46 AM
    #8
    RysiuM

    RysiuM Well-Known Member

    Joined:
    Oct 18, 2015
    Member:
    #167004
    Messages:
    1,550
    Gender:
    Male
    First Name:
    Rysiu
    Was Golden State, now Poland EU
    Vehicle:
    1995 4x4 LX Ext Cab, I4 2.7, MT, 320K miles
    DD Deck+backup camera, LED DRL, All LED except H4 Hella
    :confused: Wut?:confused: What does that have to do with the price of tea in China?
     
  9. Mar 16, 2019 at 4:23 AM
    #9
    Btoz

    Btoz Member

    Joined:
    Wednesday
    Member:
    #286530
    Messages:
    6
    Gender:
    Male
    First Name:
    Brent
    Vehicle:
    1998 Tacoma 2004 Tacoma 2008 Tacoma 2008 4Runner
    Nothing really
    Check and/or add a ground at the left rear tail light at terminal 3, White/Black wire. If the lights operate correctly, you can make the ground permanent or trace the White/Black wire. I have seen the 4 flat trailer converter boxes cause all kind of weird crap, if you have one, remove it first then check bulbs.
     
  10. Mar 16, 2019 at 4:54 AM
    #10
    Troyken

    Troyken Well-Known Member

    Joined:
    Mar 23, 2015
    Member:
    #151577
    Messages:
    339
    Gender:
    Male
    NY
    Vehicle:
    2013 DCSB v6 off road 4x4 6 spd. MT
    Remove any convertor plugged into trailer light socket if equipped and recheck. Then liberally flush out the socket with WD-40. It could be a bad convertor and /or corrosion in the socket itself. If no trailer socket, check tail light sockets and bulbs for corrosion and clean as required with power OFF. If you have added any aftermarket LED bulbs remove them first and reinstall original bulbs and recheck.
     

Products Discussed in

To Top