1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

rear license plate light assemblies

Discussion in '2nd Gen. Tacomas (2005-2015)' started by piercedtiger, Nov 14, 2012.

  1. Apr 12, 2013 at 4:56 AM
    #21
    PSJ

    PSJ Prerunners Work

    Joined:
    Nov 9, 2008
    Member:
    #10620
    Messages:
    1,348
    Gender:
    Male
    Sebastian Inlet
    Vehicle:
    09 Access Cab Prerunner
    Rear Leaf spring TSB, Bilstein 5100's all around w/ front set at 1.75", 265/75R/16 Mickey Thompson Baja STZ's, Trailer hitch w/custom wiring, AFE drop in dry filter, Rear Diff breather mod, Debadged truck, customized stock TRD wheel center caps, added factory fog lights, bed mat, door sills, tinted windows
    Do you know why your light socket has melted? Or that bulbs blow when you plug new ones in? Might want to look into this....;)
     
  2. Apr 12, 2013 at 6:34 AM
    #22
    piercedtiger

    piercedtiger [OP] Devout Atheist

    Joined:
    Oct 29, 2007
    Member:
    #3284
    Messages:
    6,365
    Gender:
    Male
    First Name:
    Jon
    B.F.E., NY
    Vehicle:
    06 TRD OR DC SB 6SPD
    Bestop canopy, hood struts, relocated 7-pin, 3" Toytec spacer/AAL, 265/75 16 Yokohama Geolander ATS, Hi-Lift mounted in bed, fog light mod, turn signal mod, locker mod, driver seat mag light mount, step bars, reinforced tailgate, ABS kill switch, black grill surround, bed lights, Brute Force front
    For me, I'm assuming the bulb burned out due to the corroded, shorted, melted contacts. As for why that happened, the clear lens part had a crack so maybe water got in?
     
To Top