1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Rear suspension help......

Discussion in 'Suspension' started by Hunter500ky, Jun 13, 2011.

  1. Jun 13, 2011 at 9:36 AM
    #1
    Hunter500ky

    Hunter500ky [OP] Well-Known Member

    Joined:
    Dec 2, 2010
    Member:
    #47031
    Messages:
    2,521
    Gender:
    Male
    E-Town Ky
    Vehicle:
    06 Tacoma 4x4 SR5
    Weathertech Mats, Toolbox, 6k HID fogs, Hardwire Escort 8500 x50,
    Well guys not to happy right now posted in my build thread but figured I should post it here.....

    I ordered some shocks from demello, I got the new TJMs and it seems the rear shocks are wrong I already called and they are going to call me back.

    But im in the middle of the lift....

    So I was just making sure I am right before I get somewhat annoyed, not at them because stuff happens just in general....



    Ok heres the issue, I got my entire rear end almost out then said well better check my new stuff....


    Well I get my rear shocks and notice they seem a lot bigger, I get my old bolt that mounts in the bottom of the shock and it has a lot of play in it, I dont think that is right.

    Also I went ahead and took the band off to check the length, its also the same length I told him I had a 2" AAl so I would figure its supposed to be bigger right?

    Also the bottom of the new shock might fit in the location its supposed to go but doesnt seem it wants to, I dont want to force it in because it might have to go back......

    So advice? Im in no way trying to slam demello because mistakes do happen just making sure Im not going crazy...



    Also last question, since the rear end is almost done can I go ahead and put my new leafs in while waiting on correct shocks if that is the issue?


    Thanks!!!
     
  2. Jun 13, 2011 at 9:40 AM
    #2
    Hunter500ky

    Hunter500ky [OP] Well-Known Member

    Joined:
    Dec 2, 2010
    Member:
    #47031
    Messages:
    2,521
    Gender:
    Male
    E-Town Ky
    Vehicle:
    06 Tacoma 4x4 SR5
    Weathertech Mats, Toolbox, 6k HID fogs, Hardwire Escort 8500 x50,
    Thanks, going to go ahead and put them in then!
     
  3. Jun 13, 2011 at 11:09 AM
    #3
    Hunter500ky

    Hunter500ky [OP] Well-Known Member

    Joined:
    Dec 2, 2010
    Member:
    #47031
    Messages:
    2,521
    Gender:
    Male
    E-Town Ky
    Vehicle:
    06 Tacoma 4x4 SR5
    Weathertech Mats, Toolbox, 6k HID fogs, Hardwire Escort 8500 x50,
    39 views? 1 response jesh!
     
  4. Jun 13, 2011 at 11:27 AM
    #4
    Downsouth Motorsports

    Downsouth Motorsports Downsouth Motorsport Vendor

    Joined:
    Nov 28, 2008
    Member:
    #11116
    Messages:
    1,983
    Gender:
    Male
    Mission Valley, San Diego
    Front King 2.5, Coilovers, Camburg UCA, Rear King 2.0 Shocks, Lots of Tinted Windows, Cherry Third Owner
    With these issues and the fact that they're same length as stock, sounds like they're just the wrong shocks. I wouldn't risk scratching/damaging them because you'll need to return them.

    As for the springs, you will run the risk of topping out the shocks because of the added lift, until you get the shocks swapped out. But I'd say you'll probably be OK for a couple of days if you're just driving on street... Just don't go launching your Tacoma!!:eek:
     
  5. Jun 14, 2011 at 7:29 AM
    #5
    Hunter500ky

    Hunter500ky [OP] Well-Known Member

    Joined:
    Dec 2, 2010
    Member:
    #47031
    Messages:
    2,521
    Gender:
    Male
    E-Town Ky
    Vehicle:
    06 Tacoma 4x4 SR5
    Weathertech Mats, Toolbox, 6k HID fogs, Hardwire Escort 8500 x50,
    Ok so Im doing great so far, I took the shocks to a shop to have them put the top spacer on the new shocks and coils.

    I came with 2 rings each goldish rings where do these go in the shock assembly that way I know they did it right?


    Thanks guys couldnt do it without you
     
  6. Jun 14, 2011 at 8:42 AM
    #6
    Hunter500ky

    Hunter500ky [OP] Well-Known Member

    Joined:
    Dec 2, 2010
    Member:
    #47031
    Messages:
    2,521
    Gender:
    Male
    E-Town Ky
    Vehicle:
    06 Tacoma 4x4 SR5
    Weathertech Mats, Toolbox, 6k HID fogs, Hardwire Escort 8500 x50,
    Negative, they are new shocks and coils.

    But in the boxes with the shocks, there was a small bag with two goldish rings. Looks like they might fit on the shock or something lol, hopefully the shop knows what they are doing lol
     
  7. Jun 14, 2011 at 9:38 AM
    #7
    Hunter500ky

    Hunter500ky [OP] Well-Known Member

    Joined:
    Dec 2, 2010
    Member:
    #47031
    Messages:
    2,521
    Gender:
    Male
    E-Town Ky
    Vehicle:
    06 Tacoma 4x4 SR5
    Weathertech Mats, Toolbox, 6k HID fogs, Hardwire Escort 8500 x50,
To Top