1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Rough idle?

Discussion in '2nd Gen. Tacomas (2005-2015)' started by USNavyTaco, Apr 14, 2011.

  1. Apr 14, 2011 at 12:19 PM
    #1
    USNavyTaco

    USNavyTaco [OP] Well-Known Member

    Joined:
    Mar 6, 2011
    Member:
    #52481
    Messages:
    147
    Gender:
    Male
    Goose Creek SC
    Vehicle:
    06 Tacoma prerunner sr5 with mods
    2 inch coil spacers up front, tsb rear, Kobalt toolbox, westin bull bar, driver seat height mod, jvc head unit, rag joint zip tie truss mod, 17inch alloy 4runner sr5 rims wrapped in 265 yoko geolanders, off road lights, uhaul hitch, tacoma seat covers, avs vent visors, debadged prerunner, mud flaps gone, scanguage II, glovebox shock absorber mod,flowmaster 40 exhaust,
    My 06 Tacoma v6 seems to have a shake when in park, not in drive. The shake is not constant. Seems to fluctuate between a vibration and a shimmy. Opened engine bay, and visibly saw engine cover and oil cap shaking. 46,000 miles on it. Just wondering if this vibration is normal for the 4.0 L v-6? If not, what can be done about it? rpm's are normal as well
     
  2. Apr 14, 2011 at 3:03 PM
    #2
    NYCO

    NYCO ┌∩┐‹(ಠ_ಠ)›┌∩┐

    Joined:
    Jul 27, 2010
    Member:
    #40842
    Messages:
    17,318
    Gender:
    Male
    First Name:
    bOb
    Colorado
    Vehicle:
    Blue Betty - '06 TRD OR
    dents & scratches
    check out the "similar threads" that are located at the bottom of this thread...good starting point
     
  3. Apr 14, 2011 at 3:04 PM
    #3
    NYCO

    NYCO ┌∩┐‹(ಠ_ಠ)›┌∩┐

    Joined:
    Jul 27, 2010
    Member:
    #40842
    Messages:
    17,318
    Gender:
    Male
    First Name:
    bOb
    Colorado
    Vehicle:
    Blue Betty - '06 TRD OR
    dents & scratches
    i notice some roughness here and there...i noticed less of a roughness when i put in my new fuel pump and fuel system cleaners seem to keep the engine running fairly smooth
     
  4. Apr 14, 2011 at 4:50 PM
    #4
    USNavyTaco

    USNavyTaco [OP] Well-Known Member

    Joined:
    Mar 6, 2011
    Member:
    #52481
    Messages:
    147
    Gender:
    Male
    Goose Creek SC
    Vehicle:
    06 Tacoma prerunner sr5 with mods
    2 inch coil spacers up front, tsb rear, Kobalt toolbox, westin bull bar, driver seat height mod, jvc head unit, rag joint zip tie truss mod, 17inch alloy 4runner sr5 rims wrapped in 265 yoko geolanders, off road lights, uhaul hitch, tacoma seat covers, avs vent visors, debadged prerunner, mud flaps gone, scanguage II, glovebox shock absorber mod,flowmaster 40 exhaust,
    I'll look for chevron techron. Any brands to stay away from?(stp?)

    Also, I'm getting new plugs, tb cleaned within next 3000 miles
     
  5. Apr 14, 2011 at 5:43 PM
    #5
    NYCO

    NYCO ┌∩┐‹(ಠ_ಠ)›┌∩┐

    Joined:
    Jul 27, 2010
    Member:
    #40842
    Messages:
    17,318
    Gender:
    Male
    First Name:
    bOb
    Colorado
    Vehicle:
    Blue Betty - '06 TRD OR
    dents & scratches
    i usually go with the lucas fuel system treatment
     
  6. Apr 14, 2011 at 8:10 PM
    #6
    USNavyTaco

    USNavyTaco [OP] Well-Known Member

    Joined:
    Mar 6, 2011
    Member:
    #52481
    Messages:
    147
    Gender:
    Male
    Goose Creek SC
    Vehicle:
    06 Tacoma prerunner sr5 with mods
    2 inch coil spacers up front, tsb rear, Kobalt toolbox, westin bull bar, driver seat height mod, jvc head unit, rag joint zip tie truss mod, 17inch alloy 4runner sr5 rims wrapped in 265 yoko geolanders, off road lights, uhaul hitch, tacoma seat covers, avs vent visors, debadged prerunner, mud flaps gone, scanguage II, glovebox shock absorber mod,flowmaster 40 exhaust,
    Just a thought, if the fuel injector cleaner does not solve this. Could it be caused by something more serious?

    Vaccuum leak? Engine/Tranny Mounts?

    I thought it may be a vaccuum leak, but wouldn't I experience a high idle speed?

    and engine mounts and tranny mounts, wouldnt i experience nasty vibrations all the time?
     
  7. Apr 14, 2011 at 9:42 PM
    #7
    nvdeserted

    nvdeserted Well-Known Member

    Joined:
    Nov 27, 2008
    Member:
    #11062
    Messages:
    1,305
    Gender:
    Male
    Reno, NV
    Vehicle:
    2009 Tacoma TRD OR Access Cab
    Electric Dynolock tailgate, TrailGear Slides, , 285/75-16 Yoko Geolanders on Wheelers Type B, SAW 2.0 front and back, Camburg b/j UCA, 1.5" AAL, Ubolt flip, ARB bump.
    The rough idle can be caused by a number of things, from a loose splug, dirty MAF, dirty airfilter, bad coil, bad gas, etc.

    It might be worth it to, dare I say it? have a mechanic run a diagnostic... just find out what it is, then fix it yourself; no point in replacing perfectly funtioning items while hunting down the problem.
     
  8. Apr 14, 2011 at 9:53 PM
    #8
    USNavyTaco

    USNavyTaco [OP] Well-Known Member

    Joined:
    Mar 6, 2011
    Member:
    #52481
    Messages:
    147
    Gender:
    Male
    Goose Creek SC
    Vehicle:
    06 Tacoma prerunner sr5 with mods
    2 inch coil spacers up front, tsb rear, Kobalt toolbox, westin bull bar, driver seat height mod, jvc head unit, rag joint zip tie truss mod, 17inch alloy 4runner sr5 rims wrapped in 265 yoko geolanders, off road lights, uhaul hitch, tacoma seat covers, avs vent visors, debadged prerunner, mud flaps gone, scanguage II, glovebox shock absorber mod,flowmaster 40 exhaust,
    Already checked airfilter.

    I'll start with the cheap repair possibilities. First thing I'll do is add a bottle of fuel injector cleaner next time I fill up the tank (probably Wednesday). If that doesn't fix it. I'll live with it till next oil change, when I'm due for new spark plugs and a throttle body cleaning anyway. If it still idles rough, I'll have a diagnostic run. But this could simply be a bad tank of gas anyway. So I won't jump to any expensive conclusions. Also, as long as it's not getting worse, I won't worry about it too much till tune up time comes.
     
  9. Apr 14, 2011 at 9:56 PM
    #9
    nvdeserted

    nvdeserted Well-Known Member

    Joined:
    Nov 27, 2008
    Member:
    #11062
    Messages:
    1,305
    Gender:
    Male
    Reno, NV
    Vehicle:
    2009 Tacoma TRD OR Access Cab
    Electric Dynolock tailgate, TrailGear Slides, , 285/75-16 Yoko Geolanders on Wheelers Type B, SAW 2.0 front and back, Camburg b/j UCA, 1.5" AAL, Ubolt flip, ARB bump.
    Are you driving alot of dirty/dusty conditions? or is stuff staying pretty clean?

    the reason I ask is because if it's dust related, that'll help narrow it down; similarly, if you're not eating dust, then that can help rule out some possibilities too.
     
  10. Apr 14, 2011 at 10:12 PM
    #10
    USNavyTaco

    USNavyTaco [OP] Well-Known Member

    Joined:
    Mar 6, 2011
    Member:
    #52481
    Messages:
    147
    Gender:
    Male
    Goose Creek SC
    Vehicle:
    06 Tacoma prerunner sr5 with mods
    2 inch coil spacers up front, tsb rear, Kobalt toolbox, westin bull bar, driver seat height mod, jvc head unit, rag joint zip tie truss mod, 17inch alloy 4runner sr5 rims wrapped in 265 yoko geolanders, off road lights, uhaul hitch, tacoma seat covers, avs vent visors, debadged prerunner, mud flaps gone, scanguage II, glovebox shock absorber mod,flowmaster 40 exhaust,
    Staying on road.
     
  11. Apr 14, 2011 at 10:15 PM
    #11
    nvdeserted

    nvdeserted Well-Known Member

    Joined:
    Nov 27, 2008
    Member:
    #11062
    Messages:
    1,305
    Gender:
    Male
    Reno, NV
    Vehicle:
    2009 Tacoma TRD OR Access Cab
    Electric Dynolock tailgate, TrailGear Slides, , 285/75-16 Yoko Geolanders on Wheelers Type B, SAW 2.0 front and back, Camburg b/j UCA, 1.5" AAL, Ubolt flip, ARB bump.
    In that case I'd focus first on fuel, injectors, throttle body, coil, plugs (not necessarily in that order)
     
  12. Apr 14, 2011 at 10:24 PM
    #12
    USNavyTaco

    USNavyTaco [OP] Well-Known Member

    Joined:
    Mar 6, 2011
    Member:
    #52481
    Messages:
    147
    Gender:
    Male
    Goose Creek SC
    Vehicle:
    06 Tacoma prerunner sr5 with mods
    2 inch coil spacers up front, tsb rear, Kobalt toolbox, westin bull bar, driver seat height mod, jvc head unit, rag joint zip tie truss mod, 17inch alloy 4runner sr5 rims wrapped in 265 yoko geolanders, off road lights, uhaul hitch, tacoma seat covers, avs vent visors, debadged prerunner, mud flaps gone, scanguage II, glovebox shock absorber mod,flowmaster 40 exhaust,
    Yes that was my general plan. In search of a potential problem today, I just discovered how long the tacomas oil dip stick was. The thing is like 5 feet long!
     
To Top