1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

running wierd!!

Discussion in '4 Cylinder' started by 99TacomaTRD, Jul 5, 2010.

  1. Jul 5, 2010 at 6:46 AM
    #1
    99TacomaTRD

    99TacomaTRD [OP] Member

    Joined:
    Jul 5, 2010
    Member:
    #39804
    Messages:
    8
    Gender:
    Male
    First Name:
    Ethan
    Union Ky
    Vehicle:
    99 tacoma reg cab 4X4
    2inch lift. 32's tube bumpers front and rear
    i have a 99 tacoma with the 2.7. i have put new plugs new wires and used that MAF sensor cleaner. when its sittin there idling it sounds like it has a cam in it or somethin. it seems kinda under powered but then again im not use to a 4 banger. i have also run injector cleaner through it and it still does it. Would a new MAFS fix it? or O2 sensors? :help:
     
  2. Jul 5, 2010 at 11:30 AM
    #2
    xsvtoyz

    xsvtoyz Well-Known Member

    Joined:
    Sep 9, 2008
    Member:
    #9099
    Messages:
    182
    Gender:
    Male
    First Name:
    AL
    Oklahoma
    Vehicle:
    03 Pre-Runner Inprogress
    HID (ACA)/ Web cams/ Header/Full Custom exhaust/ K&N FIPK II/SuperCharger
    are you sure you got the firing order right?
     
  3. Jul 5, 2010 at 5:33 PM
    #3
    micropiper

    micropiper Admiral of the JOLLY ROGER navy

    Joined:
    Aug 22, 2009
    Member:
    #21577
    Messages:
    195
    Gender:
    Male
    First Name:
    damion
    phoenix az
    Vehicle:
    Four cylinders of pure awesome
    k&n air filter in a modded intake, sliders, new horn, plenty o pinstripes, custom onboard air,cobra cb with custom skidplate,
    get new wires!
     
  4. Jul 5, 2010 at 5:47 PM
    #4
    ktmrider

    ktmrider Senior Member

    Joined:
    Jul 20, 2009
    Member:
    #19933
    Messages:
    4,956
    Gender:
    Male
    Vehicle:
    07 DCLB 4x4 Sport S/C
    Junk
    sea foam
     
  5. Jul 6, 2010 at 1:34 PM
    #5
    99TacomaTRD

    99TacomaTRD [OP] Member

    Joined:
    Jul 5, 2010
    Member:
    #39804
    Messages:
    8
    Gender:
    Male
    First Name:
    Ethan
    Union Ky
    Vehicle:
    99 tacoma reg cab 4X4
    2inch lift. 32's tube bumpers front and rear
    yea i have the right firing order. and i just put new wires on it. and ill have to try that sea foam. were can i get it?:mudding:
     
  6. Jul 8, 2010 at 5:22 PM
    #6
    silverback

    silverback Well-Known Member

    Joined:
    Oct 23, 2009
    Member:
    #24802
    Messages:
    445
    Gender:
    Male
    First Name:
    Jason
    central CA
    Vehicle:
    2006 Prerunner SR5
    painted door handles, bilstein 5100's front and back, K&N air filter. Precision power component speakers and Kenwood deck.
    grab a can at autozone. Only poor half in your vacuum brake line. Let it go until it stalls. let it sit for about 20 min start it up and give it alittle constant 2500k rev. Bunch of blue smoke will come out. Take the rest of the can and throw it in your gas tank.
     
  7. Jul 8, 2010 at 6:46 PM
    #7
    dually

    dually Low and slow

    Joined:
    Jul 29, 2008
    Member:
    #8205
    Messages:
    3,161
    Gender:
    Male
    Interstate underpass
    Vehicle:
    '16 Inferno SR5 DCLB
    265/75R16 Falken Wildpeak AT3 LED Bulbs Access Lorado
    Codes. And are you totally sure about the correct order of the plug wires? The coil packs are numbered with the associating cylinder
     
  8. Jul 9, 2010 at 6:41 AM
    #8
    99TacomaTRD

    99TacomaTRD [OP] Member

    Joined:
    Jul 5, 2010
    Member:
    #39804
    Messages:
    8
    Gender:
    Male
    First Name:
    Ethan
    Union Ky
    Vehicle:
    99 tacoma reg cab 4X4
    2inch lift. 32's tube bumpers front and rear
    i put the sea foam in the taco and it helped alot with power. its the only toyota ive had that i can cherp 2nd. but it still has a rough idle to it.
    And ive checked the firing order and its all hooked up right.
     
To Top