1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Rust + Corrosion due to salt/salt water

Discussion in 'Technical Chat' started by jds0912, Mar 9, 2011.

  1. Mar 9, 2011 at 11:39 AM
    #1
    jds0912

    jds0912 [OP] Well-Known Member

    Joined:
    Jan 18, 2011
    Member:
    #49488
    Messages:
    505
    Gender:
    Male
    First Name:
    Justin
    Baltimore, MD
    Vehicle:
    2007 Tacoma TRD Off Road
    Some shit I got on craigslist
    Hey all. I bought a truck this xmass from a local guy who said it was his business vehicle. I’ve put about 1500 miles on it and everything seems to be fine mechanically. I do, however, notice that there is quite a bit of corrosion on bolts/connectors in the engine bay, and some rust on the rear underside of the car. There was an Assateague Island permit on the truck which makes me think he had it on the beach/exposed to salt spray and possibly salt water :eek:. We have also had a few nasty winters since 2007, so there's a bunch of salt on the roads every winter which would explain a lot of the rust on the hitch ect.

    Is there anything I should do to stop the corrosion/rust? Anything I should look for to ensure there's not salt water wreaking havoc internally? I am about to do my 60k maintenance.

    Thanks!
     
  2. Mar 9, 2011 at 7:08 PM
    #2
    jrdbrn

    jrdbrn Borne Fishing

    Joined:
    Aug 10, 2009
    Member:
    #20973
    Messages:
    1,428
    Gender:
    Male
    First Name:
    Jared
    Louisiana
    Vehicle:
    '16 Inferno Tacoma TSS
    Pay someone to put an undercoat
     
To Top