1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Rust on rear bumper

Discussion in '2nd Gen. Tacomas (2005-2015)' started by jm3280, Mar 2, 2010.

  1. Mar 2, 2010 at 3:46 AM
    #1
    jm3280

    jm3280 [OP] Well-Known Member

    Joined:
    Feb 3, 2010
    Member:
    #30666
    Messages:
    61
    Gender:
    Male
    First Name:
    Jay
    Allentown, PA
    Vehicle:
    2010 TRD Off Road
    Ok, so I have a 2010 Double cab TRD Off Road. Had it for about a month. So yesterday I took it to the wash, not the drive thru. I washed it with all my quarters then brought it home to wipe it down. When i was done wiping it down I noticed a bunch of what looked like rust spots on the rear bumper. Well the steam began to come out of my ears. Long story short I began to pick at it and it started to come off. I used one of those magic erasers and it took it completely off, guess it wasnt rust but what??? Any ideas what may have happened?? Totally freaked me out.
     
  2. Mar 2, 2010 at 3:49 AM
    #2
    Mark C.

    Mark C. If you want it bad, you usually get it bad!

    Joined:
    Nov 20, 2009
    Member:
    #26250
    Messages:
    1,248
    Gender:
    Male
    First Name:
    Mark
    Connecticut
    Vehicle:
    2010 MGM SR5 4WD AC
    LED Dome, Reed Switched LEDs in Glove Box and Center Console, Bumper Fogs, Tailgate anti-theft, LEDs over Cig lighter, Back-up camera anytime, Outside Temp add-on, Hidden GPS power, Sockmonkey 3rd Brakelight decal, 4X4 switch illumination, reed switch controlled engine compartment Flood LEDs, Elite Hitch Cover, Plasti-dipped cupholders and door switch control panels, Elite Hitch Cover.
    Could have been most anything from the road. I had the same scare here in CT...and was worried because I live on the coast. I used bug and tar remover and it took it right off. I followed it up with a quick coat of wax.
     
  3. Mar 2, 2010 at 4:19 AM
    #3
    grivera

    grivera Well-Known Member

    Joined:
    Sep 25, 2008
    Member:
    #9474
    Messages:
    783
    Gender:
    Male
    Hanover, MD
    Vehicle:
    '08 DC SR5 4x4, Desert Sand Mica
    Rear Suspension TSB, Bilstein 5100 on all 4 corners-fronts set at 1.75". BFG A/T's @ 265/75/16; Access LE Roll-up cover; Iron Cross Tube SS Steps; Fumoto valve; WeatherTech Liners; AFE Pro-Dry; front side windows tinted 20%; TW Decal!
  4. Mar 2, 2010 at 4:41 AM
    #4
    jm3280

    jm3280 [OP] Well-Known Member

    Joined:
    Feb 3, 2010
    Member:
    #30666
    Messages:
    61
    Gender:
    Male
    First Name:
    Jay
    Allentown, PA
    Vehicle:
    2010 TRD Off Road
    Ok, well I feel a little better, mines not the only one. I guess I should of not tried to take it off and just took it back to the dealer. If I see it again its going back, and maybe just get the black bumper that comes on the sport. I had an 06 same truck and this never happened. Thanks everyone.
     
To Top