1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Seat Belt Mount Squeak Solution

Discussion in '2nd Gen. Tacomas (2005-2015)' started by avengedkevinfold, Oct 25, 2011.

  1. Oct 25, 2011 at 1:18 PM
    #1
    avengedkevinfold

    avengedkevinfold [OP] Well-Known Member

    Joined:
    Jan 9, 2011
    Member:
    #48997
    Messages:
    156
    Gender:
    Male
    First Name:
    Kevin
    Socal - OC - Huntington Beach
    bilstien 5100s all the way around, ICON progressive 3 leaf kit, Illegal tint, snuglid SL, seatbelt chime mod. light racing UCAs
    I have a 2011 Tacoma and when I go over bumps, my seatbelt tension changes and appears to bend the seat belt clip metal art (that attachesto the seat) and it squeaks. Has anybody had this problem? Seems like a small place to put lubricant to stop the squeak. (to be honest I still don't know EXACTLY where its coming from. however i know its coming from a location near where you clip in the seat belt on the drivers side.)

    thanks
     
  2. Oct 25, 2011 at 1:21 PM
    #2
    gooch14

    gooch14 Well-Known Member

    Joined:
    Dec 20, 2010
    Member:
    #47968
    Messages:
    2,677
    Gender:
    Male
    First Name:
    Kyle
    Michigan
    Vehicle:
    2011 Blk DC Taco SR5 4x LB
    Bestop, Child Seats, petrified french fry, dog hair, empty Mtn Dew cans cracked windshield, scratches.
    I have a crazy squeek that I can't locate as well. Drives me bananas.
     
  3. Oct 25, 2011 at 4:41 PM
    #3
    supralight

    supralight Well-Known Member

    Joined:
    Aug 20, 2009
    Member:
    #21479
    Messages:
    674
    Gender:
    Male
    First Name:
    Dan
    Earth
    Vehicle:
    2013 4Runner limited
    Got this problem too on my '11. I tried lubricating the interior of the seatbelt lock with jigaloo, did not fix the problem. Now when I hear the squeek, I hammer a few punch on the seatbelt lock (because it drives me crazy) and this fixes the noise for some time.

    Would really like to hear a more permanent solution to that problem :)

    Edit: as far as I can see, the noise doesn't come from the mount, but from the interior of the locking mechanism.
     
  4. Aug 29, 2012 at 7:49 PM
    #4
    teamfast

    teamfast Get busy living, or get busy dying.

    Joined:
    Jul 6, 2010
    Member:
    #39840
    Messages:
    871
    Gender:
    Male
    Winnipeg, Manitoba
    Vehicle:
    '10 DCLB
    BFG AT TKO2s 34 x 10.5 x17, Leer 550 Tonneau cover, weather tech digi fit liners, Viper 5901 remote start/security, 2" fr spacer, 3" TC AAL, All Pro IFS skid plate, Trans skid plate & Transfer Case skid plate, 12" roof mounted flip down dvd player, In channel vent visors.
    Im looking into this.
     
  5. Aug 30, 2012 at 3:57 PM
    #5
    knphee

    knphee Member

    Joined:
    Aug 5, 2010
    Member:
    #41295
    Messages:
    20
    Gender:
    Male
    Calgary, AB CANADA
    Vehicle:
    2011 AccessCab TRD OR
    Mine does this too, however I would call it more like a creaking noise.

    At first I thought the creaking noise came solely from the locator pins at the bottom of the driver seat - the dealer removed the pins as per the TSB. That eliminated most of the creaking noise but I still noticed the occassional creak from time to time. I've only just come to the conclusion that the remaining noise seems to come from the seat belt lever itself. Wheven ever I put on the seat belt and manually pull up the 'lever' to it's full upright position, I NEVER hear any creaking. It's now become a routine to do this as soon as I put on my seatbelt.

    However, any one with a solution to this would be greatly appreciated!
    KN
     
  6. Aug 30, 2012 at 4:20 PM
    #6
    XPOTRPR

    XPOTRPR [[[[[[EXPOtrooper]]]]]] IG: xpotrpr

    Joined:
    May 29, 2011
    Member:
    #57449
    Messages:
    22,449
    Gender:
    Male
    First Name:
    Moose
    Chandler, AZ
    Vehicle:
    SUPERCHARGED MID TRAVEL 2009 DCSB TRD O/R 4X4 AUTO
    CHECK BUILD
    Not sure if I had the same problem.. but I had a creaking/rattle sound In my B pillar as well.. I would hit it and push on it to get It to stop. Was constant. So, over the weekend i took it all apart and started wiggling and shaking everything trying to duplicate the sound.. Im pretty sure i found It. There's a blue plastic box like cover for something Inside the pillar.. its just clipped In.. but mine was super loose and rattled like crazy when moved. So, I taped that bish up. It's solid now. And.. as far as I know solved the problem. Again. Not sure if Its the same thing you guys are dealing with.. but I know the frustration your goin through.
     
  7. Sep 8, 2012 at 5:14 PM
    #7
    teamfast

    teamfast Get busy living, or get busy dying.

    Joined:
    Jul 6, 2010
    Member:
    #39840
    Messages:
    871
    Gender:
    Male
    Winnipeg, Manitoba
    Vehicle:
    '10 DCLB
    BFG AT TKO2s 34 x 10.5 x17, Leer 550 Tonneau cover, weather tech digi fit liners, Viper 5901 remote start/security, 2" fr spacer, 3" TC AAL, All Pro IFS skid plate, Trans skid plate & Transfer Case skid plate, 12" roof mounted flip down dvd player, In channel vent visors.
    Mine is def coming from the buckle mechanism.
     
  8. Jun 18, 2013 at 2:11 PM
    #8
    TwzteD

    TwzteD Well-Known Member

    Joined:
    Mar 28, 2011
    Member:
    #53902
    Messages:
    708
    Gender:
    Male
    First Name:
    Kyle
    St Lucie Fl
    Vehicle:
    2013 4x4 reg cab Auto
    2013 4x4 reg cab, 2011 4runner sr5 rims, 265 general grabber at2's, 5100's All 4 corners with fronts at .85, De badged, Egr Rainguards, Led tail lights, Int wipers, fog lights, Trailer Hitch, POwer locks+ keyless entry, Extang Solidfold Bed Cover, WeatherTech Mats, Stubbie Antenna, Trd Skid Plate, Tint, Scanguage, Cargo net in bed, Sound Ordnance B-8PT, FULID FILM Under Coat.
    I have a 13 with the same issue
     
  9. Jun 19, 2013 at 7:11 PM
    #9
    Danmcw45

    Danmcw45 Well-Known Member

    Joined:
    Dec 9, 2012
    Member:
    #92771
    Messages:
    66
    Gender:
    Male
    First Name:
    Dan
    Philadelphia
    -TRD supercharger -Truxedo lo-pro qt tonneau -Wet okole front seat covers -17" method fat five wheels -2014 Tacoma entune/nav headunit - black badges - flowmaster dual exit cat-back exhaust, swapped 50 series muffler for a super 40 series muffler for more sound
    Yea got same type of noise over bumps. Seems to be when colder out more then warm. But not consistant enough to take it to the dealer
     
  10. Jun 19, 2013 at 7:13 PM
    #10
    Danmcw45

    Danmcw45 Well-Known Member

    Joined:
    Dec 9, 2012
    Member:
    #92771
    Messages:
    66
    Gender:
    Male
    First Name:
    Dan
    Philadelphia
    -TRD supercharger -Truxedo lo-pro qt tonneau -Wet okole front seat covers -17" method fat five wheels -2014 Tacoma entune/nav headunit - black badges - flowmaster dual exit cat-back exhaust, swapped 50 series muffler for a super 40 series muffler for more sound
    Mine is a 2013 dcsb
     
  11. Jun 20, 2013 at 4:37 AM
    #11
    Jadpitt27

    Jadpitt27 Active Member

    Joined:
    May 25, 2013
    Member:
    #104852
    Messages:
    32
    Gender:
    Male
    Vehicle:
    2013 Access Cab TRD OR
    My '13 just started this yesterday at 3200 miles
     
  12. Sep 27, 2013 at 7:09 AM
    #12
    The109

    The109 Well-Known Member

    Joined:
    Oct 17, 2012
    Member:
    #89193
    Messages:
    321
    Gender:
    Male
    First Name:
    Joe
    Saint Louis, MO
    Vehicle:
    2013 TRD Access Cab
    My '13 started this almost right after my 15K maintenance check. At first I thought it was coming from the column, then the seat, now I'm positive it's the seat belt mount. If I wiggle it back and forth I can recreate the sound.

    FFFFFFFUUUUUUUUUUUUUUUUU!!!!!!
     
  13. Sep 27, 2013 at 7:17 AM
    #13
    Bogg

    Bogg Well-Known Member

    Joined:
    Apr 16, 2011
    Member:
    #55035
    Messages:
    513
    Gender:
    Male
    Vancouver, Canada
    Vehicle:
    07 DCLB Sport 4x4
    My 07 has been doing this for a while now. Pretty sure it's coming from the buckle mechanism. If I tug on the seatbelt I can sometimes recreate the sound. Interested to see how others rectify the issue
     
  14. Sep 27, 2013 at 9:46 AM
    #14
    XPOTRPR

    XPOTRPR [[[[[[EXPOtrooper]]]]]] IG: xpotrpr

    Joined:
    May 29, 2011
    Member:
    #57449
    Messages:
    22,449
    Gender:
    Male
    First Name:
    Moose
    Chandler, AZ
    Vehicle:
    SUPERCHARGED MID TRAVEL 2009 DCSB TRD O/R 4X4 AUTO
    CHECK BUILD
    After doing my previous fix (see above post).. the rattles came back. I took it apart once again, and used ensolite foam (sound deadening material) on all parts, mechanisms, etc inside the B pillar.. problem solved. There is alot of loose, moving pieces inside. So that's the cause.
     
  15. Oct 28, 2013 at 7:11 AM
    #15
    Normantaco

    Normantaco Well-Known Member

    Joined:
    Oct 1, 2012
    Member:
    #88100
    Messages:
    435
    Gender:
    Male
    Pensacola, Fl
    Vehicle:
    12 Dcab 4x4
    2012 dcsb have squeak in latch that will go away for a few minutes if I wiggle the latch. I took it in to dealer before 36k warranty expired and the dealer ordered a new seat belt latch. It will be installed this week. I'll update if it solves the problem or not.
     
To Top