1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Security Light Flashing

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Celtic Bob, Apr 10, 2010.

  1. Apr 10, 2010 at 2:55 AM
    #1
    Celtic Bob

    Celtic Bob [OP] Well-Known Member

    Joined:
    Feb 15, 2010
    Member:
    #31399
    Messages:
    69
    Gender:
    Male
    I just finished installing an amp and head unit in my new 2010 Tacoma. I have now noticed that the dash security light (by the clock) keeps flashing untill the key is in the ignition. I never noticed this before. Did I mess something up or is this normal on the 2010's?
    Thanks
    b.
     
  2. Apr 10, 2010 at 3:20 AM
    #2
    Celtic Bob

    Celtic Bob [OP] Well-Known Member

    Joined:
    Feb 15, 2010
    Member:
    #31399
    Messages:
    69
    Gender:
    Male
    Thanks
    It goes out once the key is in but back on once it is taken out. I just never noticed it before on this one or my previous 06
     
  3. Apr 10, 2010 at 4:17 AM
    #3
    Celtic Bob

    Celtic Bob [OP] Well-Known Member

    Joined:
    Feb 15, 2010
    Member:
    #31399
    Messages:
    69
    Gender:
    Male
    all is good, adios
     
  4. Apr 10, 2010 at 11:01 AM
    #4
    kenstar

    kenstar Get a Lil Mud on the Tares

    Joined:
    Feb 8, 2010
    Member:
    #30962
    Messages:
    153
    Gender:
    Male
    First Name:
    Ken
    Wrenching in the garage.
    Vehicle:
    10 4x4 TRD OR
    Pop 'n' Lock, EGR In-Chan, Bakflip G2, 6112, 5160, Dakar Set. Redline hood struts. WildPeak At3. TRD Pro Wheels. Apex Fab Fog lights; Other shit I can't remember.
    rofl. I noticed this the first night I brought my car home. My dad noticed it. After thumbing through the manual found my answer.
     
  5. Apr 10, 2010 at 11:37 AM
    #5
    Okkine

    Okkine Well-Known Member

    Joined:
    Jun 26, 2008
    Member:
    #7590
    Messages:
    771
    Gender:
    Male
    Vancouver, BC
    Vehicle:
    2009 Magnetic Grey Access Cab - 2.7L I4 - 4x2
    Yep, just the electronic immobilizer. Prevents the truck from starting when a key without the proper chip is used. It's standard (by law) on Canadian vehicles, and optional on American vehicles. If you have a key made at the local hardware store, you'll be able to use it to open the doors, but if you try to start the engine with it, the light will stay flashing, and the engine will won't start.
     
  6. Sep 30, 2012 at 6:10 PM
    #6
    moelov

    moelov Well-Known Member

    Joined:
    Aug 19, 2010
    Member:
    #41920
    Messages:
    261
    Gender:
    Male
    USA
    Vehicle:
    09 PreRunner SR5 Lifted
    Removed the Mud Flaps, Rock Deflectors and Head Rest. Limo Tint, I had 3" Toytec Lift, Procomp Nitrogen ES6000 shocks and Struts. AllPro UCA, AFE Pro Dry drop in filter, WeatherTecs. Now I have LR UCA's, Maxtrac Spindles, Eibach's, 5100's up front, Expos, 5160 for the rear, U Bolt Flip Kit, and Extended Brake lines.
    Ok so I'm having this problem now. Last night I sat in the truck finishing a phone call.
    This evening I got into the truck and before I put the key in I noticed the light flashing.
    I turned the key started the truck then turned it off, pulled the key out and the security indicator came on.

    I know forsure in the past the light only comes on when I lock the truck.

    What could be causing this?
     
  7. Oct 1, 2012 at 5:54 AM
    #7
    moelov

    moelov Well-Known Member

    Joined:
    Aug 19, 2010
    Member:
    #41920
    Messages:
    261
    Gender:
    Male
    USA
    Vehicle:
    09 PreRunner SR5 Lifted
    Removed the Mud Flaps, Rock Deflectors and Head Rest. Limo Tint, I had 3" Toytec Lift, Procomp Nitrogen ES6000 shocks and Struts. AllPro UCA, AFE Pro Dry drop in filter, WeatherTecs. Now I have LR UCA's, Maxtrac Spindles, Eibach's, 5100's up front, Expos, 5160 for the rear, U Bolt Flip Kit, and Extended Brake lines.
    Weird, I just don't ever remember seeing the security light flashing when I'm sitting in the truck on a call while the keys are out of the ignition.

    Anyone else?
     
  8. Oct 1, 2012 at 7:46 AM
    #8
    photonashville

    photonashville Well-Known Member

    Joined:
    Aug 5, 2012
    Member:
    #84177
    Messages:
    96
    Gender:
    Male
    First Name:
    John
    Nashville, TN
    Vehicle:
    06 Silver DCLB TRD Sport 4x4
    Basic stuff, Leer 100R, Yakima rack, Billy 5100s
    That flashing light is not an issue. My wife's 2000 4Runner does it and so does my 2006 Tacoma. It's just part of the vehicle security. No one reads owner manuals anymore.
     
  9. Oct 1, 2012 at 3:42 PM
    #9
    moelov

    moelov Well-Known Member

    Joined:
    Aug 19, 2010
    Member:
    #41920
    Messages:
    261
    Gender:
    Male
    USA
    Vehicle:
    09 PreRunner SR5 Lifted
    Removed the Mud Flaps, Rock Deflectors and Head Rest. Limo Tint, I had 3" Toytec Lift, Procomp Nitrogen ES6000 shocks and Struts. AllPro UCA, AFE Pro Dry drop in filter, WeatherTecs. Now I have LR UCA's, Maxtrac Spindles, Eibach's, 5100's up front, Expos, 5160 for the rear, U Bolt Flip Kit, and Extended Brake lines.
    No, I searched before before starting a new thread.

    And yes I looked it up. Page 76 in the 2009 Owners Manual.

    Well I guess It never really bothered me before. I swear I don't remember.

    Thanks.
     
  10. Oct 1, 2012 at 3:57 PM
    #10
    OffroadToy

    OffroadToy This ain't Dodge City, and you ain't Bill Hickok

    Joined:
    Sep 12, 2009
    Member:
    #22680
    Messages:
    5,258
    Gender:
    Male
    Vehicle:
    07 TRD OFFROAD 4x4 VSC/TRAC/DAC/HAC
    snugtop, piaa, weathertech, westin, oem bed mat, trd seat covers, avs inchannel vent visors, 2" suspension lift, front diff drop, rear differential breather extension, oil filter drain hose, a/c drain hose extention & reroute, front window tint, cat theft protection plate, tailgate clamp mod, xpel headlight/foglight protecters, oem block heater, bfg 265/75R/16 a/t k/o's, cabin air rodent protection screen, rcbs illuminated 4X4 switch mod
    This should explain everything...then again maybe not. :rofl:
    http://www.tacomaworld.com/forum/2nd-gen-tacomas/64376-theres-car-key-blinking.html
     
To Top