1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

shifting - automatic transmission

Discussion in '2nd Gen. Tacomas (2005-2015)' started by michigantacoowner, Feb 24, 2010.

  1. Feb 24, 2010 at 6:39 PM
    #1
    michigantacoowner

    michigantacoowner [OP] Member

    Joined:
    Jul 22, 2007
    Member:
    #2185
    Messages:
    18
    Gender:
    Male
    SouthEast Michigan
    Vehicle:
    2010 DC 4 x 4
    Jason truck cap trailer two brake Excalibur remote car starter
    I have a 2010 Double Cab. It seems like when I slow down to turn a corner that many times the transmission seems to be in the wrong gear when I step back on the gas. Anyone else experiencing this?
     
  2. Feb 24, 2010 at 6:42 PM
    #2
    jandrews

    jandrews Carolina Alliance Southwest Region Ambassador

    Joined:
    Jun 7, 2009
    Member:
    #18122
    Messages:
    12,180
    Gender:
    Male
    Vehicle:
    '09 FourDubDee TRD OR
    A-TRUCK, Fat Kid in the Bed, Custom Pinstriping, Ported and Polished Muffler Bearing, Hi-Performance Bed Mat
    There's a TSB for it. Go to your dealer and reference TSB 0703-10 for them. It's a quick reflash of the tranny, takes 15 minutes at most, and should nuke the problem.
     
  3. Feb 24, 2010 at 6:53 PM
    #3
    sako243

    sako243 Active Member

    Joined:
    Dec 2, 2007
    Member:
    #3685
    Messages:
    27
    pennsylvaina
    Vehicle:
    2008 taco 4x4 off road v6
    scangaugell, bug deflector,
    my 2008 v6 does not shift fast enough after coming to a complete stop, the going down a hill. the tranny seams to hold back in 3rd and over reves the engine . is this the same problem you are having
     
  4. Feb 24, 2010 at 6:55 PM
    #4
    michigantacoowner

    michigantacoowner [OP] Member

    Joined:
    Jul 22, 2007
    Member:
    #2185
    Messages:
    18
    Gender:
    Male
    SouthEast Michigan
    Vehicle:
    2010 DC 4 x 4
    Jason truck cap trailer two brake Excalibur remote car starter
    Same problem.
     
  5. Feb 24, 2010 at 8:10 PM
    #5
    nuckinfuts

    nuckinfuts NyQuil on the rocks.

    Joined:
    Aug 31, 2009
    Member:
    #22064
    Messages:
    203
    Gender:
    Male
    Pacific NW
    Vehicle:
    '06 AC TRD Off-Road
    DT Long Tube Headers, Empire O2 simulator, catback, Shrockworks Sliders, Old Man Emu 3" lift with 885 coils (with 1/2" top plate spacer and Dakar Leaf packs), Hi-lift mounted in bed with 4XRAC mounts, WT floor liners, other stuffs
    Going downhill the auto will downshift if you tap the brakes, it provides engine braking so you're not riding the brakes all the way down. As for the not shifting when you come to a stop, not sure what to tell ya, maybe try the TSB.
     
  6. Feb 26, 2010 at 10:23 AM
    #6
    Chappyman

    Chappyman Member

    Joined:
    Feb 26, 2010
    Member:
    #32149
    Messages:
    6
    Gender:
    Male
    First Name:
    james
    Virginia
    Vehicle:
    Tacoma TRD OFFROAD
    I have the same problem with mine! Anyone know where i can get a copy of the TSB 0703-10
     
  7. Feb 26, 2010 at 11:02 AM
    #7
    PennTaco

    PennTaco New Member

    Joined:
    Feb 26, 2010
    Member:
    #32143
    Messages:
    3
    Gender:
    Male
    First Name:
    Bryon
    Charleston, SC
    Vehicle:
    09 TRD O/R AC
    Kenwood Head Unit, SWIC-Jack PS Controls, Removed Mudflaps, AFE Air Filter
  8. Feb 26, 2010 at 11:55 AM
    #8
    SRX

    SRX Well-Known Member

    Joined:
    Feb 4, 2010
    Member:
    #30723
    Messages:
    46
    Gender:
    Male
    Vehicle:
    2014 SR5 4x4
    Shaved mud flaps, Extra 4 D-rings in bed
    Does this apply to the TSB 0703-10?

    My 2008 also does this during braking downhill. It seems to always be between 30 and 40 mph. Downshifts, revs high, and upon reaching the bottom of the hill and resuming acceleration, it seems to "kick" into the next gear.
     
  9. Feb 26, 2010 at 6:51 PM
    #9
    roy826

    roy826 Well-Known Member

    Joined:
    Nov 10, 2009
    Member:
    #25738
    Messages:
    147
    Gender:
    Male
    Mississippi
    Vehicle:
    2010 Prerunner TRD Sport DC
    My '10 does this and I have had the TSB done. No more wrong gear selection on a slow speed turn now but that is all the TSB cured. At times it seems this truck does not know what to do. The accelerator pedal feels vague to me and the processing power in the electronics between transmission and engine seems sloooow on the response side of things. I work with computers for a living and I am here to tell you this system on the Tacoma ain't right. Mine will hang in 4th at times after getting back up to speed following a slow roll but not a complete stop. Then when it finally goes to 5th it is and abrupt shift up, very annoying. Confusion in the electronics is really bad on this thing.

    I hate this transmission in this truck!!! I have complained over and over about it to anyone who will listen at the dealership. Toyota dropped the ball on this truck IMO. My '00 Tundra and '02 Tacoma were better built trucks, nuff said.:rolleyes: Fault lies with me 100% on this since I had read all the transmission issues with the Tacoma since '05 and I still bought one after all that. What a dumbass I feel like now. What's next the accelerator pedal goes wide open. I am certainly feeling the love with this thing after only 3 1/2 months.
     
  10. Mar 10, 2010 at 3:08 PM
    #10
    sparksblade

    sparksblade New Member

    Joined:
    Mar 9, 2010
    Member:
    #32843
    Messages:
    2
    Gender:
    Male
    Vehicle:
    PreRunner

    Short story to this dilemma that has apparently been making the rounds.

    1. Feb 2010 - bought a new double cab Pre-Runner.
    2. soon noticed this hesitation/rev that you guys have been discussion.
    3. wondered if it was just me
    4. heard about Tacoma World website and read it
    5. Called local Toyota who seemed oblivious to the problem but scheduled a check.
    6. Went to Toyota with TW Documents in hand expecting a challenge
    7. Within 20 minutes tech guy said, yep, I have a TSB on this.
    8. Got truck back in no time and the problem is cured.

    HOWEVER, interesting, my copy indicates reference the older TSB used to resolve the problem.

    REGARDLESS, THANKS TO ALL OF YOU ON TW FOR HELPING ME FIND THE FIX.
     
  11. Mar 10, 2010 at 4:24 PM
    #11
    Isthatahemi

    Isthatahemi Well-Known Member

    Joined:
    Apr 29, 2009
    Member:
    #16582
    Messages:
    1,156
    Gender:
    Male
    Vehicle:
    TRD OFF ROAD
    BFG AT's, Weathertechs, Hoppy's brake controller.
    Strange. The TSB has been out for awhile, and trucks are still being bought with the problem. Toyota may want to be a little more pro-active on this one.
    Consider the number of people with no knowledge of this site, with oblivious dealers that give them a blank stare when the ask for some satisfaction on this issue.
    Not to mention, how did this mis-calibration even make it to the production line.
     
  12. Mar 10, 2010 at 5:52 PM
    #12
    Caddmannq

    Caddmannq MotoNerd

    Joined:
    Sep 1, 2008
    Member:
    #8917
    Messages:
    487
    Gender:
    Male
    California
    Vehicle:
    2012 PreRunner TRD Sport DC LB
    Undercover toneau
    Has anybody noticed increased idle speed after doing this TSB?
     
  13. Mar 10, 2010 at 6:36 PM
    #13
    sparksblade

    sparksblade New Member

    Joined:
    Mar 9, 2010
    Member:
    #32843
    Messages:
    2
    Gender:
    Male
    Vehicle:
    PreRunner
    I've not notice anything negative. I am actually very happy with the fix. It has taken the worry out. I do agree with the earlier post, you would have thought that Toyota would have had the TSB and fix completed even before I bought it. When I made the original schedule call they seemed to imply that I just might not be "used to a Toyota" yet.

    The fix is a dramatic improvement in my Taco and I am finally relaxed after making the purchase.
     
  14. Mar 10, 2010 at 6:41 PM
    #14
    MNTaco

    MNTaco Newbee

    Joined:
    Jan 23, 2010
    Member:
    #29891
    Messages:
    74
    Gender:
    Male
    Twin Cities, MN
    Vehicle:
    2010 DoubleCab TRD Sport Long-Bed
    Bet mat, bug shield, running boards, tonneau cover
    I need to get this done to by 2010 TRD Sport Long Bed. It's really annoying.
     
  15. Mar 11, 2010 at 3:59 AM
    #15
    grammy

    grammy Well-Known Member

    Joined:
    Jun 7, 2008
    Member:
    #7158
    Messages:
    210
    Gender:
    Male
    Newfoundland, Canada
    Vehicle:
    4x4 v6 X-Cab
    These new transmission suck. I had the reflash and it is better, but does not shift as it should.
     
  16. Mar 11, 2010 at 4:29 AM
    #16
    dog tired

    dog tired Well-Known Member

    Joined:
    Jan 21, 2010
    Member:
    #29750
    Messages:
    465
    Gender:
    Male
    NE Ohio
    Take it out of over drive - or in other words shift into gear 4 I think a few folks are having a problem as the tranny searches for the best gear to go into. Other vehicles other than Toyo do this also with the same solution, if you are in that between area where the trans is searching for the proper gear , shift into a gear that does not have over drive
     
  17. Mar 11, 2010 at 5:51 AM
    #17
    roy826

    roy826 Well-Known Member

    Joined:
    Nov 10, 2009
    Member:
    #25738
    Messages:
    147
    Gender:
    Male
    Mississippi
    Vehicle:
    2010 Prerunner TRD Sport DC
    I totally agree with this statement. I to had the re-flash and I still do not liek the manner of which this transmission shifts and thinks on it's own I might add. They call it an adaptive transmission. Adaptive to what? it certainly does not do what I want it to. Rubbery feeling shifts, slipping, up and down or should I say almost up and sometimes maybe down. 5th gear at 35 mph:rolleyes: crazy stuff I am really starting to hate. I loved Toyota's until I bought this truck. It is turning me against Toyota everyday I drive it. Seriously considering a trade for a more conventional transmission truck.
     
  18. Mar 11, 2010 at 11:55 AM
    #18
    dbarn

    dbarn Well-Known Member

    Joined:
    Feb 18, 2010
    Member:
    #31641
    Messages:
    203
    Gender:
    Male
    Texas
    Vehicle:
    Tacoma 4X4 V6
    My 2010 was having a shift problem as well. Mainly it would hang up in low gear turning slowly and then accelerating. I did not notice until I had the reflash done but it was shifting oddly at other speeds as well. Now that the TSB has been done, the difference is night and day. Much smoother shifting. Have also noticed a 3/4 to 1 mpg improvement. I have to wonder if the reflash has not been done correctly for those it did not help. Have 6000 miles on mine and am also finally ejoying my Taco. A big improvement, but also wonder why Toyota would let it leave the factory like this??? My dealer also had a blank look on his face or they are probably playing dumb. Most likely the latter.
     
  19. Mar 11, 2010 at 12:14 PM
    #19
    chip01822

    chip01822 Well-Known Member

    Joined:
    Jan 24, 2010
    Member:
    #29932
    Messages:
    58
    Gender:
    Male
    First Name:
    chip
    kentucky
    Vehicle:
    11 DC 4x4 sport
    window tint (35% ky law) westin stepbars, in channel vents, bed mat, bed extender
    I had the same problem on my 09 took it in to the dealer armed with the tsb that was provided to me from the great folks on here. they reflashed cpu and its been doing great since
     
  20. Mar 11, 2010 at 12:26 PM
    #20
    twr437

    twr437 Well-Known Member

    Joined:
    Nov 11, 2009
    Member:
    #25804
    Messages:
    173
    Gender:
    Male
    First Name:
    Tim
    East Texas
    Vehicle:
    08 TRD Sport 4x4 LB
    nerf bars, bed cover, husky liners, Icon coilovers, LR UCA, rear 5100s, TSB AAL, diff drop, carrier baring drop, axel shims, AFE pro dry filter, BHLM, mesh grill, Black emblems,
    did they get anything right with the 2gen tacoma???

    -suspension way to soft
    -tranny won't shift right
    -engine sounds like s%#*

    toyota is really pissing me off[​IMG]

    that ford raptor sounds better and better every day.
     
To Top