1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

SmittyBilt XRC* Owners Manual - Exploded View

Discussion in 'Technical Chat' started by HBMurphy, Feb 21, 2010.

  1. Feb 21, 2010 at 5:23 PM
    #1
    HBMurphy

    HBMurphy [OP] Ban Pending

    Joined:
    Jun 27, 2009
    Member:
    #18993
    Messages:
    6,090
    Gender:
    Male
    First Name:
    Paul
    So California Coast
    Vehicle:
    09 Off Road Delete Model
    None
    Help!!!

    Does anyone have a copy of the onwers manual for a SmittyBilt XRC 8?

    Thank you, thank you, thank you...
     
  2. Feb 21, 2010 at 8:02 PM
    #2
    HBMurphy

    HBMurphy [OP] Ban Pending

    Joined:
    Jun 27, 2009
    Member:
    #18993
    Messages:
    6,090
    Gender:
    Male
    First Name:
    Paul
    So California Coast
    Vehicle:
    09 Off Road Delete Model
    None
    Here it is... SmittyBilt XRC 8 Owners Manual still having a bitch with getting this thing going.... first a solenoid (my fault). Then they thought it was a lever arm - they sent me one and another end cap and I replaced and still no luck! :( Now they've sent me a new gear box and still no luck. I guess I could say this thing sucks but I am still going to :frusty: and call them again tomorrow. One thing is for sure - I will be able to rebuild one of these puppies in my sleep!!! :rolleyes: Would I recommend one? :laugh:
     
  3. Feb 21, 2010 at 10:17 PM
    #3
    HBMurphy

    HBMurphy [OP] Ban Pending

    Joined:
    Jun 27, 2009
    Member:
    #18993
    Messages:
    6,090
    Gender:
    Male
    First Name:
    Paul
    So California Coast
    Vehicle:
    09 Off Road Delete Model
    None
    Okay so it's only me in here... I'll update anyway.... Winch is working fine and I have graduated from Smittybilt winch school! :) Most recent problem was the preloaded postition of the brake... I think I have it right now. I will test in the morning to see if the brake holds now. The last time I put it back together the brake was locked on and it wouldn't free spool and if I tried to move the spool in or out with the motor it would not budged - well at least I didn't fry my battery!
     
To Top