1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Somebody can help?

Discussion in '1st Gen. Tacomas (1995-2004)' started by silverboy, Jun 4, 2010.

  1. Jun 4, 2010 at 12:57 PM
    #1
    silverboy

    silverboy [OP] Member

    Joined:
    May 17, 2010
    Member:
    #37331
    Messages:
    19
    Gender:
    Male
    I have a 2001 Toyota tacoma, and I have like a pinging noise coming from the engine, I took it to the dealer and they only found the my o sensor it was dirty and they cleaned and they call me to pick up the truck and drive testedand still doing the same noise anybody have the same problem. Thanks for the opinions. Somebody on here told me the PWM valve? and ECU reflash?:confused::confused:
     
  2. Jun 4, 2010 at 1:06 PM
    #2
    mak90

    mak90 Well-Known Member

    Joined:
    Nov 4, 2009
    Member:
    #25411
    Messages:
    341
    Gender:
    Male
    Central Coast, Ca.
    Vehicle:
    06 Tacoma 4x4 TRD Off Road
    TRD Exhaust, TSB springs,Weathertech mats,Bed mat, Wet Okole seat covers
    If your truck has a timing chain you might want to check and see if it needs to be replaced. My old truck use to make a noise that sounded like it was pinging but turned out the chain needed to be replaced.
     
  3. Jun 4, 2010 at 2:09 PM
    #3
    silverboy

    silverboy [OP] Member

    Joined:
    May 17, 2010
    Member:
    #37331
    Messages:
    19
    Gender:
    Male
    Thanks for your opinion because I just got the truck like for a month and has 124 000miles on it , I will check into that,but my truck has timing belt.
     
  4. Jun 4, 2010 at 2:35 PM
    #4
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,121
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Can you give more info on your truck? 4x4? Extended cab?
     
  5. Jun 4, 2010 at 2:57 PM
    #5
    humanoid

    humanoid bite me

    Joined:
    Jun 27, 2007
    Member:
    #1932
    Messages:
    2,744
    Gender:
    Male
    Sunny SoCal
    Vehicle:
    I had a '99 Xtra Cab PreRunner SR5 V6
    V6 or I4? 5 lug mini or 6 lug 4x4 PreRunner? Fill out your profile so we don't have to ask you every time you have a question.
     
  6. Jun 4, 2010 at 2:57 PM
    #6
    silverboy

    silverboy [OP] Member

    Joined:
    May 17, 2010
    Member:
    #37331
    Messages:
    19
    Gender:
    Male
    is 2X4,xtrcab somebody told me it can be a knock sensor,but dealer said that is good,some body said there is a plastic valve that you replace and the pinging noise should go away but i dont know much about it. is V6 engine 3.4L is prerunner.
     
To Top