1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Spedo Fail

Discussion in 'Technical Chat' started by krzfastest2010, Dec 12, 2010.

  1. Dec 12, 2010 at 1:58 PM
    #1
    krzfastest2010

    krzfastest2010 [OP] Active Member

    Joined:
    Sep 7, 2010
    Member:
    #42894
    Messages:
    33
    Gender:
    Male
    First Name:
    Tyler
    Seattle
    Vehicle:
    01 sr5 v6 lifted
    Hey guys last night I was driving down the pass and my spedometer started goin crazy. my first thought was somthing was shorting out beacuse it was raining so hard there was standing water every where. and now my spedometer works on and off.
    What are your thoughts on this?
     
  2. Dec 12, 2010 at 2:03 PM
    #2
    SuthrnTaco07

    SuthrnTaco07 Well-Known Member

    Joined:
    Jul 23, 2009
    Member:
    #20053
    Messages:
    2,676
    Gender:
    Male
    First Name:
    Kyle
    Huntsville, AL
    Vehicle:
    2003 T4R SR5 V8 4wd
    None
    I have an 07... Good luck with the answer... I'm going to try and check my grounds... Let me know if anything else goes wrong on it.. After my speedo went a few other things did to!
     
To Top