1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Speedometer bouncing

Discussion in '1st Gen. Tacomas (1995-2004)' started by buzzboy, Jul 28, 2010.

  1. Jul 28, 2010 at 11:23 PM
    #1
    buzzboy

    buzzboy [OP] Member

    Joined:
    Apr 30, 2010
    Member:
    #36308
    Messages:
    24
    Gender:
    Male
    san diego
    Vehicle:
    2001 Creampuff
    2 into 1 lighter adapter!
    I have a 95 tacoma with a malfunctioning speedometer. At highway speed it bounces back and forth. For example, if I'm at 65 mph the speedo twitches quickly between 60 and 75 mph.

    In a possibly related issue, the cruise contol bucks/lurches whiile on the freeway. Thinking the speedo problem is causing the c/c problem? Sometimes the c/c even turns off. Heard the speedo fix is a little expensive due to the labor involved? I couldn't find any closely related threads in the search, does anyone have any info on repair costs and if the 2 issues may be related?
     
  2. Jul 28, 2010 at 11:39 PM
    #2
    AKTacoma

    AKTacoma Dedicated Crew Chief

    Joined:
    Jun 2, 2010
    Member:
    #38279
    Messages:
    374
    Gender:
    Male
    First Name:
    Chris
    Houma, Louisiana
    Vehicle:
    08 Tacoma DCLB
    could be a speed sensor or your speedometer going bad for the speedometer. For the c/c issue, maybe the c/c module
     
  3. Jul 29, 2010 at 8:12 AM
    #3
    Tacorunner87

    Tacorunner87 Well-Known Member

    Joined:
    Apr 13, 2010
    Member:
    #35217
    Messages:
    977
    Gender:
    Male
    First Name:
    Chris
    Chino Hills Ca
    To much to list!
    On a 95 the speed sensor is mechanical. unlike the newer ones.It may be an easy fix.
     
  4. Jul 29, 2010 at 5:32 PM
    #4
    kevhogaz

    kevhogaz Low Speed, High Drag

    Joined:
    Sep 6, 2008
    Member:
    #9055
    Messages:
    323
    Gender:
    Male
    Queen Creek, Arizona
    Vehicle:
    SR5 PreRunner
    3" lift front & rear, Air Raid Intake System
    Sounds like you need a speedo cable, to me. Should be real easy to replace.

    Pull out the cluster, and unscrew the cable.
    Unscrew cable from trans.
    Unbolt the cable from the various brackets.
    Route old cable out of cab.
    Install in reverse order.
     
  5. Jul 30, 2010 at 8:29 AM
    #5
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,780
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
To Top