1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

speedometer light out

Discussion in 'Lighting' started by rv210, Feb 17, 2011.

  1. Feb 17, 2011 at 4:59 PM
    #1
    rv210

    rv210 [OP] Well-Known Member

    Joined:
    Aug 23, 2010
    Member:
    #42122
    Messages:
    137
    Gender:
    Male
    First Name:
    robert
    san antonio
    Vehicle:
    ***HAD***05 quadcab 4x4 taco
    bed cover, piaa led's, bfg a/t tires,17' pro comp 6089 rims,billies 5100's in front set at 1.75'
    so i need some assistance with my Tacoma. I do not have any idea on how to fix and i have checked every single fuse and none are blown. My speedometer light (orange light) and my accessory buzzer are both not functioning at this time. i took it to Best Buy this week and the techs there did not even charge me for their time because they could not fix it. Somebody please help!
     
  2. Feb 21, 2011 at 12:31 PM
    #2
    rv210

    rv210 [OP] Well-Known Member

    Joined:
    Aug 23, 2010
    Member:
    #42122
    Messages:
    137
    Gender:
    Male
    First Name:
    robert
    san antonio
    Vehicle:
    ***HAD***05 quadcab 4x4 taco
    bed cover, piaa led's, bfg a/t tires,17' pro comp 6089 rims,billies 5100's in front set at 1.75'
    I guess no one knows the answer to my question. Thanks for all the help fellow Tacoma owners!:confused:
     
  3. Feb 21, 2011 at 12:38 PM
    #3
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,857
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    If it is just the speedometer that isn't lit up, the you have a bad LED in the cluster. Do all of the other lights light up? P,R,N,D, Tach, etc?
     
  4. Feb 21, 2011 at 12:53 PM
    #4
    rv210

    rv210 [OP] Well-Known Member

    Joined:
    Aug 23, 2010
    Member:
    #42122
    Messages:
    137
    Gender:
    Male
    First Name:
    robert
    san antonio
    Vehicle:
    ***HAD***05 quadcab 4x4 taco
    bed cover, piaa led's, bfg a/t tires,17' pro comp 6089 rims,billies 5100's in front set at 1.75'
    thanks for the response. The light indicator comes on as well as the turn signals but the orange light and the beeping noise both do not work. it is a 6 speed so there is no light for each gear.
     
  5. Feb 21, 2011 at 1:00 PM
    #5
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,857
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    When you first turn the truck key to the ON position, do any of the lights illuminate in the combination meter?
     
  6. Feb 21, 2011 at 1:37 PM
    #6
    rv210

    rv210 [OP] Well-Known Member

    Joined:
    Aug 23, 2010
    Member:
    #42122
    Messages:
    137
    Gender:
    Male
    First Name:
    robert
    san antonio
    Vehicle:
    ***HAD***05 quadcab 4x4 taco
    bed cover, piaa led's, bfg a/t tires,17' pro comp 6089 rims,billies 5100's in front set at 1.75'
    nothing lights up except for the green light when i have my headlights turned on otherwise nothing else lights up on the speedometer, temp. or the fuel.
     
  7. Feb 21, 2011 at 4:52 PM
    #7
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,857
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    You might want to check the 7.5 amp gauge fuse again.
     
To Top