1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Speedometer problem

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Bretsuaz48, May 17, 2010.

  1. May 17, 2010 at 9:20 AM
    #1
    Bretsuaz48

    Bretsuaz48 [OP] Well-Known Member

    Joined:
    Apr 14, 2010
    Member:
    #35261
    Messages:
    332
    Gender:
    Male
    First Name:
    Bret
    Surprise, Arizona
    Vehicle:
    2016 Sport
    My speedometer has been off since I bought this truck. But I figured it was the tires. Then last week, I noticed that the speedometer was not going back to 0 when stopping. It seems to be getting worse. It is now at 15 mph when stopped. I know that in the GM products, rapidly cycling the key of and on will put the speedometer back to zero. Any fixes or advise appreciated.

    I did do a search and found alot of info on other problems, but could not find this one. If there is a thread on this, can someone point me in the right direction.


    Thanks,

    Bret
     
  2. May 17, 2010 at 9:28 AM
    #2
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,741
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
To Top